Sorry, you need to enable JavaScript to visit this website.

Do not use with Ubuntu 14.04

23 posts / 0 new
Joe Konno's picture
Starter
Joe Konno

Mar 18, 2015 - 08:02am

  • Hey gang,

    Long story short, do not use the Graphics Installer with Ubuntu 14.04. As of Ubuntu 14.04.2, folks began to experience difficulties when using the Graphics Installer. We understand the causes of these difficulties-- they are similar to those seen in the last "LTS" release, Ubuntu 12.04. Ubuntu 14.04 is an "LTS" release-- this and future LTS releases will challenge us for similar reasons. I'll spare you the details, as they involve packaging minutiae.

    As a preventive measure I am considering obsoleting (disabling) Ubuntu 14.04 altogether for the Graphics Installer-- I will update this post if and when I do. If I do, a change will be made on the "server side" (download.01.org) which will prevent users of Ubuntu 14.04 from running the Graphics Installer. Normally, we obsolete Fedora or Ubuntu versions once they are "two behind" the current release. For example, Fedora 19 became obsolete when Fedora 21 was released. But, in the best interest of users, I may have to obsolete (disable) 14.04 altogether.

    The standing recommendation is: do not use the Graphics Installer with Ubuntu 14.04-- first upgrade to Ubuntu 14.10 and then run the Graphics Installer.

    Cheers-- I will update this post with any actions I take.

    UPDATE 18 March 2015 09:15 UTC-7: I have made the necessary change-- the Graphics Installer will no longer function on Ubuntu 14.04. Due to a variety of network factors, it may take up to 48 hours for this change to take effect. Users of Fedora or Ubuntu 14.10 should not be impacted. No additional software updates will be required.

    Mar 18, 2015 - 08:02am
  • Is there another thread or page or bug reeports with discussion on the exact issues?  (Or of the issues you had with 12.04?)    Will it be completely impossible to use all versions of Graphics Installer with 14.04, or would it be possible with some additional manual steps, recognizing the potential problems, in case some of them end up not being relevant to specific systems or hardware?

    Thanks

     

    Mar 19, 2015 - 07:49am
  • The details are here:

    https://01.org/linuxgraphics/comment/1157#comment-1157

    Mar 20, 2015 - 09:52am
  • <p>This link appears to be dead.&nbsp; Is there a valid link to this information?</p>

    May 26, 2015 - 09:02pm
  • Hello,

    I'm running Ubuntu 14.04.2 LTS and I previously intalled the Graphics Installer( before you make it not working anymore for 14.04.2 users). What should I do now? Should I have to keep what has been done or not? 

    And if I am suppose to remove installed packages and revert back to Ubuntu original ones, how can I do it? I haven't find any uninstaller or documentation about how to do.

    Plese note that I can't upgrade to Ubuntu 14.10.

    Thanks!

     

    Mar 25, 2015 - 05:55am
  • Reply to myself for comment: If I find all installed Intel repository packages, and reinstall them at last previous version number (so last version coming from Ubuntu repositories), shoud it be OK to uninstall Intel repository drivers?

    Of course I would prefer the project to build and share new compatible packages (maybe playing with apt pinning instead of version numbers?)

    Please give me comments,

    thanks

     

     

    Mar 26, 2015 - 07:29am
  • Ok so I follow this: https://gist.github.com/phdelodder/b28e8df770a6bc020aab

    Then purging extra packages installed by Intel installer (as far as I saw in the apt's log).

    Sad to not purpose a wayback in the installer: intel drivers are far more complicated rather nvidia drivers. 

    Mar 27, 2015 - 10:17am
  • Hi. Sorry to leave it so long before getting back to you - I've been away for a few days.
    We did initially have plans for a downgrade option but feedback from initial testing
    (especially when people had lots of PPAs enabled) indicated that it was too error prone,
    especially given that the target audience is towards the "beginner" end of the spectrum.

    Now that we know what's going on with the LTS releases, we're going to tweak the installer
    so that users don't end up with their systems i nthis state in the first place.

    Mar 31, 2015 - 07:23am
  • Thanks for you reply.

    I understand why you don't purpose a downgrade option but as the contrary was said somewhere on the forum (it was writen that we may uninstall) it could be important to write it in the annoncement or before user downloding it.

    Apr 01, 2015 - 08:25am
  • That would be great if there was a solution.

    Would it work to simply fail if the utopic backports are installed, but work if they are not?  This is of course not the best solution going forward since it prevents people from doing normal upgrades on the rest of the system but it provides a way to have it work for now.

     

     

    Mar 31, 2015 - 08:16am
  • Possibly - I foresee some long meetings where we thrash out the pros and cons of various aproaches. We might well settle on something like the approach you suggest, I just don't know yet.

    Apr 07, 2015 - 12:35pm