Sorry, you need to enable JavaScript to visit this website.

New Ubuntu 16.04 packages use unknown key (again)

59 posts / 0 new
Martin van Es's picture
Starter
Martin van Es

Aug 31, 2016 - 02:20am

  • I never experienced before that I had to manually add a key for an installed package. So this looks like a workaround to me. Can't this be done automatically when installing the deb?

    Oct 13, 2016 - 06:40am
  • You could do this thing, but think about it: It would make no sense. If the verifying key is part of the package, then _any_ package can supply a key, and the verification means nothing. You, as the user, have to decide you trust a key. That's how public key cryptography works. And you haven't had to install a key before because you've either been installing unsigned packaged, or you've been installing packages from the distribution itself (which comes pre-seeded with the official distribiution keys).

    So no - it's not a workaround. It's how public key cryptography in general (and package signing in particular) works.
    And no - the key can't be part of the package - that would make the package signature meaningless.

    Oct 18, 2016 - 08:51am
  • I have installed Chrome, Google Talk Plugin and Opera via a .deb package for example. Might be true that they are not signed.

    Oct 19, 2016 - 02:05am
  • Same problem. tried the above, didn't help.

     
    W: GPG error: https://download.01.org/gfx/ubuntu/16.04/main wily InRelease: The following signatures couldn't be verified because the public key is not available: NO_PUBKEY 2CC2A1B90A3B3268
    W: The repository 'https://download.01.org/gfx/ubuntu/16.04/main wily InRelease' is not signed.
     

     

     

    Please advise

    Thank you

     

     

    Oct 12, 2016 - 04:07am
  • I am having this error on Ubuntu 16.04 myself.

     

    I even posted about this on askubuntu, yet there is no conclusive answer to the package problem. http://askubuntu.com/questions/836069/intel-graphics-update-tool-for-lin...

     

    Is there any fix coming? I need to be able to run the tools on my new Ubuntu!

    Oct 15, 2016 - 12:30pm
  • Is anyone here? We need a solution to this thing!

    Oct 18, 2016 - 03:44am
  • Have you tried installing the key as instructed here: https://01.org/linuxgraphics/downloads/intel-graphics-update-tool-linux-os-v2.0.2 ?

    Oct 18, 2016 - 08:52am
  • When I run "sudo apt-get update", the following error appears:

     

    Ign:21 http://ppa.launchpad.net/upubuntu-com/ppa/ubuntu xenial/main DEP-11 64x64 Icons
    Reading package lists... Done
    W: The repository 'http://ppa.launchpad.net/upubuntu-com/ppa/ubuntu xenial Release' does not have a Release file.
    N: Data from such a repository can't be authenticated and is therefore potentially dangerous to use.
    N: See apt-secure(8) manpage for repository creation and user configuration details.
    W: https://download.01.org/gfx/ubuntu/16.04/main/dists/xenial/InRelease: Signature by key 09D6EF97BFB38E916EF060E756A3DEF863961D39 uses weak digest algorithm (SHA1)
    E: Failed to fetch http://ppa.launchpad.net/upubuntu-com/ppa/ubuntu/dists/xenial/main/binar...  404  Not Found
    E: Some index files failed to download. They have been ignored, or old ones used instead.
     

    Same error as I get when I run the packge tool. There is a huge problem here with your key, nothing else so far. It prevents us from moving forward.

    Oct 19, 2016 - 12:31pm
  • 1) I added this exact command: wget --no-check-certificate https://download.01.org/gfx/RPM-GPG-KEY-ilg-4 -O - | sudo apt-key add -

    This worked.

     

    2) I run the Ubuntu Intel Graphics Update Tool for Linux OS

     

    This keeps failing.

     

    3) I re-read the entire thread in here again. Everyone keeps going in circles here. You keep saying the signature is not a problem, as its just a weak signature, which I agree with, but the Intel tool still fails to finish the process, thereby making the entire tool obsolete.

     

    4) These are the final messages I am able to get within the Intel application:

    Ensuring consistent system... OK
    Listing packages... OK
    Setting up repositories... OK
    Installing packages...
        Updating package cache... Failed
     

    There simply must be a way to get this working on Ubuntu 16.04 after all this time. Please help, some of us have huge problems with graphics on Ubuntu and need this resolved.

    Oct 19, 2016 - 12:55pm
  • So far every log I've seen of the thing failing has a line like this in it:

    E: Failed to fetch http://ppa.launchpad.net/upubuntu-com/ppa/ubuntu/dists/xenial/main/binar... 404 Not Found

    Note that this is a) an error and b) a PPA whhich has nothing to do with 01.org. The update tool can't work if the apt configuration is
    invalid. If you are seeing errors like this, you need to fix them before the tool can work.

    Nov 08, 2016 - 08:47am