Sorry, you need to enable JavaScript to visit this website.

Primary tabs

Ubuntu Intel Graphics update tool Error

8 posts / 0 new
01 Staff's picture
01 Staff (not verified)

Oct 22, 2016 - 11:36pm

  • torshammer001's picture
    torshammer001 (not verified)

    Welcome to the issue that we all have. There is a 4 page thread right here:


    No response from Intel, no action, nothing! This affects more users than they realize. 

    Oct 24, 2016 - 08:00am
  • nutcracker's picture
    nutcracker (not verified)

    Thanks for the response.


    BUT, now it is giving me a different error when trying the Intel installer:


    So I did all the NOTES: Key, update & upgrade


    I have an intel i5 w/ Intel HD graphics (1000)


    I installed:

    Install the package with the following command: for Ubuntu* 16.04 (64 bits)

    sudo gdebi intel-graphics-update-tool_2.0.2_amd64.deb

    Install the package with the following command: for Ubuntu* 16.04 (32 bits)

    sudo gdebi intel-graphics-update-tool_2.0.2_i386.deb

    And I ran:




    Some installed packages seem to be broken.
    You might want to run "sudo apt-get -f install" in a terminal to correct the problems.


    So I check:

    Reading package lists... Done
    Building dependency tree       
    Reading state information... Done
    You might want to run 'apt-get -f install' to correct these.
    The following packages have unmet dependencies:
     intel-graphics-update-tool:i386 : Depends: ttf-ancient-fonts:i386 but it is not installable
                                       Depends: aptdaemon:i386 but it is not installable
                                       Recommends: libproxy1-plugin-webkit:i386 (>= 0.4.7) but it is not installed
    E: Unmet dependencies. Try using -f.


    RUNNING -f install:


    sudo apt-get -f install
    Reading package lists... Done
    Building dependency tree       
    Reading state information... Done
    Correcting dependencies... Done
    The following packages were automatically installed and are no longer required:
      fonts-ancient-scripts gcc-5-base:i386 glib-networking:i386
      libatk-bridge2.0-0:i386 libatk1.0-0:i386 libatspi2.0-0:i386
      libavahi-client3:i386 libavahi-common-data:i386 libavahi-common3:i386
      libboost-filesystem1.58.0:i386 libboost-system1.58.0:i386 libbsd0:i386
      libcairo-gobject2:i386 libcairo2:i386 libcolord2:i386 libcups2:i386
      libdatrie1:i386 libdbus-1-3:i386 libdrm-amdgpu1:i386 libdrm-intel1:i386
      libdrm-nouveau2:i386 libdrm-radeon1:i386 libdrm2:i386 libedit2:i386
      libegl1-mesa:i386 libelf1:i386 libepoxy0:i386 libexpat1:i386 libffi6:i386
      libfontconfig1:i386 libfreetype6:i386 libgbm1:i386 libgdk-pixbuf2.0-0:i386
      libgl1-mesa-dri:i386 libglib2.0-0:i386 libgmp10:i386 libgnutls30:i386
      libgraphite2-3:i386 libgssapi-krb5-2:i386 libgtk-3-0:i386 libharfbuzz0b:i386
      libhogweed4:i386 libicu55:i386 libidn11:i386 libjbig0:i386
      libjpeg-turbo8:i386 libjpeg8:i386 libjson-glib-1.0-0:i386 libk5crypto3:i386
      libkeyutils1:i386 libkrb5-3:i386 libkrb5support0:i386 liblcms2-2:i386
      libllvm3.8:i386 libmirclient9:i386 libmircommon5:i386 libmirprotobuf3:i386
      libnettle6:i386 libp11-kit0:i386 libpackagekit-glib2-16:i386
      libpango-1.0-0:i386 libpangocairo-1.0-0:i386 libpangoft2-1.0-0:i386
      libpciaccess0:i386 libpixman-1-0:i386 libpng12-0:i386
      libpolkit-gobject-1-0:i386 libprotobuf-lite9v5:i386 libproxy1v5:i386
      librest-0.7-0:i386 libsoup-gnome2.4-1:i386 libsoup2.4-1:i386
      libsqlite3-0:i386 libstdc++6:i386 libtasn1-6:i386 libthai0:i386
      libtiff5:i386 libtxc-dxtn-s2tc0:i386 libwayland-client0:i386
      libwayland-cursor0:i386 libwayland-egl1-mesa:i386 libwayland-server0:i386
      libx11-6:i386 libx11-xcb1:i386 libxau6:i386 libxcb-dri2-0:i386
      libxcb-dri3-0:i386 libxcb-present0:i386 libxcb-render0:i386 libxcb-shm0:i386
      libxcb-sync1:i386 libxcb-xfixes0:i386 libxcb1:i386 libxcomposite1:i386
      libxcursor1:i386 libxdamage1:i386 libxdmcp6:i386 libxext6:i386
      libxfixes3:i386 libxi6:i386 libxinerama1:i386 libxkbcommon0:i386
      libxml2:i386 libxrandr2:i386 libxrender1:i386 libxshmfence1:i386
      packagekit-backend-aptcc packagekit-tools python3-packagekit
    Use 'sudo apt autoremove' to remove them.
    The following packages will be REMOVED:
    0 upgraded, 0 newly installed, 1 to remove and 12 not upgraded.
    1 not fully installed or removed.
    After this operation, 193 kB disk space will be freed.
    Do you want to continue? [Y/n] y
    (Reading database ... 216637 files and directories currently installed.)
    Removing intel-graphics-update-tool:i386 (2.0.2) ...
    Processing triggers for bamfdaemon (0.5.3~bzr0+16.04.20160824-0ubuntu1) ...
    Rebuilding /usr/share/applications/bamf-2.index...
    Processing triggers for gnome-menus (3.13.3-6ubuntu3.1) ...
    Processing triggers for desktop-file-utils (0.22-1ubuntu5) ...
    Processing triggers for mime-support (3.59ubuntu1) ...


    Apparently I do not need the i386? Now my intell installer is gone.

    Oct 24, 2016 - 10:34pm
  • nutcracker's picture
    nutcracker (not verified)

    Ok i read that thread you gave me and saw this:


    "Please add  for  Xenial Release"


    How do i do that?

    Oct 26, 2016 - 06:12am
  • fledermaus's picture
    fledermaus (not verified)

    The instructions are here:

    wget -O - | sudo apt-key add -

    Nov 08, 2016 - 08:34am
  • torshammer001's picture
    torshammer001 (not verified)

    Thats the problem we are facing. If you add that key, it wont work because the software provided by Intel does not recognize the added key as secure. We are stuck until Intel fixes their key.

    Nov 03, 2016 - 09:22am
  • fledermaus's picture
    fledermaus (not verified)

    The entries marked "W: …" are warnings - they shouldn't stop anything from working. One of them is about the signature on the package being made with the SHA1 digest, which has recently been deprecated (ie it is in the process of being phased out - it isn't invalid, but at some date in the future it will be considered so). The other warnings are mostly about invalid PPA repositories (software sources) which are nothing to do with Intel or - including some errors (marked "E: …") about some PPAs you have configured. Removing the invalid PPAs from your configuration (in particular the ones marked "E: ") should allow things to work.

    Nov 08, 2016 - 08:29am
  • nutcracker's picture
    nutcracker (not verified)

    Ok, so what is the command to remove the reported PPA E errors??

    Nov 18, 2016 - 10:05pm
  • fledermaus's picture
    fledermaus (not verified)

    Instructions for removing PPAs (may also be described as "software sources") can be found here:

    Nov 22, 2016 - 05:44am