Sorry, you need to enable JavaScript to visit this website.

Details

Release Date: 
May 10, 2018

Intel® Software Guard Extensions SDK

PRODUCT CONTENTS

Intel® Software Guard Extensions SDK package includes:

  • An Intel® Software Guard Extensions SDK installer for Linux* OS. It includes binaries to develop enclave applications. The main components include:
    • Trusted libraries, including standard C library, C++ runtime support, C++ STL, and others
    • Development tools, including edger8r, signing tool, and others
    • Sample projects

WHAT’S NEW

  • Updated the cryptography library to Intel® Integrated Performance Primitives Cryptography 2018 Update 2.1. Mitigated security vulnerability CVE-2018-3617. For more details, refer to Security Advisory INTEL-SA-00106 and INTEL-SA-00135.
  • Provided enhancements to the Intel® SGX Cryptographic library.
  • Support for Intel® SGX Protected Code Loader (Intel® SGX PCL) - It is intended to protect Intellectual Property (IP) within the code for Intel® SGX enclave applications.
  • Bug fixes.

SYSTEM REQUIREMENTS

SOFTWARE REQUIREMENTS

Supported Linux OS distributions:

  • Ubuntu* 16.04 LTS 64-bit Desktop version
  • Ubuntu* 16.04 LTS 64-bit Server version
  • Red Hat* Enterprise Linux* Server 7.4 (for x86_64)
  • CentOS* 7.4 (for x86_64)
  • SUSE* Enterprise Server 12 (for x86_64)

Note: It is highly recommended to use the listed Linux* OS distributions. Other distributions have not been tested.

KNOWN ISSUES AND LIMITATIONS

  • Intel® SGX for Linux* OS does not support setting a different charset in GNU* Project Debugger (GDB*).
  • Building the Intel SGX SDK sample project “RemoteAttestation” is possible only within the Intel SGX SDK installation folder.
  • Intel SGX does not support the “long long” type in C++ templates.
  • sgx-gdb depends on GDB* 7.9.1 or later versions. Please upgrade GDB* if it is lower than 7.9.1.

 

Intel® Software Guard Extensions Platform Software

PRODUCT CONTENTS

Intel® Software Guard Extensions PSW package includes:

  • Intel® SGX Application enclaves
  • Intel® SGX Runtime System Library
  • Intel® SGX Application Enclave Service Manager (AESM)

WHAT’S NEW

Intel® Software Guard Extensions PSW includes the following changes in this release:

  • Update the cryptography library to Intel® Integrated Performance Primitives Cryptography 2018 Update 2.1. Mitigated security vulnerability CVE-2018-3617. For more details, refer to Intel Security Advisory INTEL-SA-00106 and INTEL-SA-00135.
  • Update Intel® SGX platform service Dal applet.
  • Bug fixes.

SYSTEM REQUIREMENTS

HARDWARE REQUIREMENTS

  • 6th Generation Intel® Core™ Processor or newer

SOFTWARE REQUIREMENTS

Supported Linux* OS distributions:

  • Ubuntu* 16.04 LTS 64-bit Desktop version
  • Ubuntu* 16.04 LTS 64-bit Server version
  • Red Hat* Enterprise Linux* Server 7.4(for x86_64)
  • CentOS* 7.4 (for x86_64)
  • SUSE* Enterprise Server 12 (for x86_64)

Note:

  • Intel® SGX PSW supports Intel® Xeon® Processor E3 Server V5 and onwards platforms if the platform processor and BIOS supports Intel® SGX. Please check with OEM/ODM regarding BIOS support for enabling Intel® SGX
  • Intel® SGX platform service is not supported in Intel® Xeon® Processor E3 Server platforms.