Sorry, you need to enable JavaScript to visit this website.

Primary tabs

Dell Vostro 1720/Intel GMA 4500MHD/Ubuntu 12.04

6 posts / 0 new
01 Staff's picture
01 Staff (not verified)

May 14, 2013 - 03:44am

  • 01 Staff's picture
    01 Staff (not verified)


    The driver will not load on my baseline vostro 1720, and the installation messes my mouse pad.  :(

    I have tried several times on a new install of Ubuntu 12.04 32 and 64 bits, with the same result.  

    The machine runs fine under woe 7/32/64, so there is no hardware problems. 

    Am I missinmg something? Is there any way to force the driver to load? 

    How do I restore the original ubuntu mouse pad driver? It works fine for me.

    I am willing to run some tests, if that can help, as my vostro is a dev/test machine.




    May 14, 2013 - 03:44am
  • fledermaus's picture
    fledermaus (not verified)

    Hi - we've had a couple of reports of mouse issues now, but we haven't been able to trace them
    to anything we're installing (we're pretty sure it isn't the intel graphics stack, but it would be nice
    to be sure).

    • Can you send us the contents of /var/log/dmesg ?
    • likewise the contents of /var/log/Xorg.0.log
    • dpkg -l | grep ^ii

    Also, just to be sure, you did reboot after installing the new graphics stack?
    More questions will probably follow once I've had a look at the above - thanks
    for offering to debug.

    May 14, 2013 - 08:43am
  • fledermaus's picture
    fledermaus (not verified)

    This may also be relevant:

    May 14, 2013 - 08:47am
  • tika's picture
    tika (not verified)

    I will send youfiles for before and after.  I have to backup my machine, but should be ready tomorrow. 


    May 14, 2013 - 07:09pm
  • tika's picture
    tika (not verified)


    Here are the log files.

    Order of manips.

    • Fresh install of Ubuntu 12.04 lts 64 bits.
    • reboot
    • reboot
    • logs *-before
    • install Intel graphics installer.
    • reboot
    • install drivers with Ubuntu software center.
    • reboot
    • log *-after


    • Dell Vostro 1720/GMA4500 adapter/Alps touchpad/1440*900 display.
    • proc: Intel® Core™2 Duo CPU T6670 @ 2.20GHz × 2 
    • ram: 3 gigs


    • Sys info reports unknown video adapter. :(
    • The touchpad still functions after installing the drivers, but scolling and tap-click are out.
    • I confirm the symptoms are exactly the same for Ubuntu 12.04 32bits. 

    During driver installation I did see a package with "all", "input" and "lts" in its name being uninstalled...  But it went a bit fast to note the entire name... 

    Hope this helps,



    May 14, 2013 - 11:39pm
  • fledermaus's picture
    fledermaus (not verified)

    I'm going to guess this is actually Ubuntu 12.04.2 rather than 12.04 - looks like a bunch of packages tagged -lts-quantal conflict with the intel repo packages, and were removed in favour of them. If I had to guess, I 'd say that's where the problem lies:

    We're going to have to take a look at this and figure out what the right way to fix this is: It doesn't [appear to] break anything here on my test laptops, but it's entirely possible that one of those lts packages is necessary on your Vostro.

    Short version: Our backport(s) and their backport(s) don't like each other.

    Thanks for the bug report… now we just need to figure out how best to address the problem.

    May 20, 2013 - 11:32am
  • Downgrade for Ubuntu 12.04

    1. Get u12.04-downgrade.tar
    2. Uncompact: $ tar xf u12.04-downgrade.tar
    3. Roll back by running it: $ sudo sh ./
    Jul 24, 2013 - 01:47pm
  • Topic locked