Sorry, you need to enable JavaScript to visit this website.

Primary tabs

e7440 Latitude / Dell Dock + Dual Monitors + Ubuntu 14.04 [FIXED]

19 posts / 0 new
01 Staff's picture
01 Staff (not verified)

Jul 10, 2014 - 12:16pm

  • azymuth's picture
    azymuth (not verified)

    Mouse "freeze" also happens on the standard 14.04 but I can get away with it by switching to another app using ALT-Tab, ie. it makes the mouse pointer re-appear and the mouse works again. With the modified 3.15 kernel this does not work and you either use ALT-keys for the rest of the session or you reboot :-(

    Sticky keys are indeed an issue but I had it with std 14.04 and if I recall I also had it with the pre-installed 12.04. so it cannot be blamed on the new kernel.

    BTW where did you get your E7440 ? I got mine in Asia and it may have some different components which could explain the different behavious with a same ubuntu kernel ?

    Jan 19, 2015 - 12:25am
  • youarethehat's picture
    youarethehat (not verified)

    I'm having the same trouble, only I'm running CentOS 7. It seems like I have analogous tools to compile this kernel to an RPM instead of a DEB, but... well, I'm a noob to kernel modification in general. Is it wise to use this as a CentOS kernel? Does it matter? Would it work?

    Jan 19, 2015 - 10:39am
  • nethog's picture
    nethog (not verified)

    Hello, I have the same freezing of the touchpad issue. I can't get around it (yet) with less than a suspend and reactivation. My usb mouse works fine always.

    This is a very annoying bug. Has anyone found a solution?


    Jan 27, 2015 - 10:52pm
  • vicntt's picture
    vicntt (not verified)


    This solution worked fine for me but with last version of xserver-xorg-video-intel:



    Feb 06, 2015 - 02:44am
  • vicntt's picture
    vicntt (not verified)


    @z06kris did you get a resolution to booting up with lid closed?

    Feb 06, 2015 - 02:59am
  • z06kris's picture
    z06kris (not verified)

    @vicntt -- No, not yet. To be honest, haven't really had the time for it, but I'll definitely post any/all fixes on this thread when I do.

    Feb 24, 2015 - 12:53pm
  • max's picture
    max (not verified)

    Here isHere is a version including WIFI support

    Same words of caution as usual..

    Mar 27, 2015 - 09:44am
  • z06kris's picture
    z06kris (not verified)

    Hi everyone,

    Finally got around to looking into the blank screen on boot/login more in-depth (i.e., CRTC error dialog, etc). While I could be absolutely wrong here, I suspect this behavior is related to this patch (

    Before getting too far down that road though, I decided to try a more simple test first. For those of you encountering the same issue (blank screens on boot), can you confirm whether this "band-aids" the problem on your end? This isn't supposed to be considered a "fix", rather just to help diagnose/isolate the problem.

    1. Edit /etc/UPower/UPower.conf

    2. Modify (or add to) last line:




    3. Save, exit, and reboot.

    After rebooting (with the lid closed), my external monitors will quickly flash the login screen, and go blank (as they did before). However now they're only blank for ~1-2 seconds, and come back (staying on) as they're supposed to.

    Please let me know if any of you got the same result I did.


    Apr 13, 2015 - 09:42pm
  • vinc's picture
    vinc (not verified)

    Hi there,

    I ran into this issue too :

    Having a laptop and a docking station and wanting to use 2 external monitors while docked (but not the laptop screen).


    The previous post showing the IngoreLid=true of the Upower.conf file helped me with the startup CRTC error :)

    By the way, the login screen is not showing on the external monitors but on the "first" screen, the laptop one...


    Can we just disable the laptop screen if only we are docked ? (as I want to be able to connect without the docking station !)


    Thanks for the tips :)

    Sep 08, 2015 - 05:31am
  • Topic locked