Sorry, you need to enable JavaScript to visit this website.

Primary tabs

Haswell graphics, 2 monitor, *ERROR* failed to train DP, aborting

1 post / 0 new
01 Staff's picture
01 Staff (not verified)

Feb 01, 2014 - 07:04am

  • 01 Staff's picture
    01 Staff (not verified)


    I have a DELL E7440 with a docking station. Everytime when I connect an external display to the dock (DVI or VGA) I'm getting the following message every second:

    [drm:intel_dp_complete_link_train] *ERROR* failed to train DP, aborting

    When I reduce the resolution of the external display from 1920x1080 to 800x600 it works. I tried it with an external monitor and a TV screen, always with the same result. There is no difference if I connect the monitor before booting or while system is running. On Windows I don't have this problem, all resolutions work fine. 

    Log files with drm.debug=0xe

    Boot log:

    connect display with 800x600:

    switch external display resolution to 1920x1080:



    Feb 01, 2014 - 07:04am