Sorry, you need to enable JavaScript to visit this website.

Primary tabs

No HDMI audio

3 posts / 0 new
01 Staff's picture
01 Staff (not verified)

Aug 15, 2013 - 06:38am

  • 01 Staff's picture
    01 Staff (not verified)


    I've been pulling my hair for some days now trying to get my new Haswell-based Ubuntu HTPC to output audio via HDMI.

    I'm using Ubuntu 13.04 with allt the latest updates from the official repositories. I've been trying all different configurations to try to get it to work. With the default install, the Intel HDMI Audio device shows up properly in '§ lspci ' and in '§ grep "Codec:" /proc/asound/card*/codec* ', but not when running '§ aplay -l '. It doesn't show up in ubuntu standard sound settings nor in pulseaudio settings. Running '§ lsmod | grep hda ' shows the driver is loaded but for some reason the device still doesn't show up. I've tried disabling, reenabling the sound device(s) in UEFI but still no luck. I've tried updating the ALSA drivers but still no difference.


    When I updated to mainline kernel 3.10, the HDMI audio device shows up in the settings as expected and works, although only in stereo mode (in 5.1 mode the sound crackles and don't come from the correct speaker). Only problem is (pretty big one) with the 3.10 kernel my Logitech Wireless keyboard/thouchpad combo doesn't work, at all.

    I'm starting to understand the expression "Linux is only free if your time has no value"...

    Please help, I'm completely out of ideas on this one.

    And no, I don't want to buy extra cables to use analog/optical instead for two reasons: 1. It's very inconvinient to access the cables behind my A/V-reciever; 2. I shouldn't have to. This should work, it's 2013 ffs...


    Aug 15, 2013 - 06:38am
  • Hi jadedcyborg,

    I stumbled across an Ubuntu bug about the 3.10 kernel and Logitech wireless devices. It looks like they've got a handle on that particular issue, at least.

    I've noted the HDMI audio issue you're experiencing-- I'll address that later, unless the wider community beats me to the punch.


    Aug 15, 2013 - 07:05am
  • jadedcyborg's picture
    jadedcyborg (not verified)

    Yes I found that bug report as well after some additional searching. It's supposed to be "fixed" (rather: unfucked) in 3.11-rc5 (which is only a few days old). However I'm not so comfortable using unstable kernels, I'd much rather that HD Audio worked on Ubuntu 13.04 out of the box.

    I'm not feeling so confident in the linux community right now, given that they managed to fuck up something in 3.10-rc1 and didn't manage to unfuck until 3.11-rc5 (a simple revert). Embarrassing, really.

    Aug 15, 2013 - 07:58am
  • jadedcyborg's picture
    jadedcyborg (not verified)

    Sorry for the bad attitude in the previous post, I was a bit frustrated.

    So, I wiped the system and reinstalled Ubuntu 13.04 with the kernel 3.11-rc5 from the Ubuntu mainline repository this morning and voila, both HDMI sound and my keyboard works. However, as before, HDMI sound only works if I put it in stereo mode in the configuration, if I select multichannel mode the audio gets distorted and comes from the wrong speaker(s) when running speaker test. I've tried all the tricks in Ubuntus troubleshooting guide ( as well as the workarounds mentioned here (, but with no or negative result.

    The interesting thing is that in VLC 5.1 AC3-tracks works correctly, and in XBMC as well BUT ONLY if I select the HDMI device itself as output, NOT the PulseAudio device. So it seems to be some issue there with multichannel PCM or something (and yes, my AVR supports multichannel PCM up to 8 channels).

    So for now it works good enough, I don't really need 5.1 system audio as long as AC3/DTS pass through works. However, as I mentioned before I'm not to happy about having to use an unsupported and unstable mainline kernel, since I also want to use my HTPC as a storage server (I have 4x 3TB WD REDs in there). I would be very happy if whatever changes introduced in the 3.10 line that fixed the HDMI Audio got backported to the official ubuntu kernel. I suspect, however that such a request is better suited for launchpad, or it something you can look into?

    Lastly, here the output from the commands I mentioned in my original post with using the standard (non-functioning) kernel: If there is any more info I can provide to help troubleshooting the issue further I'm happy to help.

    Aug 16, 2013 - 07:10am
  • Topic locked