Sorry, you need to enable JavaScript to visit this website.

Primary tabs

VC-1 1080p24 Visual Artifacts in Kodi on Lubuntu 15.10 with VAAPI acceleration

0 posts / 0 new
01 Staff's picture
01 Staff (not verified)

Jan 06, 2016 - 02:06pm

  • 01 Staff's picture
    01 Staff (not verified)
    Gentlemen, not sure if this should be in this thread, so if not, mods, please move it to the appropriate thread.
    I am having issues with some 1080p24 VC-1 files having visual artifacts when VAAPI hardware acceleration is enabled. The artifacts do disappear if I turn hardware acceleration off, but then the video stutters (not enough CPU power).
    I am running Kodi media center on Lubuntu 15.10, 64 bit, Kernel 4.3.3. The system is:
    ASRock N3000 with Crucial 2x4GB RAM kit and a 250GB Samsung 850 EVO mSATA drive. My UEFI version is N3000-NUC P1.50, CPU set to Sport Mode. 
    I cut a section of the video I'm having problems with, and a member on the OpenELEC forum confirmed that they have the same problem on ASRock N3000. I uploaded the section of the video below.
    I tried updating the driver using Intel Graphics Installer for Linux (1.2.1), but nothing changed. Tried using Intel Graphics Stack Release 2015 Q4 (to update to version 1.6.2) but couldn't figure out how to compile and install it, as the very first thing I'm trying to build is libdrm and the line ./ --prefix=$MY_DISTRO_PREFIX gives me error, as there's no I used configure, but also unsuccessful.
    I had the same issue with OpenELEC. I tried to address this issue on the OpenELEC and Kodi forums, but was refered to get more support here. OpenELEC forum thread is here:
    Here's the output of $ cat /proc/cpuinfo | grep -i intel:
    vendor_id    : GenuineIntel
    model name    : Intel(R) Celeron(R) CPU  N3000  @ 1.04GHz
    vendor_id    : GenuineIntel
    model name    : Intel(R) Celeron(R) CPU  N3000  @ 1.04GHz
    $ vainfo output:
    libva info: VA-API version 0.38.0
    libva info: va_getDriverName() returns 0
    libva info: Trying to open /usr/lib/x86_64-linux-gnu/dri/
    libva info: Found init function __vaDriverInit_0_38
    libva info: va_openDriver() returns 0
    vainfo: VA-API version: 0.38 (libva 1.6.1)
    vainfo: Driver version: Intel i965 driver for Intel(R) CherryView - 1.6.1
    vainfo: Supported profile and entrypoints
          VAProfileMPEG2Simple            :    VAEntrypointVLD
          VAProfileMPEG2Simple            :    VAEntrypointEncSlice
          VAProfileMPEG2Main              :    VAEntrypointVLD
          VAProfileMPEG2Main              :    VAEntrypointEncSlice
          VAProfileH264ConstrainedBaseline:    VAEntrypointVLD
          VAProfileH264ConstrainedBaseline:    VAEntrypointEncSlice
          VAProfileH264Main               :    VAEntrypointVLD
          VAProfileH264Main               :    VAEntrypointEncSlice
          VAProfileH264High               :    VAEntrypointVLD
          VAProfileH264High               :    VAEntrypointEncSlice
          VAProfileH264MultiviewHigh      :    VAEntrypointVLD
          VAProfileH264MultiviewHigh      :    VAEntrypointEncSlice
          VAProfileH264StereoHigh         :    VAEntrypointVLD
          VAProfileH264StereoHigh         :    VAEntrypointEncSlice
          VAProfileVC1Simple              :    VAEntrypointVLD
          VAProfileVC1Main                :    VAEntrypointVLD
          VAProfileVC1Advanced            :    VAEntrypointVLD
          VAProfileNone                   :    VAEntrypointVideoProc
          VAProfileJPEGBaseline           :    VAEntrypointVLD
          VAProfileJPEGBaseline           :    VAEntrypointEncPicture
          VAProfileVP8Version0_3          :    VAEntrypointVLD
          VAProfileVP8Version0_3          :    VAEntrypointEncSlice
          VAProfileH264MultiviewHigh      :    VAEntrypointVLD
          VAProfileH264MultiviewHigh      :    VAEntrypointEncSlice
          VAProfileH264StereoHigh         :    VAEntrypointVLD
          VAProfileH264StereoHigh         :    VAEntrypointEncSlice
          VAProfileHEVCMain               :    VAEntrypointVLD
    Any help on how to update to i965 driver version 1.6.2 to try it or other help is greatly appreciated. 
    Thank you.


    Jan 06, 2016 - 02:06pm