Sorry, you need to enable JavaScript to visit this website.

After installing Intel Graphics Installer 1.0.6 for Linux on t530 Docking Station not functioning properly

3 posts / 0 new
Shiran Stan's picture
Starter
Shiran Stan

Oct 14, 2014 - 01:26am

  • Hi,

    I recently installed the intel driver using 1.0.6 installer on:

    Lenevo t530

    3.13.0-37-generic #64-Ubuntu (14.04)

     

    After reboot the USB ports + displayport + dvi just stopped working on the docking station.

    while power, network and vga still functioning properly.

    the usb on the laptop itself are working fine...

     

    Any suggestions?

     

    Regards,

     

    Oct 14, 2014 - 01:26am
  • Hi. That's a little odd - hopefully it's not a regression in the driver: You can test this by removing the new driver
    (you'll revert to the old one once you've done that and rebooted).

    The new driver is provided by the packkage i915-3.15-3.13-dkms (if memory serves). Remove that and reboot.
    If the problem goes away, it's a regression in the driver, and we can take it from there. If not, then it's something else and we'll have to do some more digging.

    Oct 21, 2014 - 06:51am
  • Hi,

    The USB ports got back to work at some point (maybe some update from ubuntu repo).

    the Displayport and DVI still havn't work both on dock and on the laptop itself (not seeing the attached display)

    they seemed to work when i updated kernel to 3.16 but then i got crash error with the i9xx device after login.

     

    I removed the driver and after reboot i can see the attached screens again.

     

    i started this whole thing becuase when i use digital port i get many artifacts as in image attached.this also happened when i tried the 3.16 kernel.

    any idea on that?

     

    Thanks for the help!

     

     

    Oct 22, 2014 - 05:04am
  • Ick, that's nasty - looks like it might be a regression in the driver itself.

    What kernel were you on before?
    does reverting to that kernel make the problem go away (if that's something you can easilyt test)?

    Nov 04, 2014 - 07:53am