Sorry, you need to enable JavaScript to visit this website.

Grainy graphics with ubuntu 14.04 and Intel 1.0.7 Installer

3 posts / 0 new
Jim Jacobs's picture
Starter
Jim Jacobs

Dec 06, 2014 - 07:06pm

  • I just installed ubuntu 14.04.  The CD showed very "grainy" graphics and nothing I've been able to do during the installation or subsequent update has changed that.  The big characters display look jagged and the small ones (e.g., on the terminal screen) seem to have patches othat are off-color making them difficult to read.  Pathces of solid color show a very small grid of fine black lines between blocks of mostly solid color (except they often have a hash or dot pottern (what you see when the system can't render can't render all the colors properly). 

     

    I installed Kubuntu 14.04.1 from CD.  Graphics quality remained unchanged between LiveCD and post-reboot.  Downloaded Intel Graphics Installer 1.0.7 for Ubuntu 14.04 64bit.  Ran it and it appeared to work.  Rebotted but there was no change.  Let software update system and reran Graphics Installer then rebooted.  No change to graphics. 

     

    The computer is a Dell Inspiron 17R laptop (aka Inspiron 17R (5737) BTX Base).  The invoice lists "Intel(R) HD Graphics 4400" and "4th Generation Intel Core i5-4 200U processor (3M Cache, up to 2.6 GHz)" as the graphics and processor involved.   Under Win8.1 the display is fine and uses 1600x900 @ 60 Hz. 

    Dec 06, 2014 - 07:06pm
  • Hi - is the configured resolution of your display correct? You mention that windows is driving it at 1600x900 - is Ubuntu also trying that resolution, or has it fallen back to a lower resolution for some reason?

    Dec 09, 2014 - 07:55am
  • We bit the bullet and did the science fair project on Win8.1 but now my wife is going to help my son do some web development and so getting Linux going on his laptop has come back to the forefront. I thought I had set up the forum to e-mail me on any updates, but it appears I was mistaken.

    I can't really seem to find anything on KDE to let me even look at the resolution, color depth, etc., which seems a little odd I installed Kubuntu 14.10 on a different partition but that doesn't work any better than 14.04 did even after its Intel driver upgrade (I used the 1.0.7 installer to try one more time on 14.04); I gather there isn't any need to install anything on the 14.10 distro?

    Interestingly (I think), I get the same display problems when I run Kubuntu right off the 14.10 DVD rather than installing it. I just upgraded the BIOS to the latest, according to Dell (A08) and that had no effect. Maybe there's a BIOS setting that's wrong?

    Mar 03, 2015 - 12:22pm
  • Hi. Strictly speaking, unless you have very new hardware, there's no _need_ to use the installer at all, what it gives you is a more recent release of the kernel module/xorg/mesa/etc than came out with the distrbution.

    For 14.04 your best (newest) drivers are currently available by upgrading to 14.04.2 and applying the
    utopic hardware packs, kernels etc for that LTS.

    For 14.10, an installer should be hitting the site soon - but 14.10 will have a newer set of user and kernel space drivers than 14.04 anyway, so I'd be very surprised if the same hardware was unsupported in 14.10 _and_ 14.04

    The symptom you are describing (grainy display) sounds to me like you are running at the wrong resolution for your LCD - I don't think that's very likely to be down to the drivers (one thing it could be, for example, is misleading or malformed EDID from the display hardware, leading the OS to pick the wrong resolution).

    If I were you I'd file a bug with the distribution, supplying:

    output of lspci -vnn
    output of xdpyinfo
    The contents of your /var/log/Xorg.0.log

    Mar 09, 2015 - 05:00pm