Sorry, you need to enable JavaScript to visit this website.

Graphics Installer 1.0.3 for Linux*

20 posts / 0 new
Joe Konno's picture
Starter
Joe Konno

Jan 13, 2014 - 03:07pm

  • fledermaus's picture
    fledermaus (not verified)

    Hi - packages.ubuntu.com seems to indicate here ( http://packages.ubuntu.com/saucy/libglib2.0-0 ) that the current version for saucy (13.10) is 2.38.0-1ubuntu1 - are you definitely on saucy and not raring (13.04)?

    If you are on saucy, is there a problem with your apt repository config that's preventing it from getting
    updates? Those are the possible problems that spring immediately to mind based on your description
    above.

    Feb 11, 2014 - 05:46am
  • crunch33's picture
    crunch33 (not verified)

    Thanks for your contribution.

    My distro is debian based (as ubuntu), but is not ubuntu. CrunchBang is a lightweight xfce distro welcome on Atom N2600 that can't aford a beautifull graphic environment.

    Last libglib2.0-0 in CrunchBang synaptic is 2.33.12+really2.32.4-5 (and this is the installed version).

    I understand difficult task for Intel to support all distros (supporting Gentoo would probably resolve much more technical issues).

    So my question is: does Intel driver absolutly needs a very up to date libglib2.0-0 version or is it only a false dependency that locks installation?

    Feb 11, 2014 - 01:24pm
  • fledermaus's picture
    fledermaus (not verified)

    It's not a build dependency, but it is an installation dependency (that's the library the installer was
    built against for the target distribution).

    Mar 06, 2014 - 08:35am
  • crunch33's picture
    crunch33 (not verified)

    Thank's for your response fledermaus.

    So I undestand that it's a mistake building package with this wrong version dependency.

    Please, could you provide us a new installer with correct installer dependency (ie the same than build dependency that should be the older possible for a larger compatibility) ?

    Mar 06, 2014 - 12:36pm
  • fledermaus's picture
    fledermaus (not verified)

    I think we may be talking at cross purposes here - it's not, I believe, a mistake.
    The binary package really does depend on that version. If you build the source
    package.

    With regards to supporting distributions other than the currently targeted ones,
    I don't think it will be possible to alter the existing packages (thay have to go through
    a _lot_ of QA before we can release them).

    We may be able to do something about making it easier for people on distros other
    than the currently targeted ones, but I can't make any promises about that yet,
    we're still exploring the problem.

    Mar 07, 2014 - 10:18am
  • crunch33's picture
    crunch33 (not verified)

    It's a pity for me, but I understand...

    I hope you just check for this dependency and try to support a 18 month old libglib to improve compatibility.

    Regards,

    Mar 07, 2014 - 01:50pm
  • nifr's picture
    nifr (not verified)

    Thanks for all your efforts to provide these drivers. I just installed these on my Ubuntu 13.10 System.

    I'm running a Core i5-3570 (non-K) with Intel HD 2500 IGPU.

    1. Issue

    Running LIBGL_DEBUG=verbose glxgears results in the following output:

    pci id for fd 4: 8086:0152, driver i965
    libGL: OpenDriver: trying /usr/lib/x86_64-linux-gnu/dri/tls/i965_dri.so
    libGL: OpenDriver: trying /usr/lib/x86_64-linux-gnu/dri/i965_dri.so
    libGL: screen 1 does not appear to be DRI2 capable
    libGL: OpenDriver: trying /usr/lib/x86_64-linux-gnu/dri/tls/swrast_dri.so
    libGL: OpenDriver: trying /usr/lib/x86_64-linux-gnu/dri/swrast_dri.so
    libGL: driver does not expose __driDriverGetExtensions_swrast(): /usr/lib/x86_64-linux-gnu/dri/swrast_dri.so: undefined symbol: __driDriverGetExtensions_swrast

    25416 frames in 5.0 seconds = 5083.178 FPS
    ...

    2. Issue

    I experience horizontal tearing in almost every video played with the Ubuntu default video (totem) player since i installed the driver.

    ---

    Further i have the following questions:

    1. How can i test/verify that the driver is successfully installed (and definitely being used) ?

    2. How to uninstall the driver completely after using the intel-linux-graphics-installer?

    3. Is it possible to run the installer without the GUI (i.e. for scripted setups)? If yes - which arguments need to be passed?

     

     

     

    Feb 04, 2014 - 02:08pm
  • nifr's picture
    nifr (not verified)

    I'm not sure if the driver is installed correctly.

    Why does LIBGL_DEBUG=verbose output driver i965 ...

    ... while lshw -c video outputs :

    *-display
           description: Display controller
           product: Xeon E3-1200 v2/3rd Gen Core processor Graphics Controller
           vendor: Intel Corporation
           physical id: 2
           bus info: pci@0000:00:02.0
           version: 09
           width: 64 bits
           clock: 33MHz
           capabilities: msi pm bus_master cap_list
           configuration: driver=i915 latency=0
           resources: irq:52 memory:f6400000-f67fffff memory:d0000000-dfffffff ioport:f000(size=64)

     

    modinfo i915 output

    nico@nico-i5:~$ modinfo i915
    filename:       /lib/modules/3.11.0-15-generic/kernel/drivers/gpu/drm/i915/i915.ko
    license:        GPL and additional rights
    description:    Intel Graphics
    author:         Tungsten Graphics, Inc.
    license:        GPL and additional rights
    srcversion:     6422A1AA6E59CE389D6597C

    modinfo i965 output:

    ERROR: Module i965 not found.

    lspci -nnk output:

    00:02.0 Display controller [0380]: Intel Corporation Xeon E3-1200 v2/3rd Gen Core processor Graphics Controller [8086:0152] (rev 09)
        Subsystem: ASRock Incorporation Device [1849:0152]
        Kernel driver in use: i915


     

    Feb 04, 2014 - 03:03pm
  • nifr's picture
    nifr (not verified)
    /usr/lib/nux/unity_support_test --print output:
    
    pci id for fd 4: 8086:0152, driver i965
    OpenGL vendor string:   Intel Open Source Technology Center
    OpenGL renderer string: Mesa DRI Intel(R) Ivybridge Desktop 
    OpenGL version string:  3.0 Mesa 10.1.0-devel (git-3f3aafb saucy-oibaf-ppa+curaga)

     

    i915 or i965 ?

    Feb 04, 2014 - 03:27pm
  • fledermaus's picture
    fledermaus (not verified)

    Ok, to answer some questions:

    The drivers are (in this release) just normal packages for ubuntu made from more up to date
    upstream releases: the 2013-Q4 release (which is what is currently out for saucy) does not
    contain an updated kernel video driver (saucy's driver was already new enough for 2013-Q4).

    So if the packages in the update are installed, then that's all that should be neccesary: The packages
    for this release are:

    i965-va-driver intel-gpu-tools libva1 libva-egl1 libva-glx1 libva-tpi1
    libva-x11-1 libva-drm1 libva-intel-vaapi-driver vainfo

    You can uninstall them as follows:

    # remove the intel linux graphics repo from /etc/apt/sources.list.d
    apt-get update
    apt-get remove libva-drm1
    apt-get install --reinstall \
    i965-va-driver/saucy \
    intel-gpu-tools/saucy \
    libva1/saucy \
    libva-egl1/saucy \
    libva-glx1/saucy \
    libva-tpi1/saucy \
    libva-x11-1/saucy \
    libva-intel-vaapi-driver/saucy \
    vainfo/saucy

    Note that when you do this, you may have to remove any related -dev packages by hand first,
    you can reinstall them afterwards.

    It's probably worth mentioning at this point that you should check that all of the above packages
    are from the intel linux graphics repo and not some other PPA, and also that the mesa and libdrm
    packages are from vanilla ubuntu and not a PPA (we can't test against every PPA so it's impossible
    to rule out a bad interaction between their updates and ours in advance, as I'm sure you understand)

    Hope this helps, please let us know if you have any further questions.

    Feb 11, 2014 - 06:01am