Sorry, you need to enable JavaScript to visit this website.

Graphics Installer 1.0.5 for Linux* released!

41 posts / 0 new
Joe Konno's picture
Starter
Joe Konno

May 14, 2014 - 10:08am

  • Hi - thanks to all of you for digging that up, I've bounced it across to the team that handles it.

    May 16, 2014 - 09:56am
  • Since we'are not talking about some complicated programming/algorithm issue, but about config-value bug is there any roadmap for the hotfix (day, week, month)?

    Thanks.

    May 16, 2014 - 10:12am
  • Hey gang,

    Thanks for the heads-up. I've updated the ilg-config.cfg file hosted on download.01.org to point to the https URL. It may take a while for this change to propagate, but so far as I can tell here it's now fixed.

    Cheers

    May 16, 2014 - 01:19pm
  • Getting this error instead of the GPG error when I tried sudo apt-get update

    W: Failed to fetch https://download.01.org/gfx/ubuntu/14.04/main/dists/Ubuntu/14.04/binary-...  HttpError404

    W: Failed to fetch https://download.01.org/gfx/ubuntu/14.04/main/dists/Ubuntu/14.04/binary-...  HttpError404
     

    May 16, 2014 - 09:32pm
  • Got it working finally after fixing the url in repository.

    May 16, 2014 - 10:13pm
  • When attempting to install I get a unicode error

    UnicodeDecodeError: 'utf-8' codec can't decode byte 0x92 in position 579: invalid start byte
     
    Occurs on the upgrading system page when "listing packages". Seems to have broken apt / aptdaemon for  some reason.
     
    Have tried reinstall, reinstalled apt and aptdaemon - despite this same error each time
     
    Any clues?
     
    Iain
     
    May 17, 2014 - 12:47am
  • What's the difference between install driver by "Linux Graphic Installer" or just install this packages already present in Ubuntu Universe Repository?:

        i965-va-driver:amd64 (1.3.0-1ubuntu1)
        libva-drm1:amd64 (1.3.0-2)
        libva-egl1:amd64 (1.3.0-2)
        libva-glx1:amd64 (1.3.0-2)
        libva-intel-vaapi-driver:all (1.3.0-1ubuntu1)
        libva-tpi1:amd64 (1.3.0-2)
        libva-wayland1:amd64 (1.3.0-2)
        libva-x11-1:amd64 (1.3.0-2)
        vainfo:amd64 (1.3.0-2)

    I don't insert "intel-gpu-tools:amd64 (1.6-1)" package because is the only one with different version between installer (v1.6-1) and repository (v. 1.3.0-2), also I read this is just a debugger so I think it is not necessary.

    May 17, 2014 - 03:22pm
  • I've installed the 64-bit GNU/Linux XUbuntu 14.04 LTS operating system into my mother's laptop (a 15.6" Acer Aspire notebook model number E1-571-6854, which uses a Intel Core i5-3230M processor with Intel Graphics HD 4000) and have just installed and ran the Intel Graphics Installer 1.0.5 (14 May 2014) for Linux Ubuntu 14.04, 64-bit.

    All the installation process ocurred without any trouble. However, like some other guys I'm too wondering if any of the installed files were really necessary. Also, I am not sure if the driver was installed correctly. Apparently, the i965 driver should've replaced the i915 one. Assuming that this is a true statement, the O.S. indicates that such replacement didn't happen, otherwise the output of the lshw -c video command wouldn't be this:

    *-display
           description: VGA compatible controller
           product: 3rd Gen Core processor Graphics Controller
           vendor: Intel Corporation
           physical id: 2
           bus info: pci@0000:00:02.0
           version: 09
           width: 64 bits
           clock: 33MHz
           capabilities: msi pm vga_controller bus_master cap_list rom
           configuration: driver=i915 latency=0
           resources: irq:42 memory:c0000000-c03fffff memory:b0000000-bfffffff ioport:2000(size=64)

     
    Also, the command modinfo i965 gives me this output:
     
    modinfo: ERROR: Module i965 not found.
     
    ...while the modinfo i915 command outputs this:
     
    filename:       /lib/modules/3.13.0-24-generic/kernel/drivers/gpu/drm/i915/i915.ko
    license:        GPL and additional rights
    description:    Intel Graphics
    author:         Tungsten Graphics, Inc.
    license:        GPL and additional rights
    srcversion:     C6C6D0B5224D5DF3DCE1AE6
    alias:          pci:v00008086d00000155sv*sd*bc03sc*i*
    (...)
    alias:          pci:v00008086d00003577sv*sd*bc03sc*i*
    depends:        drm_kms_helper,drm,video,i2c-algo-bit
    intree:         Y
    vermagic:       3.13.0-24-generic SMP mod_unload modversions 
    signer:         Magrathea: Glacier signing key
    sig_key:        69:B0:D0:A7:9B:85:D9:06:21:70:6E:8D:06:60:4D:73:0B:35:9F:C0
    sig_hashalgo:   sha512
    (...)
    parm:           prefault_disable:Disable page prefaulting for pread/pwrite/reloc (default:false). For developers only. (bool)
     
    I've also ran the sudo updatedb && locate i965 command: no i965.ko file is present anywhere in the system.
     
    Finally, the command lspci -vvvknn -s 00:02.0 returned me the following:
     
    00:02.0 VGA compatible controller [0300]: Intel Corporation 3rd Gen Core processor Graphics Controller [8086:0166] (rev 09) (prog-if 00 [VGA controller])
    Subsystem: Acer Incorporated [ALI] Device [1025:064b]
    Control: I/O+ Mem+ BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr- Stepping- SERR- FastB2B- DisINTx+
    Status: Cap+ 66MHz- UDF- FastB2B+ ParErr- DEVSEL=fast >TAbort- <TAbort- <MAbort- >SERR- <PERR- INTx-
    Latency: 0
    Interrupt: pin A routed to IRQ 42
    Region 0: Memory at c0000000 (64-bit, non-prefetchable) [size=4M]
    Region 2: Memory at b0000000 (64-bit, prefetchable) [size=256M]
    Region 4: I/O ports at 2000 [size=64]
    Expansion ROM at <unassigned> [disabled]
    Capabilities: [90] MSI: Enable+ Count=1/1 Maskable- 64bit-
    Address: fee0f00c  Data: 41a1
    Capabilities: [d0] Power Management version 2
    Flags: PMEClk- DSI+ D1- D2- AuxCurrent=0mA PME(D0-,D1-,D2-,D3hot-,D3cold-)
    Status: D0 NoSoftRst- PME-Enable- DSel=0 DScale=0 PME-
    Capabilities: [a4] PCI Advanced Features
    AFCap: TP+ FLR+
    AFCtrl: FLR-
    AFStatus: TP-
    Kernel driver in use: i915
     
    I can't help wondering what change the version 1.0.5 of the Intel Graphics Installer effectively provides. It seems that no driver was updated.
     
    ?:-|
    May 18, 2014 - 02:54am
  •  

    Hi,

     

    I'm thinking / getting the same result as you on this.  Did you ever get a response or come to a conclusion on this?

    thanks,

    Jul 22, 2014 - 08:49am
  • In a nutshell: the i915 driver is your graphics device driver and the i965 driver deals with the video acceleration part (it's called Intel VA-API, meaning "Intel's Video Acceleration Application Programming Interface"). If your system is Ubuntu 14.04, then it already had the 1.0.5 version of i915 and hence all that the IGI (Intel Graphics Installer) did was to install the VA-API (the i965 driver plus all the other VA-API-related files).

    For a little more info, please read this post.

    Jul 22, 2014 - 09:14am