Sorry, you need to enable JavaScript to visit this website.

Graphics Installer 1.0.7 for Linux does'nt recognize Bay Trail graphics on Ubuntu 14.04

9 posts / 0 new
Thomas Demuth's picture
Thomas Demuth

Feb 11, 2015 - 07:01am

  • Hello,

    I installed Ubuntu 14.04 on my new ACER Travelmate. Afterwards I installed the Graphics installer 1.0.7.

    This is a notebook with the the Intel N3540 processor, based on the bay trail platform.

    Starting the Graphics Installer results the message box with the content: "You don’t seem to have an Intel i915 chipset so no updates are needed". The main window contains the message: "Checking if Intel graphics card available... Failed"

    Listing the PCI-Devices shows following results:

    $  lspci -k |grep -C 3 "VGA"
    00:00.0 Host bridge: Intel Corporation ValleyView SSA-CUnit (rev 0e)
        Subsystem: Acer Incorporated [ALI] Device 0860
    00:02.0 VGA compatible controller: Intel Corporation ValleyView Gen7 (rev 0e)
        Subsystem: Acer Incorporated [ALI] Device 0860
        Kernel driver in use: i915
    00:13.0 SATA controller: Intel Corporation ValleyView 6-Port SATA AHCI Controller (rev 0e)

    What is going wrong, what can I do to install the latest graphics driver?



    Feb 11, 2015 - 07:01am
  • That is odd. Can you see the contents of /sys/module/i915/initstate ? If so, what does that file say?

    Feb 16, 2015 - 11:52am
  • I've found following: There is no directory i915 in /sys/module, but a directory i915_bdw. The content of the file: $ cat /sys/module/i915_bdw/initstate live

    Feb 17, 2015 - 08:58am
  • Ah, that will be why. The module you have loaded has had some surgery done on it so the installer
    doesn't reckon you are running an i915-driven system. Hm, this is awkward... I can't think of an easy
    way to create a fake /sys entry... If you like, I can walk you through the steps necessary to do what
    the installer would have done for you by hand.

    Feb 17, 2015 - 09:45am
  • Thank you for your fast response!

    I 've found the i915_bdw driver is an out-of the box solution of ubuntu 14.04. (see

    I can't see a way to create a fake /sys entry. I guess the best way would be the manual installation of the i915 driver.

    Therefore I need a recipe. Is ther anywhere a site describes the steps for a manual installation?

    Otherwise I'd come back to your offer to walk me through the installation steps.




    Feb 17, 2015 - 11:07am
  • It's pretty straightforward: It's all driven by the configuration here:

    If you download that, you'll see a section for trusty:

    [Ubuntu trusty]
    source trusty
    source main

    You put those 3 entries together to make an entry for /etc/apt/sources.list.d/intellinuxgraphics.list

    deb trusty main

    Once that's in place, sudo apt-get update.

    Following that you'll see a list of packages: The ones marked with a 'u' or 'i'
    are the ones you want to install (plus one special package for the kernel module),
    so eg:

    kernel 3.13 3.16 i i915-3.16-3.13-dkms
    u libgl1-mesa-glx
    u libglapi-mesa
    i libgles1-mesa

    would mean:

    sudo apt-get install libgl1-mesa-glx libglapi-mesa libgles1-mesa i915-3.16-3.13-dkms

    There are a lot more packages in that section, so your actual command line will be longer,
    but you get the idea.

    Feb 17, 2015 - 01:59pm
  • I hesitated al little bit to update the system manually. But I've done an it works.

    - at first a made a backup of my root partition

    - then first I added

      deb trusty main

      to the repository to /etc/apt/sources.lst

    - updated the sofware lists

    sudo apt-get update

    Next I handycrafted the update commnad with a text editor bases on

    The result was following:

    sudo apt-get install libegl1-mesa libegl1-mesa-drivers libgbm1 libgl1-mesa-dri libgl1-mesa-glx libglapi-mesa libgles1-mesa libgles2-mesa libopenvg1-mesa libosmesa6 libwayland-egl1-mesa libxatracker2 xserver-xorg-video-intel libdrm-intel1 libdrm-nouveau2 libdrm-radeon1 libdrm2 libva-drm1 libva-egl1 libva-glx1 libva-tpi1 libva-wayland1 libva-x11-1 libva1 va-driver-all vainfo i965-va-driver would-break-abi intel-gpu-tools

    I was surpriced - the update worked.

    After booting the computer I found, the X-performnce it's better than with the out of the box driver.

    The driver works, I found just one "feature": Sometimes the shutdown screen degrades into a "ghost image", but the system does'nt hang, it shuts down a second later. I hope this issue will be solved with the next driver version.

    Thank's for your support.

    Feb 23, 2015 - 11:50am
  • Great! Glad it all worked. We'll have to see about a more robust method
    for detecting a running i915 system - thanks for reporting the probem.

    Feb 26, 2015 - 06:12am
  • This problem doesn't exist by installing Ubuntu 14.04.02. Yesterday I tried this version. The module "i915" is present and the graphics installer works properly. Perhaps also 14.04.01 came with tho original named kernel modul. I made the mistake by installing the basic version of TrustyTahr without a subversion (14.04).

    Possibly it isn't worth to adapt the graphics installer to work with a kernel module i915_bdw.

    Mar 03, 2015 - 10:19am
  • Hi - thanks for the updated info - will definitely bear it in mind when updating the installer in upcoming releases.

    One point worth noting: 14.04.2 comes with the kernel from utopic (14.10) and Xorg packages from utopic as well (-lts-utopic appended to the name) - so for 14.04.2 and later, if you grab the LTS kernel and X packages, you'll actually be getting more recent graphics support than the installer provides for 14.04.1

    Mar 09, 2015 - 04:51pm