Sorry, you need to enable JavaScript to visit this website.

I can't install the Intel Driver on the Debian SID

1 post / 0 new
mario mario's picture
Starter
mario mario

Jul 19, 2014 - 12:16pm

  • Hello. I'm trying to install the intel driver on a fresh installation of  Debian SID because I want to use two monitors at the same time. Infact the primary graphic card that I have is a geforce GTX 770 and the second one is embedded on the motherboard. These are the specs of the motherboard :

    http://www.gigabyte.com/products/product-page.aspx?pid=4489#sp

    and this is my operatying system :

    root@ziomario:/home/ziomario/Scrivania/intel-linux-graphics-installer_1.0.5# uname -a
    Linux ziomario 3.2.0-4-amd64 #1 SMP Debian 3.2.60-1+deb7u1 x86_64 GNU/Linux

    root@ziomario:/home/ziomario# lspci -v | grep -i vga
    00:02.0 VGA compatible controller: Intel Corporation Xeon E3-1200 v3/4th Gen Core Processor Integrated Graphics Controller (rev 06) (prog-if 00 [VGA controller])
    01:00.0 VGA compatible controller: NVIDIA Corporation GK106 [GeForce GTX 660] (rev a1) (prog-if 00 [VGA controller])

     

    root@ziomario:/home/ziomario# modinfo i915
    filename:       /lib/modules/3.2.0-4-amd64/kernel/drivers/gpu/drm/i915/i915.ko
    license:        GPL and additional rights
    description:    Intel Graphics
    author:         Tungsten Graphics, Inc.
    license:        GPL and additional rights
    alias:          pci:v00008086d0000016Asv*sd*bc03sc*i*
     

    I'm pretty sure that it can be done because it is already worked on the fedora 20. Infact I have already installed the graphic installer and I have activated two monitors simultaneously. Now I would like to do the same on Debian Sid. Actually I get two errors. When I run the graphic installer it says :

    You don’t seem to have an Intel i915 chipset so no updates are needed

    Also I have tried to compile the installer from the source and this is what happened :

     

    ......

    root@ziomario:/home/ziomario/Scrivania/intel-linux-graphics-installer_1.0.5# make
    make  all-recursive
    make[1]: ingresso nella directory "/home/ziomario/Scrivania/intel-linux-graphics-installer_1.0.5"
    Making all in src
    make[2]: ingresso nella directory "/home/ziomario/Scrivania/intel-linux-graphics-installer_1.0.5/src"
    /usr/bin/glib-genmarshal marshal.list --header --prefix=_marshal > marshal.h
    /usr/bin/glib-genmarshal marshal.list --body --prefix=_marshal > marshal.c
    make  all-am
    make[3]: ingresso nella directory "/home/ziomario/Scrivania/intel-linux-graphics-installer_1.0.5/src"
      CC       configuration.o
      CC       proxy-config.o
      CC       diagnostics-view.o
      CC       driver-manager-app.o
      CC       key-view.o
      CC       main.o
      CC       main-window.o
    main-window.c: In function ‘main_window_init’:
    main-window.c:576:3: warning: ‘GtkStock’ is deprecated [-Wdeprecated-declarations]
       win->priv->close_button = gtk_dialog_add_button (GTK_DIALOG (win), GTK_STOCK_CLOSE, RESPONSE_CLOSE);
       ^
      CC       marshal.o
      CC       package-manager.o
      CC       package-manager-fedora.o
    package-manager-fedora.c: In function ‘on_pk_transaction_signal’:
    package-manager-fedora.c:514:13: warning: ‘pk_message_enum_to_string’ is deprecated (declared at /usr/include/PackageKit/packagekit-glib2/pk-enum.h:562) [-Wdeprecated-declarations]
                 type = (gchar *) pk_message_enum_to_string (status);
                 ^
      CC       package-manager-ubuntu.o
      CC       transaction-view.o
      CC       report-view.o
      CC       utils.o
    utils.c: In function ‘http_download_file’:
    utils.c:257:3: warning: ‘soup_gnome_features_2_26_get_type’ is deprecated (declared at /usr/include/libsoup-gnome-2.4/libsoup/soup-gnome-features.h:20) [-Wdeprecated-declarations]
       http_session = soup_session_sync_new_with_options (SOUP_SESSION_ADD_FEATURE_BY_TYPE, SOUP_TYPE_GNOME_FEATURES_2_26,
       ^
      CCLD     intel-linux-graphics-installer
      CC       ilg_config_test-configuration.o
      CC       ilg_config_test-utils.o
    utils.c: In function ‘http_download_file’:
    utils.c:257:3: warning: ‘soup_gnome_features_2_26_get_type’ is deprecated (declared at /usr/include/libsoup-gnome-2.4/libsoup/soup-gnome-features.h:20) [-Wdeprecated-declarations]
       http_session = soup_session_sync_new_with_options (SOUP_SESSION_ADD_FEATURE_BY_TYPE, SOUP_TYPE_GNOME_FEATURES_2_26,
       ^
      CC       ilg_config_test-conftest.o
      CCLD     ilg-config-test
    make[3]: uscita dalla directory "/home/ziomario/Scrivania/intel-linux-graphics-installer_1.0.5/src"
    make[2]: uscita dalla directory "/home/ziomario/Scrivania/intel-linux-graphics-installer_1.0.5/src"
    Making all in images
    make[2]: ingresso nella directory "/home/ziomario/Scrivania/intel-linux-graphics-installer_1.0.5/images"
    make[2]: Nessuna operazione da eseguire per "all".
    make[2]: uscita dalla directory "/home/ziomario/Scrivania/intel-linux-graphics-installer_1.0.5/images"
    Making all in data
    make[2]: ingresso nella directory "/home/ziomario/Scrivania/intel-linux-graphics-installer_1.0.5/data"
    cd .. && /bin/bash ./config.status data/org.01.linuxgraphics.policy
    config.status: error: cannot find input file: `data/org.01.linuxgraphics.policy.none.in'
    Makefile:337: set di istruzioni per l'obiettivo "org.01.linuxgraphics.policy" non riuscito
    make[2]: *** [org.01.linuxgraphics.policy] Errore 1
    make[2]: uscita dalla directory "/home/ziomario/Scrivania/intel-linux-graphics-installer_1.0.5/data"
    Makefile:416: set di istruzioni per l'obiettivo "all-recursive" non riuscito
    make[1]: *** [all-recursive] Errore 1
    make[1]: uscita dalla directory "/home/ziomario/Scrivania/intel-linux-graphics-installer_1.0.5"
    Makefile:345: set di istruzioni per l'obiettivo "all" non riuscito
    make: *** [all] Errore 2

     

    What can I do ? Thanks.

    Jul 19, 2014 - 12:16pm
  • Hi - all the installer delivers is an updated version of what's in the target distributions: If you're running sid,
    you're almost certainly already ahead of what the installer would deliver anyway, so using it isn't going to
    do much for you (there's no proprietary or secret code here: just a packaged version of what's in mainline)

    Aug 12, 2014 - 07:44am