Sorry, you need to enable JavaScript to visit this website.

Intel graphics 1.4.0, 32bit Ubuntu 15.10 & Login Screen corruption

14 posts / 0 new
Chris Clemson's picture
Starter
Chris Clemson

Feb 23, 2016 - 04:06pm

  • Hello,

    I have an HP nc6320 Laptop that is running 32bit Ubuntu 15.10.

    I thought I'd try the Intel graphics installer 1.4.0 as there are some minor glitches with window movement and corner transparency on my machine.

    The drivers installed without error as far as I could see, but on reboot, the usual Ubuntu login screen did not appear.

     

    What happens now is the mouse pointer appears correctly, and can move around, and the ubuntu "drums" sound, but in the top 1cm (ish) , there is a ubuntu purple stripe, and the rest of the screen is blank.

    In this purple stripe, there are a few white pixels, that start off in the top left of the stripe, and as I move the mouse pointer around, more white pixels appear.

     

    If I type my password in as normal, my Ubuntu desktop appears as normal (sadly the screen corruption hasn't been fixed by this installation).

    While this is workable, if I ever need to log in to my machine as another user, I'm in trouble as I can't see the login screen to select other users or window managers.

     

    There are  warnings in the syslog file, but I don't know if this is important:

    WARNING: CPU: 0 PID: 113 at /var/lib/dkms/i915-4.3.3-4.2.0/2/build/drivers/gpu/drm/i915/intel_display.c:1391 assert_planes_disabled+0x100/0x140 [i915]()

    WARNING: CPU: 0 PID: 79 at /var/lib/dkms/i915-4.3.3-4.2.0/2/build/drivers/gpu/drm/drm_atomic.c:493 drm_atomic_check_only+0x4bf/0x5a0 [drm]()

    WARNING: CPU: 0 PID: 79 at /var/lib/dkms/i915-4.3.3-4.2.0/2/build/drivers/gpu/drm/i915/intel_fbdev.c:402 intel_fb_initial_config+0x2dc/0x5f0 [i915]()

    WARNING: CPU: 0 PID: 4 at /var/lib/dkms/i915-4.3.3-4.2.0/2/build/drivers/gpu/drm/i915/intel_fbdev.c:402 intel_fb_initial_config+0x2dc/0x5f0 [i915]()

    WARNING: CPU: 0 PID: 4 at /var/lib/dkms/i915-4.3.3-4.2.0/2/build/drivers/gpu/drm/i915/intel_display.c:11673 intel_plane_atomic_calc_changes+0x51c/0x690 [i915]()
    CPU: 0 PID: 4 at /var/lib/dkms/i915-4.3.3-4.2.0/2/build/drivers/gpu/drm/drm_atomic_helper.c:676 drm_atomic_helper_update_legacy_modeset_state+0x26a/0x280 [drm_kms_helper]()
    WARNING: CPU: 0 PID: 4 at /var/lib/dkms/i915-4.3.3-4.2.0/2/build/drivers/gpu/drm/i915/intel_display.c:1391 assert_planes_disabled+0x100/0x140 [i915]()
    gpu-manager[1196]: update-alternatives: warning: alternative /usr/lib/i386-linux-gnu/mesa/ld.so.conf (part of link group i386-linux-gnu_gl_conf) doesn't exist; removing from list of alternatives
     

    Is there anything I can check to find out why the login screen isn't displaying properly?

    Thanks

     

    Feb 23, 2016 - 04:06pm
  • Hm. That does sound nasty. I think you've probably already reported the items of interest - I'll pass them on to the dev team and see if they have anything to say about it. You should be able to remove the i915 update by doing the following:

    apt-get remove i915-4.3.3-4.2.0-dkms

    and then rebooting. Does that fix the problem? If so it's a bug in the backported i915 driver,
    in which case we'd be interested in the output of

    lspci -kvnn

    Feb 24, 2016 - 08:40am
  • Hi Vivek,

    Thank you for the quick reply.

    Yes, uninstalling i915-4.3.3-4.2.0-dkms seemed to fix the problem, and I have the normal login screen back.

    Before I did this, I ran the ubuntu software updater, and it did update the kernel to 4.2.0-31-generic (from -30), but that didn't make any difference.

    When I paste the output of lspci -kvnn below, it triggers the spam filter :(
    Please let me know if I can email it somewhere instead.

    Thanks,

    Chris

    Feb 25, 2016 - 01:42am
  • Hm - you should be able to mail me via the forum but I can't find the link - you can email vivek AT collabora DOT com
    If you have a chance to test, reinstalling that package, rebooting, and grabbing the `dmesg' output may also be very informative.

    Feb 25, 2016 - 09:48am
  • Hello,

    I had the same problem with the spam filter in another thread and solved it by using pastbin.

    http://pastebin.com/

    Feb 26, 2016 - 10:09am
  • I don't think I've seen an email from you (checked my spam trap just in case, nothing there either) - did you send anything to me? (Just want to be sure you aren't waiting for a reply from me).

    Mar 01, 2016 - 06:45am
  • Hi Vivek,

    Sorry, yes I did send you the output of dmesg as a .zip on the 25th.

    I will send it again now.

    Thanks!

     

    Chris

    Mar 01, 2016 - 11:40am
  • Hi - I found a report which looked similar and I'm trying out the proposed fix on the hardware I have here - I don't have any kit that displays the same problem though, so all I'll be able to confirm is that it doesn't break any of my test platforms - is there any chance you'd be able to try an updated i915 DKMS package?

    Mar 08, 2016 - 09:13am
  • By all means, so long as I can uninstall it again if there's problems!

    Thanks,

     

    Chris

     

    Mar 08, 2016 - 11:09am
  • Great - I think I've found the commit that introduced the problem, I'll see if I can reverse it reasonably in a copy of the i915 DKMS package for you.

    Mar 08, 2016 - 03:55pm
  • Excellent, I look forward to it :)

    Mar 09, 2016 - 01:17am