Sorry, you need to enable JavaScript to visit this website.

intel-linux-graphics-installer-1.0.7 installation failed

1 post / 0 new
He's picture
Starter
He

Feb 01, 2015 - 07:14pm

  • He's picture
    He

    I tired to make intel-linux-graphics-installer-1.0.7 in my gentoo linux ,but it failed:

    ...................................
    make[2]: Entering directory '/root/intel-linux-graphics-installer-1.0.7/data'
    cd .. && /bin/sh ./config.status data/org.01.linuxgraphics.policy
    config.status: error: cannot find input file: `data/org.01.linuxgraphics.policy.none.in'
    Makefile:336: recipe for target 'org.01.linuxgraphics.policy' failed
    make[2]: *** [org.01.linuxgraphics.policy] Error 1
    make[2]: Leaving directory '/root/intel-linux-graphics-installer-1.0.7/data'
    Makefile:415: recipe for target 'all-recursive' failed
    make[1]: *** [all-recursive] Error 1
    make[1]: Leaving directory '/root/intel-linux-graphics-installer-1.0.7'
    Makefile:344: recipe for target 'all' failed
    make: *** [all] Error 2

    .....................
    it seems there is no "org.01.linuxgraphics.policy.none.in" file in source package ,anybody knows how to fix it ?

    Feb 01, 2015 - 07:14pm
  • A few points are worth mentioning here:

    - You shouldn't build things as root! It's dangerous

    - The policy files have to be set up for each target distribution,
    as each one has a different package manager with slightly
    different requirements.

    - Apart from writing a policy file, you would also need to tweak the
    AC_ARG_WITH([distribution], entry in configure.ac (this is where
    the "none" is coming from).

    - Having done that, you would then need to write a backend for gentoo
    (you can see the package-manager-*.c files for examples) and tweak
    the package-manager.c code to invoke it when on gentoo.

    Feb 02, 2015 - 03:51pm