Sorry, you need to enable JavaScript to visit this website.

Issues with Intel 1.0.7 Installer

12 posts / 0 new
Ali Nauman's picture
Ali Nauman

Feb 22, 2015 - 07:27am

  • Hi guys


    I installed Intel 1.0.7 driver installer. Now my Synaptics touchpad is not working . I think this is due to the fact that it removed a lot of Mesa files. Any possible solution?


    Thanks in Advance.

    Feb 22, 2015 - 07:27am
  • Some questions which might shed light on the problem:

    Which distribution are you using?

    Did you save the list of packages added/removed?
    There should be a log of the installer's actions in /var/tmp.

    Did your xinput packages get removed for some reason?

    Do you have any other 3rd party repositories enabled?

    Feb 23, 2015 - 06:24am
  • Hi, everybody.

    As ali60351 commented, I installed Intel Graphics Drivers Installed on my HP Probook 4320s running Ubuntu 14.04 LTS (64 bits). After I rebooted, my Synaptics touchpad stopped to work. When I checked out the removed packages list, I noticed that xserver-xorg-input-synaptics-lts-utopic was removed. I installed xserver-xorg-input-synaptics (without lts-utopic, no particular reason for it: I only didn't realized which version was previously intalled until I carefully read my list of changes) from the package manager, and my trackpad worked fine again.

    The only thing I don't understand now is why the Graphics Driver removed xserver-xorg-input-wacom-lts-utopic.





    Mar 15, 2015 - 07:06pm
  • The LTS update for 14.04.2 appears to have introduced a parallel set of X packages instead of upgrading the existing Xorg packages: If you look you'll find a set of packages with -lts-utopic apprended to the name.

    What's happening is the installer adds its xorg packages: The package manager see this isn't compatible
    with the -lts-utopic package and has to remove that package. Unfortunately, there is no information to tell it that the -lts-utopic package is an upgrade to the xorg package, so it removes that package and all packages associated with it.

    I don't know why the LTS point release was done this way, but it makes it incompatible with the intel installer:
    If the LTS had simply released updated Xorg packages, the installer would have noted the LTS packages were more recent than its own and left them alone.

    Mar 16, 2015 - 10:46am
  • Earlier in this thread Vivek Das Mohapatra explained why 14.04.2 is incompatible with the Intel installer.

    Has anyone checked to see if the problem has been addressed in 14.04.3?  Would really like to use these drivers without having to stray from LTS if possible.


    Aug 15, 2015 - 11:45am
  • The same problem would occur _but_ happily applying the latest .3 hardware LTS support packs and LTS kernel update will get you newer drivers than the old installer would have provided anyway.

    Aug 17, 2015 - 07:57am
  • If you want to install the Intel GPU drivers you can install Ubuntu 14.04 LTS instead of 14.04.2 LTS. Or you could install a 14.04 varient like Zorin / Linux Mint. Don't go for fedora its not good at all. In my opinion Ubuntu 14.04 is the best. But if you want to game Windows 8.1 is the best.

    If you can't find the links or tutorials let me know.

    Mar 16, 2015 - 11:24am
  • So is there any route left available for users of Ubuntu 14.04 that want to use the Intel graphics installer?

    Installing Intel graphics installer v1.0.7 on Ubuntu 14.04.2 or Ubuntu 14.04 doesn't work, that gives 'distribution not supported' errors. I would be fine with using apt-pinning or other more difficult solutions.



    Apr 21, 2015 - 03:40am
  • Sorry, didn't use the fine search.... 

    The following forum post seems to offer help:

    Apr 21, 2015 - 04:11am
  • Thanks, ali60351.

    I installed 14.04.2 to test if it's updated kernel could fix an overheating issue that I was experiencing with 14.04. As the problem persisted and I was told it's probably related to the Intel video chip that comes with my machine, I installed the Intel Drivers package. For now, it seems this solved the overheating issue, but now I have this trouble with my Wacom tablet.

    I'll try by reinstalling 14.04 and installing the Intel Graphics Drivers there, although I'm afraid of the issue coming again.

    Once again, thanks for your suggestion.

    Kind regards.


    Mar 16, 2015 - 04:58pm
  • Now that Ubuntu 15.04 is out I have some more things to test out but I wanted to know that what made you install the Intel drivers at first place (overheating?).

    I tried Ubuntu 14.10 for quite a while only with the default drivers and had no problem. Although all I ever did was watched some movies, surf the internet and most of all do my work (coding, programming etc). I did try some F2P games(TF2, DOTA) but I didn't notice any difference in 14.10 and 14.04 (with drivers).

    I can't tell you about the Wacom Tab since I don't own one.

    What I did was I used Zorin and installed drivers with help of these :



    Sorry for the late reply I don't check my E-mail regularly.


    Apr 26, 2015 - 08:14am