Sorry, you need to enable JavaScript to visit this website.

Multiple Intel GPU drivers installed?

1 post / 0 new
Agostinho Carvalho's picture
Starter
Agostinho Carvalho

Oct 30, 2014 - 05:49am

  • Hello.

    I have a Debian 7.X system applied into a netbook with Intel Atom N2805 SoC.
    The embedded GPU is based on Intel HD Graphics series.

    Gnome 3 fails to load at startup. I think it's because of the old included driver.
    Does Debian already provide (in it's repositories) drivers for this GPU?
    What packages should I use?


    Also... please analyze the following scenario:

    1) Imagine that Debian comes with Mesa 8.XX

    2) Now, imagine that I manually compile Mesa 10.XX (to obtain updated support for 3D rendering). At that moment, will I have two Mesa versions installed? Which one will be actively in use? In case Mesa 10.XX is actively in use, should I remove Mesa 8.XX?

    3) If, during next month or so, Debian repositories update it's Mesa version to 9.XX and I run System Update, what driver will prevail in my system? I mean... will Mesa 9.XX (from the repos), "destroy" my manually compiled Mesa 10.XX which was more recent?

    Thank you.

    Oct 30, 2014 - 05:49am
  • There are two ways you could build the newer mesa locally:

    - You could just compile it and install it in /usr/local without packaging it
    - You could build a newer package

    If you build a package (eg by fetching from jessie's repo and rebuilding it and any
    dependencies on wheezy) then you will only have one version and updates to
    your distro won't replace it automatically unless they would actually be upgrades
    (so 9.x wouldn't be installed because you already had 10.x, but 10.y would be installed
    on upgrade if it became available).

    If you install a library under /usr/local or /opt or wherever, then:

    -The library will only get linked at runtime or build time if the linker knows to look for it there
    (this should be the case for /usr/local/… by default)
    - The most library used will depend on the search path for the linker: Typically /usr/local
    would be searched first, so you'd likely get that library
    - This is only true for libraries with the same major version. So libGL.so.1.2.1 in /usr/local
    would still (I think) win out over libGL.so.1.2.3 in /usr (these are just examples).
    - Since packaging never touches /usr/local, any distro packages would co-exist with
    your locally installed version.
    - If the major versions are different, then the program will only use a library with the
    major version it is expecting.

    HTH

    Nov 11, 2014 - 06:37am