Sorry, you need to enable JavaScript to visit this website.

Need to downgrade?

2 posts / 0 new
Iversen's picture
Starter
Iversen

Nov 03, 2014 - 05:36am

  • Hello.

    I have used intel graphics installer 1.0.6 to install i915 driver on ubuntu 14.04lts.

    When starting x it falls back to some default intel driver and after examening dmesg I find this line:

    i915: module has bad taint, not creating trace events

    What can I do to fix it.

    I have searched the net and found suggestion to downgrade to version 1.0.5.

    But I havent found 1.0.5 to download.

    regards

    Kjartan

     

     

    Nov 03, 2014 - 05:36am
  • As far as I can tell 1.0.5 is not easy to find. Every well known site where I found a link to it directed me back to the 1.0.6 download. If a community member here has a copy that may be the best option for a legitimate version of 1.0.5

    I will check my archive backups & see if I still have it.

    Nov 03, 2014 - 01:54pm
  • The "Bad Taint" message is triggered by a kernel bug - the upstream kernel developers decided (at one point) that there was no possible use case for kernel modules being built outside the main kernel tree, and that all such modules should be flagged with the same warning as modules that were incompatible, but forcibly loaded.

    This bug has since been corrected (in 3.15.x kernels and later, upstream, and in more recent ubuntu kernel updates for 3.13.x too).

    To summarise:

    • The warning is wrong (and unrelated to any display bugs you are experiencing)
    • Unless you need to trace the kernel or debug it, it won't break anything for you
    • It is fixed in recent ubuntu updates

    If you want to try removing the updated driver to see if it is the source of your display problems, you can remove the i915-3.15-3.13-dkms package and reboot, and you'll be back to what ships with vanilla ubuntu.

    Nov 04, 2014 - 07:36am