Sorry, you need to enable JavaScript to visit this website.

New Ubuntu 16.04 packages use unknown key (again)

59 posts / 0 new
Martin van Es's picture
Starter
Martin van Es

Aug 31, 2016 - 02:20am

  • i can't believe, you still didn't fix that issue. shame on you.

    Oct 21, 2016 - 07:30am
  • Afaik to their understanding this is not an issue but wanted.

    Oct 21, 2016 - 09:02am
  • Ok seriously now, we need this done. 

     

    Who is the Github committer? This needs to work, I cannot work without my GPU functioning and being recognized by the Ubuntu system. 

     

    It is a simple fix, if someone from Intel actually wants to solve this issue. Come on devs, you can do it! 

    Oct 24, 2016 - 07:58am
  • i have solved that issue on Ubuntu 16.10 kylin by using RPM-GPG-GROUP-KEY-ilg  instead of RPM-GPG-KEY-ilg-4

    from that directory

    https://download.01.org/gfx/

     

    and command would be like that for it

    
    
    

    @page { margin: 0.79in } pre.cjk { font-family: "Nimbus Mono L", monospace } p { margin-bottom: 0.1in; line-height: 120% } code.cjk { font-family: "Nimbus Mono L", monospace }

    wget --no-check-certificate https://download.01.org/gfx/RPM-GPG-GROUP-KEY-ilg -O - | sudo apt-key add -

     

    and don't forget to update and upgrade your packages after that using

    sudo apt-get update

    sudo apt-get upgrade

    i think it would solve it for all those who got " weak digest algorithm (SHA1) "

     

    Salam

    Nov 29, 2016 - 11:48am
  • Hi, 

    I am using Linux Mint 18.1 (Ubuntu 16.04) and I also get the error:

    W: https://download.01.org/gfx/ubuntu/16.04/main/dists/xenial/InRelease: Signature by key 09D6EF97BFB38E916EF060E756A3DEF863961D39 uses weak digest algorithm (SHA1)

     

    I've tried several commands from this thread and also the one in the 01.org tool webpage:

    wget --no-check-certificate https://download.01.org/gfx/RPM-GPG-KEY-ilg-4 -O - | sudo apt-key add -
    wget --no-check-certificate https://download.01.org/gfx/RPM-GPG-KEY-ilg-4 -O - | \
    sudo apt-key add -

    wget --no-check-certificate https://download.01.org/gfx/RPM-GPG-GROUP-KEY-ilg -O - | sudo apt-key add - 

     

    All of them followed by apt-get update and upgrade but none solved the issue. 

    Is there a solution to this problem?

    Thanks

    Jan 10, 2017 - 12:57am
  • That is only a warning, not an error - it should not stop anything from working. Later releases use a stronger hash algorithm for signing which shouldn't trigger that warning.

    Jan 10, 2017 - 08:06am
  • Hi Vivek. Thanks for your response. I tried a few commands to get rid of it I guess I messed with the repositories and I was getting a new update to libdrm (from 2.4.68-1 to 2.4.70-1) that wanted to unistall around 100 packages. I had to manually add again the 'deb https://download.01.org/gfx/ubuntu/16.04/main xenial main Intel Graphics drivers' to create again in 'intellinuxgraphics.list'. Now I don't get that update anymore for that package but now I can see them as 'kept back'. Should these packages stay like this?

    Jan 10, 2017 - 10:06pm
  • These are the packages being held back:

     $ sudo apt-get upgrade
    Los siguientes paquetes se han retenido:
      libdrm-amdgpu1 libdrm-intel1 libdrm-nouveau2 libdrm-radeon1 libdrm2
      libegl1-mesa libegl1-mesa:i386 libgl1-mesa-dri libgl1-mesa-dri:i386
      libwayland-client0 libwayland-cursor0 libwayland-egl1-mesa
      libwayland-egl1-mesa:i386 libwayland-server0 mp
    Jan 10, 2017 - 10:10pm
  • I've tried re-running the Intel Graphics Update Tool again but now I get a dependencies error:

    Error running transaction: GDBus.Error:org.debian.apt.TransactionFailed: error-dep-resolution-failed: The following packages have unmet dependencies:
    
    libegl1-mesa: Depends: libgl1-mesa-dri (= 12.0.3-1ubuntu1~ubuntu16.04.1~ppa1) but 12.0.3-1ubuntu1~ubuntu16.04.1~ppa1 is to be installed)
     
    Tried manually updating these packages (and the held ones) with Synaptic and in most of them it asks me to uninstall many packages. 
    Recently I updated my Mint 18 (Ubuntu 16.04) to Mint 18.1 so maybe that is the reason why it all got messed up? Any way to get things back to normal?
    Jan 10, 2017 - 11:25pm
  • Finally I managed to re-run the  Intel Graphics Update Tool and update almost all the held packages without any warnings, except for the last three:

    libwayland-client0 libwayland-cursor0 libwayland-server0
     
    But installing these will result on uninstalling some of the mesa packages previously installed. I guess it is a problem of compatibility between files versions? Is this normal?:
    $apt-cache policy libwayland-client0 libwayland-cursor0 libwayland-server0
    
    libwayland-client0:
    
      Installed: 1.9.0-1
    
      Candidate:  1.11.0-2~ubuntu16.04.1~ppa1
    
    libwayland-cursor0:
    
      Installed: 1.9.0-1
    
      Candidate:  1.11.0-2~ubuntu16.04.1~ppa1
    
    libwayland-server0:
    
      Installed: 1.9.0-1
    
      Candidate:  1.11.0-2~ubuntu16.04.1~ppa1
    Jan 11, 2017 - 01:02am