Sorry, you need to enable JavaScript to visit this website.

Problem with Hybrid system

11 posts / 0 new
Michele de Rosa's picture
Starter
Michele de Rosa

May 07, 2013 - 02:07am

  • Hi all,

    I'm new of this forum and I have a problem with my "Dell Vostro 3560" laptop. The laptop has an ATI 7670M and an integrated Intel HD4000 (CPU I7 3632QM), while the O.S. is OpenSUSE 11.4, kernel 2.6.37.6-24 64 bits. The problem is that I am unable to drive the graphics (both ATI and Intel) and so I have to run my graphics in "safe mode" using the radeon drivers, which perform very poor. The Intel drivers version, I installed, is 2.17 and I'm unable to install the 2.20 or higher version. Please, could anyone help me?

    Thanks a lot

    Michele

    May 07, 2013 - 02:07am
  • Hi micder,

    It is always complicated to deal with hybrid systems, mainly when you are using a so old linux kernel.

    So, my first question to you is: would it be possible to upgrade your kernel our your distribution to newer versions?

    Anyways, I'm not promissing that this will fix all issues you are facing, but it is a good start point.

    Unfortunatelly there is nothing we can do for you right now with this old kernel, but once you get it upgraded any other issues can be reported at https://bugs.freedesktop.org/.

    Thanks,

    Rodrigo.

    May 07, 2013 - 09:43am
  • Hi Rodrigo,

    thank a lot for your reply. For the moment I cannot upgrade my system, because I'm using it for my work. I swapped my hdd from one laptop to another (newer) one. All works well but the graphics. I think the problem is the Intel driver, because when X starts it fails with the following error:

    297.191] (--) Chipset Supported AMD Graphics Processor (0x6840) found
    [   297.192] (II) fglrx: intel VGA device detected, load intel driver.
    [   297.192] (II) LoadModule: "intel"
    [   297.193] (II) Loading /usr/lib64/xorg/modules/drivers/intel_drv.so
    [   297.194] (II) Module intel: vendor="X.Org Foundation"
    [   297.194]    compiled for 1.9.3, module version = 2.17.0
    [   297.194]    Module class: X.Org Video Driver
    [   297.194]    ABI class: X.Org Video Driver, version 8.0
    [   297.194] (II) AMD Video driver is running on a device belonging to a group targeted for this release
    [   297.194] (II) AMD Video driver is signed
    [   297.194] (II) fglrx(0): pEnt->device->identifier=0x80b140
    [   297.226]
    Fatal server error:
    [   297.226] atiddxProbe: fail to probe intel VGA device

    I think that the problem is the Intel driver version, which doesn't support the graphic card (Intel HD 4000). I am unable to install the 2.20 (or higher) driver version for my kernel version. Is it a way to compile it on my platform?

     

    Thanks again

     

    Michele

    May 08, 2013 - 02:08am
  • Hi Michele,

    atiddxProbe that is failing is probably a fglrx function. That is a closed source X driver. Although it tries to support intel kernel driver (i915) I've never seen it fully working. And since it is a closed driver, unfortunatelly, there is nothing we can do nor compile it.

    Ok, /usr/lib64/xorg/modules/drivers/intel_drv.so is probably part of Intel's X driver (xf86-intel-video) and it's being loaded by X, but it doesn't seem it is trying to use it. So I would suggest you to change your xorg.conf telling it to use "intel" Driver instead of "fglrx".

    Anyway you might check if Intel's kernel driver is loaded: "$ lsmod | grep i915" in a cmdline. 

    Another possibilitie here is to use a tool called aticonfig and switch the board.

    After playing with this xorg.conf and this tool, if you are still facing any issue, please post what board is in use according to aticonfig, lsmod output, xorg.conf and Xorg.log.

    May 09, 2013 - 06:54am
  • Hi Rodrigo,

    probably you are right. The intel driver is not loaded, because the lsmod command show me nothing. This is the xorg.conf content:

    Section "ServerLayout"
            Identifier     "aticonfig Layout"
            Screen      0  "aticonfig-Screen[0]-0" 0 0
    EndSection

    Section "Module"
    EndSection

    Section "Monitor"
            Identifier   "aticonfig-Monitor[0]-0"
            Option      "VendorName" "ATI Proprietary Driver"
            Option      "ModelName" "Generic Autodetecting Monitor"
            Option      "DPMS" "true"
    EndSection

    Section "Device"
            Identifier  "aticonfig-Device[0]-0"
            Driver      "fglrx"
            BusID       "PCI:1:0:0"
    EndSection

    Section "Screen"
            Identifier "aticonfig-Screen[0]-0"
            Device     "aticonfig-Device[0]-0"
            Monitor    "aticonfig-Monitor[0]-0"
            DefaultDepth     24
            SubSection "Display"
                    Viewport   0 0
                    Depth     24
            EndSubSection
    EndSection
     

    In your opinion, does changing the Driver to "i915" and the BusID to "PCI:0:2:0" solve the problem? Actually I'm using the radeon driver, but the performance are very poor (fan runs always).

     

    Bye

     

    Michele

     

    May 09, 2013 - 07:40am
  •  

    Hi Michele,

    No, i915 is the kernel driver. X option should be "intel" instead. However the i915 must be loaded.  If the kernel driver isn't loaded the X driver doesn't work anyway.

    Have you tried the aticonfig tool? If you switch between graphics and reboot I'd say that your problems will be solved. hopefully.

    But regarding the performance, usually on the hybrid, the intel has a low performance overal, but better power savings. Is that what you really want?

    It seems there is a way of disable the boring fan noise according: http://xpressrazor.wordpress.com/2013/01/13/how-to-setup-amdintel-hybrid-graphics-cards-in-linux-ubuntu/

    But I have no idea if that works. Anyway, try to play with aticonfig first. 

     

    May 09, 2013 - 07:56am
  • Hi Rodrigo,

    I'll try and cross the fingers :) Is the switch command "switchlibglx"?

    Thanks a lot

    Michele

    May 09, 2013 - 08:10am
  • Hi Rodrigo,

    following your advise, I noted that the dmesg command shows me the following error:

     

    [drm:i915_init] *ERROR* drm/i915 can't work without intel_agp module!

     

    So, the i915 driver isn't loaded. How could I solve this problem?

     

    Bye

     

    Michele

    May 10, 2013 - 01:00am
  • Hi Rodrigo,

    any news?

    Bye

    May 13, 2013 - 01:33am
  • Hi Michele,

    have you tried "modprobe intel_agp"?

    from a quicly google it seems fglrx (AMD closed driver) doesn't work when intel_agp is on so I'd say your distribution might have removed this at all or blacklisted it.

    If  it is removed you will have to install it with zypper or yast. But might break fglrxf. If it installed you probably need to remove from blacklist and add it to automatically load at boot. Don't know how to do it on your distro.

    About The "aticonfig" command I mentioned, it shows a nice graphical window where you can switch between graphics and last time I used in a suse system it worked fine... I didn't had to modprobe any modules manually. But it was a newer suse version.

     

    May 13, 2013 - 06:33am
  • Hi Rodrigo,

    there is an update of my kernel (from 2.6 to 3.0) for my opensuse version. I hope that this update could solve some of my problems. I'll inform you if any news.

     

    Bye

     

    Michele

    May 13, 2013 - 08:21am