Sorry, you need to enable JavaScript to visit this website.

Troubles with Intel Graphics Installer 1.4.0 instalation to Linux Mint 17.3

1 post / 0 new
Andrew Maslov's picture
Starter
Andrew Maslov

May 10, 2016 - 10:18am

  • Hello,

     

    I'm trying to install Intel Graphics drivers - Graphics Installer 1.4.0 for Ubuntu* 15.10, 64-bit into Linux Mint 17.3. And I've faced with a trouble. When I run that deb package it says "Error: Dependency is not satisfiable: libgtk-3-0 (>= 3.16.2)". I have libgtk-3-0:amd64 3.10.8~8+qiana installed in my system. I was trying to find some information how to update gtk to 3.16.2 for my case, but haven't able to find a correct way how to do this. Can someone advise how to update libgtk to newer version or maybe some workaround to install the intel grapgics driver? Without this driver my Linux Mint can't shutdown or reboot properly. It hangs with errors like this: "BUG: soft lockup - CPU#5 stuck for 22s!". Only adding acpi=off option on boot helps to avoid this problem, but it turns off a lot of functionality of my leptop like touchpad, batarey manager, FN keys etc.

     

    Thank you!

    May 10, 2016 - 10:18am
  • Hi - Mint 17.3 is based on ubuntu 14.04 which is an LTS release - this means your best bet for getting an updated i915 kernel module is to install the 14.04 enablement stack from ubuntu - You can find instructions here:

    https://wiki.ubuntu.com/Kernel/LTSEnablementStack#Trusty

    That should get you up and running with a newer kernel (4.2) instead of the 3.19 kernel Mint 17.3 ships with, which is hopefully new enough to fix your display problems.

    May 10, 2016 - 11:46am