Sorry, you need to enable JavaScript to visit this website.

Ubuntu 14.04 (32bit) mouse pointer corrupted

12 posts / 0 new
g browne's picture
Starter
g browne

Jan 10, 2015 - 09:29am

  • Have intalled the Intel graphics driver stack on our Dell Dimension 3100C running Ubuntu 14.04 32bit
    and all seems to have gone well. Working fine (and quite quickly) except that the mouse cursor is now somewhat corrupted.

    All the image information still seems to be there and to move around, but it is chopped vertically into around 11 slices separated by screen image.  The tip of the 'cursor' still points to the hotspot onscreen and the slices change according to the function of the pointer on the screen, so it's nearly working.

    This behaviour begins the moment the PC boots X.

    Any hints or suggestions would be gratefully received.

    GB.

     

    Jan 10, 2015 - 09:29am
  • Just used the intel linux graphics installer. Works great except the mouse pointer is distorted exactly like he describes. Still fully functional but its rather annoying, Any ideas on a fix?

    Jan 17, 2015 - 12:34pm
  • Could you tell me which exact hardware you see this on? The output of lspci -vnn would do.

    Jan 19, 2015 - 07:27am
  • Same issue on my old ibm z60t.

    00:02.1 Display controller [0380]: Intel Corporation Mobile 915GM/GMS/910GML Express Graphics Controller [8086:2792] (rev 03)
    Subsystem: IBM Device [1014:058c]
    Flags: fast devsel
    Memory at 80200000 (32-bit, non-prefetchable) [disabled] [size=512K]
    Capabilities: <access denied>
    Jan 23, 2015 - 07:45am
  • 00:02.0 VGA compatible controller [0300]: Intel Corporation Mobile 915GM/GMS/910GML Express Graphics Controller [8086:2592] (rev 03) (prog-if 00 [VGA controller])
    Subsystem: IBM Device [1014:058c]
    Flags: bus master, fast devsel, latency 0, IRQ 16
    Memory at a0080000 (32-bit, non-prefetchable) [size=512K]
    I/O ports at 1800 [size=8]
    Memory at c0000000 (32-bit, prefetchable) [size=256M]
    Memory at a0040000 (32-bit, non-prefetchable) [size=256K]
    Expansion ROM at <unassigned> [disabled]
    Capabilities: <access denied>
    Kernel driver in use: i915
     
    Jan 23, 2015 - 07:51am
  • Thanks for the extra details - I'll flag it up with the developers and see what they say.

    Jan 26, 2015 - 10:31am
  • Hello, I tested Ubuntu 14.04 and Fedora 20 with the latest installer, same bug.

    Hardware is a Dell Latitude D610, no problem with the stock drivers and full patches.

     

    Regards

    Riccardo

    [raffaella@d610 ~] $ lspci -vnn
    00:00.0 Host bridge [0600]: Intel Corporation Mobile 915GM/PM/GMS/910GML Express Processor to DRAM Controller [8086:2590] (rev 03)
        Subsystem: Dell Dell Latitude C610 [1028:0182]
        Flags: bus master, fast devsel, latency 0
        Capabilities: <access denied>
        Kernel driver in use: agpgart-intel

    00:02.0 VGA compatible controller [0300]: Intel Corporation Mobile 915GM/GMS/910GML Express Graphics Controller [8086:2592] (rev 03) (prog-if 00 [VGA controller])
        Subsystem: Dell Device [1028:0182]
        Flags: bus master, fast devsel, latency 0, IRQ 16
        Memory at dff00000 (32-bit, non-prefetchable) [size=512K]
        I/O ports at ec38 [size=8]
        Memory at c0000000 (32-bit, prefetchable) [size=256M]
        Memory at dfec0000 (32-bit, non-prefetchable) [size=256K]
        Expansion ROM at <unassigned> [disabled]
        Capabilities: <access denied>
        Kernel driver in use: i915
        Kernel modules: i915

    00:02.1 Display controller [0380]: Intel Corporation Mobile 915GM/GMS/910GML Express Graphics Controller [8086:2792] (rev 03)
        Subsystem: Dell Device [1028:0182]
        Flags: bus master, fast devsel, latency 0
        Memory at dff80000 (32-bit, non-prefetchable) [size=512K]
        Capabilities: <access denied>

    cut to prevent spam filter

    Jan 30, 2015 - 11:56am
  • I have same problem in Ubuntu 14.04 with my IBM ThinkCentre 8122 AWG (MB with Intel 915G chip). After installing "intel-linux-graphics-installer_1.0.7-0intel1_i386.deb" mouse pointer was corrupted like on the picture above. With original Ubuntu 14.04 drivers it was OK.

    Same time I saw that, when I watch Youtube 720p video, CPU usage is lower that with default Ubuntu VGA drivers.

    I need help too!

    Jan 31, 2015 - 07:40am
  • Thanks for the extra data point - I'll pass on the info.

    Feb 02, 2015 - 03:54pm
  • Same cursor rendering problem on my IBM T42 laptop. The rest of the Intel GPU driver works fine.

    $ uname -a
    Linux think 3.13.0-24-generic #46-Ubuntu SMP Thu Apr 10 19:08:14 UTC 2014 i686 i686 i686 GNU/Linux
     

     $ lspci -vnn

    00:00.0 Host bridge [0600]: Intel Corporation Mobile 915GM/PM/GMS/910GML Express Processor to DRAM Controller [8086:2590] (rev 03)
    Subsystem: IBM ThinkPad Z60t [1014:0575]
    Flags: bus master, fast devsel, latency 0
    Capabilities: <access denied>
    Kernel driver in use: agpgart-intel
     
    00:02.0 VGA compatible controller [0300]: Intel Corporation Mobile 915GM/GMS/910GML Express Graphics Controller [8086:2592] (rev 03) (prog-if 00 [VGA controller])
    Subsystem: IBM Device [1014:0582]
    Flags: bus master, fast devsel, latency 0, IRQ 16
    Memory at 90080000 (32-bit, non-prefetchable) [size=512K]
    I/O ports at 1800 [size=8]
    Memory at b0000000 (32-bit, prefetchable) [size=256M]
    Memory at 90000000 (32-bit, non-prefetchable) [size=256K]
    Expansion ROM at <unassigned> [disabled]
    Capabilities: <access denied>
    Kernel driver in use: i915
     
    00:02.1 Display controller [0380]: Intel Corporation Mobile 915GM/GMS/910GML Express Graphics Controller [8086:2792] (rev 03)
    Subsystem: IBM Device [1014:0582]
    Flags: fast devsel
    Memory at 80200000 (32-bit, non-prefetchable) [disabled] [size=512K]
    Capabilities: <access denied>
     
    Feb 11, 2015 - 02:48pm
  • Filed a bug here: https://bugs.freedesktop.org/show_bug.cgi?id=89191

    Hopefully info will be forthcoming about roughly where/when it was fixed.

    Feb 17, 2015 - 02:02pm