Sorry, you need to enable JavaScript to visit this website.

ubuntu 14.10 disconnected dp port

7 posts / 0 new
urban14's picture
Starter
urban14

Sep 01, 2015 - 12:30am

  • hello,

    i have no output to DP port at ubuntu!!

    Windows works with this DP port!!!!!!

     

     

    my systemparameter:

    board: intel baytrail

    ubuntu 14.10

    kernel : 3.16.0.-41.55

    driver: 00.2.0 VGA omptibl controller (0300): Intel Corportion Atom Processor Z6xx/Z3xxx Series Graphics & Dislpay(80860f31) (rev0e) Subssystem: Intel Corpartion Atom Processor Z36xxx/Z37xxx Series Graphics & Display (8086:0f31) Kernel driver in use: i915

    file: intl_dp.c   > 150,2 kB

     

    xrandr-q

    DP1 disconnected

    DP2 disconnected

    HDMI1 disconnected

    HDMI2 disconnected

    VGA conneced

    xrandr --newmode  xxx

    xrandr  -- addmode DP1 xxx

    xrandr --output DP1 xxx

    >>>> DP1 no output

    >>>> DP1 disconnected

    xrandr configure crtc 0 failed

     

     

     

    Have you solution for this problem?

     

    BS

    urban4

    Sep 01, 2015 - 12:30am
  • Is it possible for you to check to see if the setup works with a different monitor connected via displayport?
    Just to rule that out as a possibility. It's also worth checking with Ubuntu directly since you appear to be using
    their standard kernel ratrher than the updated version from 01.org.

    Sep 14, 2015 - 04:22pm
  • Thank you,

    the display is ok!

     

    With Windows I have an image!!!

    Sep 16, 2015 - 02:16am
  • i will install kernel 4.2.

    DP-Port disconnected!!!

     

     

     

    Sep 20, 2015 - 11:33pm
  • Just to be clear:

    You installed 4.2 and it still didn't work?
    Or you are going to try 4.2 but you haven't yet?

    I've asked some people who know more than I do about this how they'd
    proceed with debugging this problem, I'll post here when I have an answer.

    Sep 22, 2015 - 06:09am
  • Hello,

    thank you for your answer!!!!

     

    I have install the ubuntu 15.04 with 4.2 kernel and the new driver!

     

    BS

     

    The new dmesg report:

     

    10.650467] [drm] Driver supports precise vblank timestamp query.

    [   10.650470] [drm:init_vbt_defaults] Set default to SSC at 100000 kHz

    [   10.650474] [drm:validate_vbt] Using VBT from OpRegion: $VBT VALLEYVIEW     d

    [   10.650478] [drm:parse_general_features] BDB_GENERAL_FEATURES int_tv_support 0 int_crt_support 1 lvds_use_ssc 0 lvds_ssc_freq 120000 display_clock_mode 0 fdi_rx_polarity_inverted 0

    [   10.650481] [drm:parse_general_definitions] crt_ddc_bus_pin: 2

    [   10.650484] [drm:parse_lfp_panel_data] DRRS supported mode is static

    [   10.650488] [drm:parse_lfp_panel_data] Found panel mode in BIOS VBT tables:

    [   10.650492] [drm:drm_mode_debug_printmodeline] Modeline 0:"800x600" 0 40000 800 832 912 1056 600 603 607 628 0x8 0xa

    [   10.650495] [drm:parse_lfp_panel_data] VBT initial LVDS value 42100300

    [   10.650498] [drm:parse_lfp_backlight] VBT backlight PWM modulation frequency 200 Hz, active high, min brightness 0, level 0

    [   10.650501] [drm:parse_sdvo_device_mapping] No SDVO device info is found in VBT

    [   10.650504] [drm:parse_driver_features] DRRS State Enabled:0

    [   10.650507] [drm:parse_psr] No PSR BDB found.

    [   10.650518] [drm:intel_dsm_pci_probe] no _DSM method for intel device

    [   10.650528] [drm:i915_gem_init_stolen] found 67108864 bytes of stolen memory at bb000000

    [   10.657991] [drm:intel_display_power_get] enabling always-on

    [   10.657996] [drm:intel_display_power_get] enabling display

    [   10.659604] [drm:intel_display_power_get] enabling dpio-tx-b-01

    [   10.661618] [drm:intel_display_power_get] enabling dpio-tx-b-23

    [   10.663745] [drm:intel_display_power_get] enabling dpio-tx-c-01

    [   10.665761] [drm:intel_display_power_get] enabling dpio-tx-c-23

    [   10.667614] [drm:intel_display_power_get] enabling dpio-common

    [   10.706095] [drm:intel_modeset_init] 2 display pipes available.

     

     

     

     

    ………

    10.706095] [drm:intel_modeset_init] 2 display pipes available.

    [   10.706118] vgaarb: device changed decodes: PCI:0000:00:02.0,olddecodes=io+mem,decodes=io+mem:owns=io+mem

    [   10.706520] [drm:intel_crt_reset] crt adpa set to 0xf40018

    [   10.706645] [drm:intel_dp_init_connector] Adding DP connector on port B

    [   10.706704] [drm:intel_dp_aux_init] registering DPDDC-B bus for card0-DP-1

    [   10.706885] i2c-dev: adapter [DPDDC-B] registered as minor 6

    [   10.706911] i2c i2c-6: adapter [DPDDC-B] registered

    [   10.707085] [drm:intel_dp_init_connector] Adding DP connector on port C

    [   10.707137] [drm:intel_dp_aux_init] registering DPDDC-C bus for card0-DP-2

    [   10.707773] i2c-dev: adapter [DPDDC-C] registered as minor 7

    [   10.707806] i2c i2c-7: adapter [DPDDC-C] registered

    [   10.707938] [drm:intel_dsi_init]

    [   10.710095] [drm:intel_modeset_readout_hw_state] [CRTC:21] hw state readout: enabled

    [   10.710100] [drm:intel_modeset_readout_hw_state] [CRTC:26] hw state readout: disabled

    [   10.710105] [drm:intel_modeset_readout_hw_state] [ENCODER:30:DAC-30] hw state readout: disabled, pipe A

    [   10.710108] [drm:intel_modeset_readout_hw_state] [ENCODER:31:TMDS-31] hw state readout: disabled, pipe A

    [   10.710112] [drm:intel_modeset_readout_hw_state] [ENCODER:36:TMDS-36] hw state readout: disabled, pipe A

    [   10.710115] [drm:intel_modeset_readout_hw_state] [ENCODER:38:TMDS-38] hw state readout: disabled, pipe A

    [   10.710121] [drm:intel_modeset_readout_hw_state] [ENCODER:40:TMDS-40] hw state readout: enabled, pipe A

    [   10.710124] [drm:intel_modeset_readout_hw_state] [CONNECTOR:29:VGA-1] hw state readout: disabled

    [   10.710128] [drm:intel_modeset_readout_hw_state] [CONNECTOR:32:HDMI-A-1] hw state readout: disabled

    [   10.710131] [drm:intel_modeset_readout_hw_state] [CONNECTOR:37:DP-1] hw state readout: disabled

    [   10.710134] [drm:intel_modeset_readout_hw_state] [CONNECTOR:39:HDMI-A-2] hw state readout: disabled

    [   10.710137] [drm:intel_modeset_readout_hw_state] [CONNECTOR:41:DP-2] hw state readout: enabled

    [   10.710144] [drm:intel_dump_pipe_config] [CRTC:21][setup_hw_state] config ffff8800abbd4400 for pipe A

    [   10.710146] [drm:intel_dump_pipe_config] cpu_transcoder: A

    [   10.710149] [drm:intel_dump_pipe_config] pipe bpp: 24, dithering: 0

    [   10.710152] [drm:intel_dump_pipe_config] fdi/pch: 0, lanes: 0, gmch_m: 0, gmch_n: 0, link_m: 0, link_n: 0, tu: 0

    [   10.710155] [drm:intel_dump_pipe_config] dp: 1, gmch_m: 1864135, gmch_n: 8388608, link_m: 77672, link_n: 524288, tu: 64

    [   10.710157] [drm:intel_dump_pipe_config] dp: 1, gmch_m2: 0, gmch_n2: 0, link_m2: 0, link_n2: 0, tu2: 0

    [   10.710160] [drm:intel_dump_pipe_config] audio: 0, infoframes: 0

    [   10.710162] [drm:intel_dump_pipe_config] requested mode:

    [   10.710166] [drm:drm_mode_debug_printmodeline] Modeline 0:"" 0 0 640 0 0 0 480 0 0 0 0x0 0x0

    [   10.710168] [drm:intel_dump_pipe_config] adjusted mode:

    [   10.710171] [drm:drm_mode_debug_printmodeline] Modeline 0:"" 0 0 0 0 0 0 0 0 0 0 0x0 0x5

    [   10.710175] [drm:intel_dump_crtc_timings] crtc timings: 39999 800 832 912 1056 600 603 607 628, type: 0x0 flags: 0x5

    [   10.710177] [drm:intel_dump_pipe_config] port clock: 270000

    [   10.710179] [drm:intel_dump_pipe_config] pipe src size: 640x480

    [   10.710182] [drm:intel_dump_pipe_config] num_scalers: 0, scaler_users: 0x0, scaler_id: 0

    [   10.710185] [drm:intel_dump_pipe_config] gmch pfit: control: 0x80000000, ratios: 0x0ccd0ccd, lvds border: 0x00000000

    [   10.710187] [drm:intel_dump_pipe_config] pch pfit: pos: 0x00000000, size: 0x00000000, disabled

    [   10.710189] [drm:intel_dump_pipe_config] ips: 0

    [   10.710191] [drm:intel_dump_pipe_config] double wide: 0

    [   10.710194] [drm:intel_dump_pipe_config] dpll_hw_state: dpll: 0xf0002000, dpll_md: 0x3, fp0: 0x0, fp1: 0x0

    [   10.710196] [drm:intel_dump_pipe_config] planes on this crtc

    [   10.710200] [drm:intel_dump_pipe_config] STANDARD PLANE:18 plane: 0.0 idx: 0 disabled, scaler_id = 0

    [   10.710203] [drm:intel_dump_pipe_config] CURSOR PLANE:20 plane: 0.1 idx: 1 disabled, scaler_id = 0

    [   10.710206] [drm:intel_dump_pipe_config] STANDARD PLANE:22 plane: 0.1 idx: 2 disabled, scaler_id = 0

    [   10.710209] [drm:intel_dump_pipe_config] STANDARD PLANE:23 plane: 0.2 idx: 3 disabled, scaler_id = 0

    [   10.710213] [drm:intel_dump_pipe_config] [CRTC:26][setup_hw_state] config ffff8800abbd5000 for pipe B

    [   10.710215] [drm:intel_dump_pipe_config] cpu_transcoder: B

    [   10.710217] [drm:intel_dump_pipe_config] pipe bpp: 0, dithering: 0

    [   10.710220] [drm:intel_dump_pipe_config] fdi/pch: 0, lanes: 0, gmch_m: 0, gmch_n: 0, link_m: 0, link_n: 0, tu: 0

     

    …….

     

    10.755453] [drm:drm_do_probe_ddc_edid] drm: skipping non-existent adapter i915 gmbus dpb

    [   10.755456] [drm:drm_helper_probe_single_connector_modes_merge_bits] [CONNECTOR:32:HDMI-A-1] status updated from 3 to 2

    [   10.755464] [drm:drm_helper_probe_single_connector_modes_merge_bits] [CONNECTOR:32:HDMI-A-1] disconnected

    [   10.755467] [drm:drm_helper_probe_single_connector_modes_merge_bits] [CONNECTOR:37:DP-1]

    [   10.755470] [drm:intel_dp_detect] [CONNECTOR:37:DP-1]

    [   10.755475] [drm:drm_helper_probe_single_connector_modes_merge_bits] [CONNECTOR:37:DP-1] status updated from 3 to 2

    [   10.755478] [drm:drm_helper_probe_single_connector_modes_merge_bits] [CONNECTOR:37:DP-1] disconnected

    [   10.755480] [drm:drm_helper_probe_single_connector_modes_merge_bits] [CONNECTOR:39:HDMI-A-2]

    [   10.755482] [drm:intel_hdmi_detect] [CONNECTOR:39:HDMI-A-2]

    [   10.755488] i2c i2c-3: master_xfer[0] W, addr=0x50, len=1

    [   10.755492] i2c i2c-3: master_xfer[1] R, addr=0x50, len=1

    [   10.755638] [drm:gmbus_xfer] GMBUS [i915 gmbus dpc] NAK for addr: 0050 w(1)

    [   10.755640] [drm:gmbus_xfer] GMBUS [i915 gmbus dpc] NAK on first message, retry

    [   10.755976] [drm:gmbus_xfer] GMBUS [i915 gmbus dpc] NAK for addr: 0050 w(1)

    [   10.755985] [drm:drm_do_probe_ddc_edid] drm: skipping non-existent adapter i915 gmbus dpc

    [   10.755992] [drm:drm_helper_probe_single_connector_modes_merge_bits] [CONNECTOR:39:HDMI-A-2] status updated from 3 to 2

    [   10.755995] [drm:drm_helper_probe_single_connector_modes_merge_bits] [CONNECTOR:39:HDMI-A-2] disconnected

    [   10.755999] [drm:drm_helper_probe_single_connector_modes_merge_bits] [CONNECTOR:41:DP-2]

    [   10.756002] [drm:intel_dp_detect] [CONNECTOR:41:DP-2]

    [   10.756008] [drm:drm_helper_probe_single_connector_modes_merge_bits] [CONNECTOR:41:DP-2] status updated from 3 to 2

    [   10.756011] [drm:drm_helper_probe_single_connector_modes_merge_bits] [CONNECTOR:41:DP-2] disconnected

    [   10.756016] [drm:drm_setup_crtcs]

    [   10.756020] [drm:drm_enable_connectors] connector 29 enabled? yes

    [   10.756023] [drm:drm_enable_connectors] connector 32 enabled? no

    [   10.756025] [drm:drm_enable_connectors] connector 37 enabled? no

    [   10.756027] [drm:drm_enable_connectors] connector 39 enabled? no

    [   10.756029] [drm:drm_enable_connectors] connector 41 enabled? no

    [   10.756033] [drm:intel_fb_initial_config] connector VGA-1 has no encoder or crtc, skipping

    [   10.756036] [drm:intel_fb_initial_config] connector HDMI-A-1 not enabled, skipping

    [   10.756038] [drm:intel_fb_initial_config] connector DP-1 not enabled, skipping

    [   10.756040] [drm:intel_fb_initial_config] connector HDMI-A-2 not enabled, skipping

    [   10.756042] [drm:intel_fb_initial_config] connector DP-2 not enabled, skipping

    [   10.756044] [drm:intel_fb_initial_config] fallback: Not all outputs enabled

    [   10.756046] [drm:intel_fb_initial_config] Enabled: 0, detected: 1

    [   10.756048] [drm:intel_fb_initial_config] Not using firmware configuration

    [   10.756051] [drm:drm_target_preferred] looking for cmdline mode on connector 29

    [   10.756054] [drm:drm_target_preferred] looking for preferred mode on connector 29 0

    [   10.756056] [drm:drm_target_preferred] found mode 1920x1080

    [   10.756059] [drm:drm_setup_crtcs] picking CRTCs for 8192x8192 config

    [   10.756063] [drm:drm_setup_crtcs] desired mode 1920x1080 set on crtc 21 (0,0)

    [   10.756069] [drm:intelfb_create] no BIOS fb, allocating a new one

    [   10.756072] [drm:i915_gem_object_create_stolen] creating stolen object: size=7e9000

    [   10.756084] [drm:i915_pages_create_for_stolen] offset=0x60000, size=8294400

    [   10.759297] [drm:intelfb_create] allocated 1920x1080 fb: 0x0006a000, bo ffff8800b49e4000

    [   10.759765] fbcon: inteldrmfb (fb0) is primary device

    [   10.759913] [drm:intel_crtc_set_config] [CRTC:21] [FB:61] #connectors=1 (x y) (0 0)

    [   10.759918] [drm:intel_modeset_stage_output_state] [CONNECTOR:41:DP-2] to [NOCRTC]

    [   10.759920] [drm:intel_modeset_stage_output_state] [CONNECTOR:29:VGA-1] to [CRTC:21]

    [   10.759928] [drm:connected_sink_compute_bpp] [CONNECTOR:29:VGA-1] checking for sink bpp constrains

    [   10.759930] [drm:connected_sink_compute_bpp] clamping display bpp (was 30) to default limit of 24

    [   10.759932] [drm:intel_crtc_compute_config] intel_crtc = ffff8800b4a33000 drm_state (pipe_config->base.state) = ffff88013a03cae0

    [   10.759934] [drm:intel_modeset_pipe_config] plane bpp: 30, pipe bpp: 24, dithering: 0

    [   10.759936] [drm:intel_dump_pipe_config] [CRTC:21][modeset] config ffff88009d795c00 for pipe A

    [   10.759937] [drm:intel_dump_pipe_config] cpu_transcoder: A

    [   10.759938] [drm:intel_dump_pipe_config] pipe bpp: 24, dithering: 0

    [   10.759940] [drm:intel_dump_pipe_config] fdi/pch: 0, lanes: 0, gmch_m: 0, gmch_n: 0, link_m: 0, link_n: 0, tu: 0

    [   10.759941] [drm:intel_dump_pipe_config] dp: 0, gmch_m: 0, gmch_n: 0, link_m: 0, link_n: 0, tu: 0

    [   10.759943] [drm:intel_dump_pipe_config] dp: 0, gmch_m2: 0, gmch_n2: 0, link_m2: 0, link_n2: 0, tu2: 0

    [   10.759944] [drm:intel_dump_pipe_config] audio: 0, infoframes: 0

     

     

     

    Sep 24, 2015 - 12:43am
  • Hello,

    i will building the Intel-GPU-Tools.

    I have an errror:

     

    make[3]: Entering directory '/usr/intel-graphics/intel-gpu-tools/tools/registers'
    ', needed by 'all-am'.  Schluss.get 'audio_config_haswell_plus.txt
    make[3]: Leaving directory '/usr/intel-graphics/intel-gpu-tools/tools/registers'
    Makefile:1098: recipe for target 'all-recursive' failed
    make[2]: *** [all-recursive] Error 1
    make[2]: Leaving directory '/usr/intel-graphics/intel-gpu-tools/tools'
    Makefile:480: recipe for target 'all-recursive' failed
    make[1]: *** [all-recursive] Error 1
    make[1]: Leaving directory '/usr/intel-graphics/intel-gpu-tools'
    Makefile:411: recipe for target 'all' failed
    make: *** [all] Error 2

     

    What can i do? What is my error?

     

    BS

    Sep 30, 2015 - 02:04am
  • Hi - I don't have an answer about your DP question yet, but for the GPU tools could you get more verbose error reporting out? try

    make V=1

    instead of just

    make

    Oct 06, 2015 - 08:26am