Sorry, you need to enable JavaScript to visit this website.

Ubuntu Installer failing with Failed distribution check

1 post / 0 new
W's picture
Starter
W

Jan 01, 2015 - 01:34pm

  • W's picture
    W

    I am using Ubuntu Mate 14.04 64 bit on a Lenovo T410i with a core i3 M370 and I am unable to install the Intel Drivers. The driver install utility fails at the distribution check. The confusing part is why did it fail? 

    lsb_release gives me:

    No LSB modules are available.
    Distributor ID: Ubuntu
    Description: Ubuntu 14.10
    Release: 14.10
    Codename: utopic
     
    I would like to add that Intel needs to increase the verbosity of the error codes. If I am running Ubuntu and it fails the distribution check, then tell me what the reason for failue is.
     
    Here is the terminal output of my installer session:
    (intel-linux-graphics-installer:3329): Gtk-WARNING **: Failed to register client: GDBus.Error:org.freedesktop.DBus.Error.ServiceUnknown: The name org.gnome.SessionManager was not provided by any .service files
    diagnostics-view.c/new_diagnostic: Adding diagnostic for Checking if Intel graphics card available...
    diagnostics-view.c/new_diagnostic: Adding diagnostic for Retrieving information from 01.org...
    diagnostics-view.c/new_diagnostic: Adding diagnostic for Checking distribution...
    diagnostics-view.c/new_diagnostic: Adding diagnostic for Checking kernel version...
    diagnostics-view.c/new_diagnostic: Adding diagnostic for Checking available repositories...
    diagnostics-view.c/new_diagnostic: Adding diagnostic for Checking package manager status...
    No LSB modules are available.
    polkit: Fetching org.01.linuxgraphics.installer permissions...
    $ sudo intel-linux-graphics-installer > intel_installer.txt
     
    (intel-linux-graphics-installer:3345): Gtk-WARNING **: Failed to register client: GDBus.Error:org.freedesktop.DBus.Error.ServiceUnknown: The name org.gnome.SessionManager was not provided by any .service files
    No LSB modules are available.
    {
      errors: (nil)
      sources: []
      keys: []
      docs: []
      INSTALL: []
      install: []
      upgrade: []
    }
    {
      errors: (nil)
      sources: []
      keys: []
      docs: []
      INSTALL: []
      install: []
      upgrade: []
    }

     

    Jan 01, 2015 - 01:34pm
  • Ubuntu 14.10 isn't supported by the last release of the installer:

    That version is aimed at 14.04. The next release of the installer, based on the 2014-Q4 release
    of the Intel Graphics stack for Linux will be for Ubuntu 14.10.

    Good point about the error though, I'll see if I can get more useful info put into it (not sure if that will
    make the next release, but the feedback is appreciated).

    Jan 06, 2015 - 06:58am