Sorry, you need to enable JavaScript to visit this website.

Verify that 1.0.5 has installed ??

5 posts / 0 new
Don McNight's picture
Starter
Don McNight

May 18, 2014 - 05:40pm

  • https://01.org/linuxgraphics/comment/738#comment-738

    I see all of the entries listed in this link and & "Upgraded: Intel-gpu-tools:amd64(from 1.30ubuntu2 to 1.6-1)" Thanks to Sampayu's explanation in the sticky I was able to get 1.0.5 to install sans any errors.  - Can someone tell me if I using 1.0.5 now on my system? -Sager NP2740, Ubuntu 14.04 LTS with all Ubuntu updates

     

     

    May 18, 2014 - 05:40pm
  • Your "My Content" folder isn't visible to others.

    If you want other people to see your screenshot, you need to incorporate the file here in your post. You do this by clicking onto the Image button (it's located at the toolbar, left side of the "Source" button) and then selecting the screenshot file that's hosted in your personal/user folder.

    Anyway, if you ran intel-linux-graphics-installer 'til the end (clicked on Begin and then Install and didn't receive any error message) then you're all done: the Intel Graphics Installer (IGI) already fetched your system data, connected to the correct Intel repository, downloaded all the necessary packages and installed and configured them.

    The problem is: what's next? I'm wondering if installing these files was anywhere useful. As you probably saw on my other post, apparently no graphic device driver was replaced by the IGI. You can run lshw -c video to check what is your graphical device and which driver it's using (it's probably i915). You may also want to run modinfo name_of_the_driver (e.g. modinfo i915) in order to gather more data about the driver that's being used by your graphical device.

    If you want to make your life less painfull while dealing with multiple DEB packages and their dependencies, I recommend installing Synaptic:

    sudo apt-get install synaptic

    Now run Synaptic and type intel inside the "Quick filter" field. You'll see these packages:

    intel-linux-graphics-installer - the one you downloaded and installed in order to run IGI.

    i965-va-driver, intel-gpu-tools and probably some other packages that were automatically downloaded and installed by the IGI.

    If these packages are present and installed, Synaptic will show you that and hence you'll know that IGI is installed, as well as the packages that are compatible with your system's graphical device. These packages may have no practical use, but they're there.   :-P

     

    PS: to get more details about a specific (installed) DEB package, return to Synaptic, right-click the package, select Properties and then Installed Files.

    May 18, 2014 - 07:39pm
  • If you want o verify your installed drivers, then Noobslab makes a nice little app for the open-source and proprietary driver verification called ddm (device driver manager) available on their PPA by adding the following:

    ppa:noobslab/ppa

    and then run:

    sudo apt-get update && sudo apt-get install ddm

    which will install ddm. Then simply run the command:

    sudo ddm

    and you can then verify what is installed. You do have to trust the nooblab ppa, so please be aware of that. 

    May 20, 2014 - 09:00am
  • It's a simple yet friendly and useful app. Thank you, Chuck.  :)

     

    For those unfamiliar with adding a PPA, getting the repository's respective PGP key etc., just run these 4 commands in the terminal (follow the exact sequence as shown below):

     

    sudo add-apt-repository ppa:noobslab/apps

     

    sudo apt-get update

     

    sudo apt-get install ddm

     

    ddm&

    May 21, 2014 - 03:56pm
  • Hi - since 14.04 came out a little after the most recent Intel stack release, it already contained
    most of the components we would have upgraded otherwise, including the i915 graphics driver,
    so _this_ time the installer does _NOT_ upgrade those parts.

    What you're gettimg this time is intel-gpu-tools (which is mostly of interest to developers)
    and an updated VA API infrastructure (which is used to get hardware accelerated video playback).

    You'll need a VA enabled video player to see the benefits of this - unfortunately I don't
    think anybody ships one out of the box yet, but we're working on enabling totem+gstreamer
    and if you're feeling brave, I believe you can patch mplayer to support it.

    The VA acceleration is pretty impressive if you do have it, on my laptop playing HD video
    with a supported codec goes from something like 80% cpu to 5%, it's just not easily available
    in any of the pre-packaged players [yet].

    May 22, 2014 - 04:39am
  • Hi, fledermaus, thank you for the info. :)

    About the VA API: 80% to 5% is really impressive. I hadn't yet given this feature a try, but after your post I got curious and decided to make a little research, which led me to find out that VLC player already supports hardware video decoding. It does decoding in GPU at the decoding stage only, hence the performance improvement isn't so impressive. Anyway it's better than nothing, I suppose.

    Here's a screenshot of VLC Media Player on a 64-bit XUbuntu Linux 14.04 LTS O.S. All I had to do was to access VLC's Preferences, go to Input / Codecs and enable Hardware Acceleration.

    VA API i965 driver loaded on VLC Media Player in a 64-bit XUbuntu Linux 14.04 LTS O.S.

    Since it's general (though maybe not absolute...) sense that under Linux distros the exit code 0 means "success", I'm assuming that those "returns 0" outputs mean "successful" results, and that thereafter the driver was actually loaded and executed.

    Just for the sake of curiosity, here's a screenshot featuring VLC Media Player using Apple's VDA on OS X 10.9 "Mavericks":

    May 22, 2014 - 01:15pm