Sorry, you need to enable JavaScript to visit this website.

"Your system does not have the 'org.freedesktop.packagekit.package-install' PolicyKit files installed" error from update tool.

1 post / 0 new
Piotr Dobrogost's picture
Starter
Piotr Dobrogost

Sep 14, 2016 - 06:50am

  • Hi!
     
    After installing intel-graphics-update-tool-2.0.2-24.intel20162.x86_64.rpm on Fedora 24 I run
    $ intel-graphics-update-tool
    and got this error
    $ polkit: Fetching org.freedesktop.packagekit.package-install permissions...
    src/transaction-view.c/on_pm_op_failed: Package manager operation failed: Your system does not have the 'org.freedesktop.packagekit.package-install' PolicyKit files installed. Please check your installation
     
     
    I have version 0.113-5.fc24 of polkit installed.

    How could I fix this?

     

    Regards,

    Piotr Dobrogost

    Sep 14, 2016 - 06:50am
  • That is strange. On my test systems:

    [user@int0068-01 ~]$ rpm -qf /usr/share/polkit-1/actions/org.freedesktop.packagekit.policy
    PackageKit-1.1.3-1.fc24.x86_64

    Are you missing that file? Does reinstalling te packagekit package fix it?

    Sep 26, 2016 - 06:02pm