Sorry, you need to enable JavaScript to visit this website.

Can't get 2160p60 on DP or HDMI 2.0 on my Fatal1ty Z170 Gaming ITX

0 posts / 0 new
Perig Vennetier's picture
Starter
Perig Vennetier

Feb 25, 2016 - 04:54pm

  • Hi,

     

    Not sure if this is a good place to get some help about this but I am pretty new to Linux so I am trying in multiple places to try to find a solution to my issue.

     

    I have a system with a Fatal1ty Z170 Gaming ITX with an i7 CPU and not additional graphics card. This card has a DP 1.2 and and HDMI 2.0 output.

     

    I have a Terranex Mini HDMI to SDI converter connected to either DP (with a DP to HMDI 2.0 converter) or HDMI. That supports up to UHD 60fps on its HMDI input.

     

    I currently cannot get above 30fps.

     

    Below is what I get for it plugged on DP1 with the DP to HDMI 2.0 converter (same results direct on HDMI 2.0 output)

     

    DP1 connected 3840x2160+0+0 (normal left inverted right x axis y axis) 708mm x 398mm
       1920x1080i    60.00 +  50.00    59.94  
       4096x2160     24.00    23.98  
       3840x2160     30.00*   25.00    24.00    29.97    23.98  
       1920x1080     60.00    50.00    59.94    30.00    25.00    24.00    29.97    23.98  
       1280x720      60.00    50.00    59.94  
       1440x480i     59.94  
       720x576       50.00  
       720x480       60.00    59.94  
       640x480       60.00    59.94  

     

    I do not have access to 3840x2160 above 30 and 4096x2160 above 24 (should have up to 30).

     

    I have the following setup:

     

    $ uname -a

    Linux test-desktop 4.4.2-040402-generic #201602171633 SMP Wed Feb 17 21:35:10 UTC 2016 x86_64 x86_64 x86_64 GNU/Linux

     

    $ sudo lshw -c video | grep 'configuration'

    configuration: driver=i915 latency=0

     

    $ sudo lshw -c video
      *-display               
           description: VGA compatible controller
           product: Sky Lake Integrated Graphics
           vendor: Intel Corporation
           physical id: 2
           bus info: pci@0000:00:02.0
           version: 06
           width: 64 bits
           clock: 33MHz
           capabilities: pciexpress msi pm vga_controller bus_master cap_list rom
           configuration: driver=i915 latency=0
           resources: irq:146 memory:de000000-deffffff memory:c0000000-cfffffff ioport:f000(size=64)

     

    $ modinfo i915 | grep filename
    filename:       /lib/modules/4.4.2-040402-generic/kernel/drivers/gpu/drm/i915/i915.ko

     

    I have the latest Intel Drivers 1.4.0 from here I believe.

     

    Any help in figuring this out would be very much appreciated.

     

    Thanks.

    Feb 25, 2016 - 04:54pm