Sorry, you need to enable JavaScript to visit this website.

Intel driver for Atom Baytrail

0 posts / 0 new
Joris Lasnier's picture
Starter
Joris Lasnier

Nov 03, 2014 - 12:51am

  • Hello all,
     
    I've a problem to run the xserver on my baytrail (E3845) platform (Qseven) composed by an Intel GPU.
    I want to generate a core-image-sato with Yocto, the image works, there is a graphical result but with a poor resolution. I think the OS use the xf86-video-fbdev driver instead of xf86-video-intel... This is my dmesg | grep i915 output:
     
    [    0.000000] Command line: BOOT_IMAGE=/boot/bzImage root=/dev/sda2 rootdelay=4 i915.modeset=1
    [    0.000000] Kernel command line: BOOT_IMAGE=/boot/bzImage root=/dev/sda2 rootdelay=4 i915.modeset=1
    [    1.648785] i915 0000:00:02.0: setting latency timer to 64
    [    1.684576] i915 0000:00:02.0: irq 103 for MSI/MSI-X
    [    1.684735] [drm:i915_stolen_to_physical] *ERROR* conflict detected with stolen region: [0x9b000000 - 0x9f000000]
    [    1.780040] [drm] GMBUS [i915 gmbus vga] timed out, falling back to bit banging on pin 2
    [    3.178899] i915 0000:00:02.0: fb0: inteldrmfb frame buffer device
    [    3.178969] i915 0000:00:02.0: registered panic notifier
    [    3.186896] [drm] Initialized i915 1.6.0 20080730 for 0000:00:02.0 on minor 0
     
    I add this kernel configuration
     
    # Graphics support
    #
    CONFIG_AGP=y
    CONFIG_AGP_INTEL=y
    CONFIG_VGA_ARB=y
    CONFIG_VGA_ARB_MAX_GPUS=16
    CONFIG_DRM=y
    CONFIG_DRM_KMS_HELPER=y
    CONFIG_DRM_I915=y
    CONFIG_DRM_I915_KMS=y
    CONFIG_VIDEO_OUTPUT_CONTROL=y
    CONFIG_FB=y
    CONFIG_FB_CFB_FILLRECT=y
    CONFIG_FB_CFB_COPYAREA=y
    CONFIG_FB_CFB_IMAGEBLIT=y
    CONFIG_FB_EFI=y
     
    I give the i915.modeset=1 parameter to the grub config to use KMS.
     
    First, I used a kernel 3.8: the core-image-sato boot and ... no graphical result.
    So, I tried to execute the startx command... failed.
     
    [1726404.498] (EE) no device(s) detected
    [1726404.498] 
    Fatal server error:
    [1726404.498] no screens found
    [1726404.498] (EE) 
     
    I decide to generate a xorg.conf file with Xorg -configure commande, followed by startx: failed  
     
    Then I generate a new core-image sato with a 3.10 kernel version with just one kernel config added:
     
    CONFIG_DRM_i915_FBDEV=y which doesn't exist on 3.8
     
    I boot the image with the same grub config: and there is a graphical result but with a very bad resolution...
     
    I try the Ubuntu 14.04 to have a reference, with the "Intel(R) Graphics Installer 1.0.6 for Linux" but the same thing, poor resolution with the same dmesg output...
     
    Someone have an idea to use xserver with the GPU intel (i915) on Baytrail platform??? Because I have tried lot of configuration without result...
     
    PS: this is my lspci | grep VGA output:
    00:02.0 VGA compatible controller: Intel Corporation ValleyView Gen7 (rev 0c)
     
    Thank you.
     
    Nov 03, 2014 - 12:51am