Sorry, you need to enable JavaScript to visit this website.

Kernel mode settings for LVDS - Intel i74700EQ

1 post / 0 new
Einar Bjorgvinsson's picture
Starter
Einar Bjorgvinsson

Apr 15, 2014 - 10:33pm

  • Hi there

    I am having a bit of a trouble getting my board running with proper graphics support using LVDS. We have a custom made Linux distro based on Ubuntu and without any windowing system (X/Wayland...) 

    The board is acquired from iBase called MI980VF and has i7 4700EQ on it. I am currently running Linux 3.6.11. 

    I define in BIOS the primary display to be LVDS but secondary DVI. 

    The problem is with the mode settings because the only working mode set is the kernel option nomodeset

    If I don't use this one the output on the screen gets garbled a soon as the kernel switches graphical mode during bootup. The BIOS/Grub and initial kernel boot sequence are all printed out ordinarily but shortly after that the kernel switches the graphical mode and the output becomes garbled. 

    When I use the nomodeset there will be no framebuffer available for the user , which I need !! so what I am asking for here is what settings to use in order to prevent the output being garbled and also to keep the framebuffer ?

    The DVI output always works fine.

     

    regards

    Einar

    Apr 15, 2014 - 10:33pm