Sorry, you need to enable JavaScript to visit this website.

No signal on HDMI (HD 4000)

7 posts / 0 new
Joha's picture
Starter
Joha

Sep 12, 2013 - 03:09am

  • Hi 

    Iam using Ubuntu 13.04 (64-bit) and I cannot get picture over the HDMI port. It is working when I use the DVI port. If I use the HDMI port I can see a purple screen for a couple of seconds and then the screen goes black. The monitor is acting as if its not getting any signal. I have tried 2 monitors and a TV but with the same result.

    If I use both DVI and HDMI at the same time the HDMI port still dosen't work but I can see the monitor that is connected to the HDMI port. The only thing that works is if I use nomodeset in grub. I have also tried different HDMI cables but the same problem. In Windows 8 everything is working perfectly, even dual monitor.

    CPU: i3-3225

    MB: MSI Z77IA-S01 (http://eu.msi.com/product/mb/Z77IA-S01.html)

    I don't have any other graphics card installed and I have installed Linux* Graphics Installer version 1.0.2.

    Xrandr:

    http://pastebin.com/MLTjusg8

    Here is my xorg log.

    http://pastebin.com/5gNjV4HN

    I have no clue what the problem is, so please help me.

    Regards

    triinkn

     

    Sep 12, 2013 - 03:09am
  • What does it happen if you execute this command:

    xrandr --output HDMI2 --mode 1920x1080

    also, if possible boot your machine adding drm.debug=0xe to your linux cmdline at grub and paste dmesg output.

    Thanks,

    Rodrigo.

    Sep 17, 2013 - 08:20am
  • I am having a similar issue.

    Ubuntu 13.04 64 bit latest Intel driver installed.  Hd4000 no HDMI output. 

    xrandr --output HDMI1 --mode 1920x1080 gives the following output:

    xrandr: cannot find mode 1920x1080

    Same with HDMI2. 



     

    Sep 24, 2013 - 12:58pm
  • what does your xrandr --verbose says?

    also, do you have any xorg.conf in /etc/X11 or any conf file at /etc/X11/xorg.conf.d ? please paste me all of them.

    Also paste your /var/log/Xorg.0.log please.

    Thanks,

    Rodrigo.

     

    Sep 25, 2013 - 06:54am
  • I put everything in pastebin because it was quite lengthy.  My /var/log/Xorg.0.log was huge due to the fact that I take the laptop to and from work every day (lots of usb unplugging and re-plugging). 

    I do not have an xorg.conf file of any kind, and no xorg.conf.d either. 

    If you would like I can do a [tail -f /var/log/Xorg.0.log] and let you know if anything changes when I plug in an HDMI cord. 

    Just let me know what I can do to help.

    Sep 26, 2013 - 11:02pm
  • I can't edit, and I forgot the pastebin link:

    http://pastebin.com/6sb1aycb

    Sep 26, 2013 - 11:04pm
  • I can't edit, and I forgot the pastebin link:

    http://pastebin.com/6sb1aycb

    Sep 26, 2013 - 11:04pm
  • It's been quite some time and this still hasn't seen a reply, has anyone found a fix for this?

    Dec 13, 2013 - 02:15pm
  • Topic locked