Sorry, you need to enable JavaScript to visit this website.

Ubuntu 13.04: Unable to boot in X (Haswell CPU)

1 post / 0 new
Michiel Vries's picture
Starter
Michiel Vries

Sep 27, 2013 - 07:21am

  • Today I ran the installer on my clean install of Ubuntu 13.04. Unfortunately, after running the installer and doing a reboot, my system will not load X anymore. I get an error saying "The system is running in low-graphics mode" and I am unable to proceed.

    My system contains a Haswell i3-4130 CPU. The sytem is connected to my TV using a HDMI connection.

    After hours of searching fora for similar issues I'm nearing the point of doing a clean install of Ubuntu. Maybe you guys have any ideas?

    Below a copy-paste of my /var/log/Xorg.0.log:

    [    12.346]

    X.Org X Server 1.13.3
    Release Date: 2013-03-07
    [    12.346] X Protocol Version 11, Revision 0
    [    12.346] Build Operating System: Linux 3.2.0-37-generic x86_64 Ubuntu
    [    12.346] Current Operating System: Linux HTPC 3.8.0-31-generic #46-Ubuntu SMP Tue Sep 10 20:03:44 UTC 2013 x86_64
    [    12.346] Kernel command line: BOOT_IMAGE=/boot/vmlinuz-3.8.0-31-generic root=UUID=c8a2756e-7d34-4639-a909-2673164c0770 ro quiet splash vt.handoff=7
    [    12.346] Build Date: 17 April 2013  10:43:13PM
    [    12.346] xorg-server 2:1.13.3-0ubuntu6 (For technical support please see http://www.ubuntu.com/support)
    [    12.346] Current version of pixman: 0.28.2
    [    12.346]    Before reporting problems, check http://wiki.x.org
            to make sure that you have the latest version.
    [    12.346] Markers: (--) probed, (**) from config file, (==) default setting,
            (++) from command line, (!!) notice, (II) informational,
            (WW) warning, (EE) error, (NI) not implemented, (??) unknown.
    [    12.346] (==) Log file: "/var/log/Xorg.0.log", Time: Fri Sep 27 16:11:31 2013
    [    12.346] (==) Using system config directory "/usr/share/X11/xorg.conf.d"
    [    12.346] (==) No Layout section.  Using the first Screen section.
    [    12.346] (==) No screen section available. Using defaults.
    [    12.346] (**) |-->Screen "Default Screen Section" (0)
    [    12.346] (**) |   |-->Monitor "<default monitor>"
    [    12.346] (==) No monitor specified for screen "Default Screen Section".
            Using a default monitor configuration.
    [    12.346] (==) Automatically adding devices
    [    12.346] (==) Automatically enabling devices
    [    12.346] (==) Automatically adding GPU devices
    [    12.346] (WW) The directory "/usr/share/fonts/X11/cyrillic" does not exist.
    [    12.346]    Entry deleted from font path.
    [    12.346] (WW) The directory "/usr/share/fonts/X11/100dpi/" does not exist.
    [    12.346]    Entry deleted from font path.
    [    12.346] (WW) The directory "/usr/share/fonts/X11/75dpi/" does not exist.
    [    12.346]    Entry deleted from font path.
    [    12.346] (WW) The directory "/usr/share/fonts/X11/100dpi" does not exist.
    [    12.346]    Entry deleted from font path.
    [    12.346] (WW) The directory "/usr/share/fonts/X11/75dpi" does not exist.
    [    12.346]    Entry deleted from font path.
    [    12.346] (WW) The directory "/var/lib/defoma/x-ttcidfont-conf.d/dirs/TrueType" does not exist.
    [    12.346]    Entry deleted from font path.
    [    12.346] (==) FontPath set to:
            /usr/share/fonts/X11/misc,
            /usr/share/fonts/X11/Type1,
            built-ins
    [    12.346] (==) ModulePath set to "/usr/lib/x86_64-linux-gnu/xorg/extra-modules,/usr/lib/xorg/extra-modules,/usr/lib/xorg/modules"
    [    12.346] (II) The server relies on udev to provide the list of input devices.
            If no devices become available, reconfigure udev or disable AutoAddDevices.
    [    12.346] (II) Loader magic: 0x7f80c5e2dd20
    [    12.346] (II) Module ABI versions:
    [    12.346]    X.Org ANSI C Emulation: 0.4
    [    12.346]    X.Org Video Driver: 13.1
    [    12.346]    X.Org XInput driver : 18.0
    [    12.346]    X.Org Server Extension : 7.0
    [    12.346] (II) config/udev: Adding drm device (/dev/dri/card0)
    [    12.347] (--) PCI:*(0:0:2:0) 8086:041e:1043:8534 rev 6, Mem @ 0xf7800000/4194304, 0xe0000000/268435456, I/O @ 0x0000f000/64
    [    12.347] (II) Open ACPI successful (/var/run/acpid.socket)
    [    12.347] Initializing built-in extension Generic Event Extension
    [    12.347] Initializing built-in extension SHAPE
    [    12.347] Initializing built-in extension MIT-SHM
    [    12.347] Initializing built-in extension XInputExtension
    [    12.347] Initializing built-in extension XTEST
    [    12.347] Initializing built-in extension BIG-REQUESTS
    [    12.347] Initializing built-in extension SYNC
    [    12.347] Initializing built-in extension XKEYBOARD
    [    12.347] Initializing built-in extension XC-MISC
    [    12.347] Initializing built-in extension SECURITY
    [    12.347] Initializing built-in extension XINERAMA
    [    12.347] Initializing built-in extension XFIXES
    [    12.347] Initializing built-in extension RENDER
    [    12.347] Initializing built-in extension RANDR
    [    12.347] Initializing built-in extension COMPOSITE
    [    12.347] Initializing built-in extension DAMAGE
    [    12.347] Initializing built-in extension MIT-SCREEN-SAVER
    [    12.347] Initializing built-in extension DOUBLE-BUFFER
    [    12.347] Initializing built-in extension RECORD
    [    12.347] Initializing built-in extension DPMS
    [    12.347] Initializing built-in extension X-Resource
    [    12.347] Initializing built-in extension XVideo
    [    12.347] Initializing built-in extension XVideo-MotionCompensation
    [    12.347] Initializing built-in extension SELinux
    [    12.347] Initializing built-in extension XFree86-VidModeExtension
    [    12.347] Initializing built-in extension XFree86-DGA
    [    12.347] Initializing built-in extension XFree86-DRI
    [    12.347] Initializing built-in extension DRI2
    [    12.347] (II) LoadModule: "glx"
    [    12.348] (II) Loading /usr/lib/xorg/modules/extensions/libglx.so
    [    12.348] (II) Module glx: vendor="X.Org Foundation"
    [    12.348]    compiled for 1.13.3, module version = 1.0.0
    [    12.348]    ABI class: X.Org Server Extension, version 7.0
    [    12.348] (==) AIGLX enabled
    [    12.348] Loading extension GLX
    [    12.348] (==) Matched intel as autoconfigured driver 0
    [    12.348] (==) Matched intel as autoconfigured driver 1
    [    12.348] (==) Matched vesa as autoconfigured driver 2
    [    12.348] (==) Matched modesetting as autoconfigured driver 3
    [    12.348] (==) Matched fbdev as autoconfigured driver 4
    [    12.348] (==) Assigned the driver to the xf86ConfigLayout
    [    12.348] (II) LoadModule: "intel"
    [    12.348] (II) Loading /usr/lib/xorg/modules/drivers/intel_drv.so
    [    12.348] (II) Module intel: vendor="X.Org Foundation"
    [    12.348]    compiled for 1.13.3, module version = 2.21.9
    [    12.348]    Module class: X.Org Video Driver
    [    12.348]    ABI class: X.Org Video Driver, version 13.1
    [    12.348] (II) LoadModule: "vesa"
    [    12.348] (II) Loading /usr/lib/xorg/modules/drivers/vesa_drv.so
    [    12.348] (II) Module vesa: vendor="X.Org Foundation"
    [    12.348]    compiled for 1.12.99.902, module version = 2.3.2
    [    12.348]    Module class: X.Org Video Driver
    [    12.348]    ABI class: X.Org Video Driver, version 13.0
    [    12.348] (II) LoadModule: "modesetting"
    [    12.348] (II) Loading /usr/lib/xorg/modules/drivers/modesetting_drv.so
    [    12.348] (II) Module modesetting: vendor="X.Org Foundation"
    [    12.348]    compiled for 1.13.3, module version = 0.7.0
    [    12.348]    Module class: X.Org Video Driver
    [    12.348]    ABI class: X.Org Video Driver, version 13.1
    [    12.348] (II) LoadModule: "fbdev"
    [    12.349] (II) Loading /usr/lib/xorg/modules/drivers/fbdev_drv.so
    [    12.349] (II) Module fbdev: vendor="X.Org Foundation"
    [    12.349]    compiled for 1.12.99.902, module version = 0.4.3
    [    12.349]    Module class: X.Org Video Driver
    [    12.349]    ABI class: X.Org Video Driver, version 13.0
    [    12.349] (II) intel: Driver for Intel Integrated Graphics Chipsets: i810,
            i810-dc100, i810e, i815, i830M, 845G, 854, 852GM/855GM, 865G, 915G,
            E7221 (i915), 915GM, 945G, 945GM, 945GME, Pineview GM, Pineview G,
            965G, G35, 965Q, 946GZ, 965GM, 965GME/GLE, G33, Q35, Q33, GM45,
            4 Series, G45/G43, Q45/Q43, G41, B43, B43, Clarkdale, Arrandale,
            Sandybridge Desktop (GT1), Sandybridge Desktop (GT2),
            Sandybridge Desktop (GT2+), Sandybridge Mobile (GT1),
            Sandybridge Mobile (GT2), Sandybridge Mobile (GT2+),
            Sandybridge Server, Ivybridge Mobile (GT1), Ivybridge Mobile (GT2),
            Ivybridge Desktop (GT1), Ivybridge Desktop (GT2), Ivybridge Server,
            Ivybridge Server (GT2), HD Graphics, HD Graphics 4600,
            Haswell Desktop (GT3), HD Graphics, HD Graphics 4600,
            Haswell Mobile (GT3), HD Graphics, HD Graphics P4600/P4700,
            Haswell Server (GT3), Haswell (GT1), Haswell (GT2), Haswell (GT3),
            HD Graphics, Haswell (GT2), Haswell (GT3), Haswell SDV Desktop (GT1),
            Haswell SDV Desktop (GT2), Haswell SDV Desktop (GT3),
            Haswell SDV Mobile (GT1), Haswell SDV Mobile (GT2),
            Haswell SDV Mobile (GT3), Haswell SDV Server (GT1),
            Haswell SDV Server (GT2), Haswell SDV Server (GT3),
            Haswell SDV (GT1), Haswell SDV (GT2), Haswell SDV (GT3),
            Haswell SDV (GT1), Haswell SDV (GT2), Haswell SDV (GT3),
            Haswell ULT Desktop (GT1), Haswell ULT Desktop (GT2),
            Iris(TM) Graphics 5100, HD Graphics, HD Graphics 4400,
            HD Graphics 5000, Haswell ULT Server (GT1), Haswell ULT Server (GT2),
            Iris(TM) Graphics 5100, Haswell ULT (GT1), Haswell ULT (GT2),
            Iris(TM) Graphics 5100, HD Graphics, HD Graphics 4200,
            Iris(TM) Graphics 5100, Haswell CRW Desktop (GT1), HD Graphics 4600,
            Iris(TM) Pro Graphics 5200, Haswell CRW Mobile (GT1),
            HD Graphics 4600, Iris(TM) Pro Graphics 5200,
            Haswell CRW Server (GT1), Haswell CRW Server (GT2),
            Iris(TM) Pro Graphics 5200, Haswell CRW (GT1), Haswell CRW (GT2),
            Iris(TM) Pro Graphics 5200, Haswell CRW (GT1), Haswell CRW (GT2),
            Iris(TM) Pro Graphics 5200, ValleyView PO board
    [    12.349] (II) VESA: driver for VESA chipsets: vesa
    [    12.349] (II) modesetting: Driver for Modesetting Kernel Drivers: kms
    [    12.349] (II) FBDEV: driver for framebuffer: fbdev
    [    12.349] (++) using VT number 7
     
    [    12.349] (WW) Falling back to old probe method for vesa
    [    12.349] (WW) Falling back to old probe method for modesetting
    [    12.349] (WW) Falling back to old probe method for fbdev
    [    12.349] (II) Loading sub module "fbdevhw"
    [    12.349] (II) LoadModule: "fbdevhw"
    [    12.349] (II) Loading /usr/lib/xorg/modules/libfbdevhw.so
    [    12.349] (II) Module fbdevhw: vendor="X.Org Foundation"
    [    12.349]    compiled for 1.13.3, module version = 0.0.2
    [    12.349]    ABI class: X.Org Video Driver, version 13.1
    [    12.349] (II) intel(0): Creating default Display subsection in Screen section
            "Default Screen Section" for depth/fbbpp 24/32
    [    12.349] (==) intel(0): Depth 24, (--) framebuffer bpp 32
    [    12.349] (==) intel(0): RGB weight 888
    [    12.349] (==) intel(0): Default visual is TrueColor
    [    12.349] (--) intel(0): Integrated Graphics Chipset: Intel(R) Haswell (GT2)
    [    12.349] (II) UnloadModule: "intel"
    [    12.349] (EE) Screen(s) found, but none have a usable configuration.
    [    12.349]
    Fatal server error:
    [    12.349] no screens found
    [    12.349] (EE)
    Please consult the The X.Org Foundation support
             at http://wiki.x.org
     for help.
    [    12.349] (EE) Please also check the log file at "/var/log/Xorg.0.log" for additional information.
    [    12.349] (EE)
    [    12.353] Server terminated with error (1). Closing log file.
     

     

     

     

     

     

    Sep 27, 2013 - 07:21am
  • Z's picture
    Z

    I have the same problem and haven't wound any solution.

    Adding Device with AccelMethod sna in xorg.conf make things work, but without hardware acceleration.

    Sep 28, 2013 - 08:50pm
  • Topic locked