Sorry, you need to enable JavaScript to visit this website.

Ultra High Res and Integrated Graphics (Lenovo T520)

1 post / 0 new
Thomas Beauvais's picture
Starter
Thomas Beauvais

Jul 23, 2013 - 05:55am

  • I have been using this Lenovo T520 with Intel Integrated Graphics 3000 on Ubuntu and loving it.

    A recently purchased Dell 27" Ultra-sharp U2713HM monitor with promised 2560x1440 resolution poses a problem. Randomly during normal use (and almost instantly during heavy use) the monitor blinks off/on and sometimes shuts off completely forcing a manual restart of the monitor!

    At lower resolution (1920x1200) over DisplayPort there are no problems at all.  Also, when I disable my Lenovo's built-in screen (1920x1200) it works great.  Perhaps the Intel 3000 can't handle such a large workarea??

    In Windows 7,  it is a bit "laggy" but everything appears to be working perfectly as well enough (aka not shutting off).

    I've installed the new May 20th 2013 Intel Integrated Graphics driver and the problem still persists.

    Let me know if any information is needed but I would sure appreciate anyone that can take a minute to point me in the right direction.

    Thank you!

    Jul 23, 2013 - 05:55am
  • I too experience random "blackouts" on my monitors forcing me to completely restart (power cycle) the monitor for things to link up.

    I'm using DisplayPort connections on Ubuntu 13.04 trying to drive both of my U2713HM's @ 2560x1440 from my docked Lenovo X220.

    I'd be more than happy to grab any logs or dumps that I can get you guys to help debug this.

    Aug 05, 2013 - 03:10pm
  • Topic locked