Sorry, you need to enable JavaScript to visit this website.

Upgrading to the latest driver for mythbuntu 12.04

3 posts / 0 new
Mak's picture
Starter
Mak

Sep 16, 2013 - 02:26am

  • Mak's picture
    Mak

    I like to upgrade to the latest stable intel driver for Ivy Brdige. 

    The reason is that:

    1) I got tearoff on the full HD video playback sometimes.

    2) I can't rotate the screen left/right with HDMI connector (VGA connection is fine)

    Now I have the following packages installed on the mythbuntu 12.04

    Linux kenel: 3.2.0-29-generic-pae

    libva-intel-vaapi-driver             1.0.15-1ubuntu2

    xserver-xorg-video-intel             2:2.17.0-1ubuntu4.4

    Can you shred me some lights how to upgrade to the latest stable driver from 01.org?

    I didn't see any drivers for 12.04, or I need to upgrade from the source? And how?

     

    Sep 16, 2013 - 02:26am
  •  

    Unfortunatelly we have no easy way for getting it upgraded for 12.04.

    We do have a easy Installer for non-technical users, but currently only targetting 2013Q2 for Fedora 19 and Ubuntu 13.04: https://01.org/linuxgraphics/downloads/2013/intelr-linux-graphics-installer-version-1.0.2

    The easy installer for 12.04 was deprecated after we started to cause conflicts with official packages from Canonical.

    Please notice that we don't recommend to change your distribution kernel that contains latest from your distribution including Security patches, but if you are a brave user willing to get sources and replacing even your kernel: The only way for you would be manually compiling the whole stack from source folowing development procedures available at  https://01.org/linuxgraphics/documentation/build-guide and get sources of latest availabe stack: https://01.org/linuxgraphics/downloads/2013/2013q2-intel-graphics-stack-release

    Thanks,

    Rodrigo.

    Sep 17, 2013 - 08:25am
  • Mak's picture
    Mak

    Just wondering if I just upgrade the Intel driver (2D) only, I just need to compile the followings?

     

    It didn't say much on the build guide....

    I did compile all the above packages, but when I reboot I got the following errors from Xorg.0.log

    X.Org X Server 1.13.3   (old release)
    Release Date: 2013-03-07
    [     4.891] X Protocol Version 11, Revision 0

    ........

    .......

    [ 93440.560] (EE) Backtrace:
    [ 93440.562] (EE) 0: /usr/bin/X (xorg_backtrace+0x49) [0xb7693e29]
    [ 93440.562] (EE) 1: /usr/bin/X (0xb74dc000+0x1bbc2a) [0xb7697c2a]
    [ 93440.562] (EE) 2: (vdso) (__kernel_rt_sigreturn+0x0) [0xb74b940c]
    [ 93440.562] (EE) 3: /usr/bin/X (0xb74dc000+0xcd762) [0xb75a9762]
    [ 93440.562] (EE) 4: /usr/bin/X (0xb74dc000+0x1a0bc8) [0xb767cbc8]
    [ 93440.562] (EE) 5: /usr/bin/X (0xb74dc000+0x12f1a2) [0xb760b1a2]
    [ 93440.562] (EE) 6: /usr/bin/X (FreeCursor+0x54) [0xb750b6e4]
    [ 93440.562] (EE) 7: /usr/bin/X (0xb74dc000+0x56547) [0xb7532547]
    [ 93440.562] (EE) 8: /usr/bin/X (0xb74dc000+0x303d3) [0xb750c3d3]
    [ 93440.563] (EE) 9: /usr/bin/X (0xb74dc000+0x30b80) [0xb750cb80]
    [ 93440.563] (EE) 10: /usr/bin/X (0xb74dc000+0x29a17) [0xb7505a17]
    [ 93440.563] (EE) 11: /lib/i386-linux-gnu/libc.so.6 (__libc_start_main+0xf3) [0xb71344d3]
    [ 93440.563] (EE) 12: /usr/bin/X (0xb74dc000+0x29d69) [0xb7505d69]
    [ 93440.563] (EE)
    [ 93440.563] (EE) Segmentation fault at address 0x0
    [ 93440.563]
    Fatal server error:
    [ 93440.563] Caught signal 11 (Segmentation fault). Server aborting
    [ 93440.563]
    [ 93440.563] (EE)
     

    Actually, the system is still using the old xorg, and it didn't use the newly compiled xorg under /usr/local/bin/

    What options should I use when I compile the XServer  for Ubuntu 12.04?

    Thanks,

    Wilson

    Sep 27, 2013 - 01:44am
  • Mak's picture
    Mak

    How to compile Xserver Xorg 1.14.2?

    Right now, i still use the old version Xorg in the system after compiling.

    Thanks,

    Wilson

    Oct 01, 2013 - 08:12pm
  • Topic locked