Sorry, you need to enable JavaScript to visit this website.

Use i7-7700K (HD Graphics 630) on CentOS 7

2 posts / 0 new
Ohkubo's picture
Starter
Ohkubo

Apr 03, 2017 - 07:34pm

  • Hello!
    I want to use i7-7700K (HD Graphics 630) on CentOS 7, but it works at 1024x768 resolution only now.

    First, I tried to use intel-graphics-update-tool-2.0.4-25.intel20164.x86_64.rpm, unfortunately it didn't work.
    # intel-graphics-update-tool
    intel-graphics-update-tool: symbol lookup error: intel-graphics-update-tool: undefined symbol: gtk_label_set_xalign

    Second, I tried to compile this tool, but it failed during configure.
    # tar Jxf intel-graphics-update-tool_2.0.4.tar.xz
    # cd intel-linux-graphics-installer-git
    # ./configure
    ...
    checking whether NLS is requested... yes
    ./configure: line 12450: intltool-update: command not found
    checking for intltool >= 0.40.1... found
    configure: error: Your intltool is too old. You need intltool 0.40.1 or later.

    So I installed intltool by
    # yum install intltool

    After that, I got these messages:
    ./configure
    ...
    configure: error: Package requirements ( gtk+-3.0 gio-2.0 polkit-gobject-1 packagekit-glib2 >= 0.5.2 libsoup-gnome-2.4 gmodule-2.0 ) were not met:

    No package 'gtk+-3.0' found
    No package 'gio-2.0' found
    No package 'polkit-gobject-1' found
    No package 'packagekit-glib2' found
    No package 'libsoup-gnome-2.4' found
    No package 'gmodule-2.0' found

    I feel it's a little hard way. Is there any better idea?

    My environment:
    CentOS Linux release 7.3.1611 (Core) (updated all installed packages today)
    Linux 3.10.0-514.el7.x86_64
    gcc version 4.8.5 20150623 (Red Hat 4.8.5-11) (GCC)

    Thanks in advance!

    Apr 03, 2017 - 07:34pm
  • Although I don't know why, it works fine today with 4K display!!!

    Yesterday, it was Linux 3.10.0-514.el7.x86_64 kernel.

    After updating all packages, and ***REBOOT***, it's 3.10.0-514.10.2.el7.x86_64.

    * Today's /var/log/Xorg.0.log :

    [    15.145] xf86EnableIOPorts: failed to set IOPL for I/O (Operation not permitted)
    [    15.146] (II) intel(0): Using Kernel Mode Setting driver: i915, version 1.6.0 20160229

    * Yesterday's /var/log/Xorg.0.log :

    [    10.805] xf86EnableIOPorts: failed to set IOPL for I/O (Operation not permitted)
    [    10.808] (EE) open /dev/dri/card0: No such file or directory

     

    Apr 05, 2017 - 12:13am
  • Hi - glad your problem got sorted out - sounds like an i915 fix or fixes got backported in your new kernel package. For what it's worth, for CentOS I'd recommend using an extra repository from here:

    https://wiki.centos.org/AdditionalResources/Repositories

    In particular elrepo - that will be a lot easier than porting the fedora packages the 01.org updater provides (because of dependencies and version skew and so forth).

    Apr 18, 2017 - 05:35am