Sorry, you need to enable JavaScript to visit this website.

Primary tabs

Finding Drivers After Install - Asrock Q1900M Pro3/Ubuntu 14.04

1 post / 0 new
01 Staff's picture
01 Staff (not verified)

Dec 10, 2014 - 07:23pm

  • 01 Staff's picture
    01 Staff (not verified)

    I upgraded an old machine to an Asrock J1900 motherboard today.  In order to have video drivers I also upgraded from Ubuntu 12.04 32 bit to Ubuntu 14.04 32 bit (it was an old install).  The machine came up as 800x600 and 1024x768 options only when plugged in using the VGA cable.  The system settings are reporting that graphics re Intel Bay Trail.  I downloaded and the version 1.0.7 graphics installer (Ubuntu 32bit version) and it appears to succeed with no errors.  After reboot I am presented with no new resolution options an the display setup reports.  I also tried a HDMI cable to the monitor (it is a HD TV).  The second monitor was detected I was presented with other resolution options.  Switching to HDMI input on the screen sort of worked.

    I want to check to make sure I  have the right driver before messing with the X configs.  I don't do this often - the last mobo upgrade for that box was 7 years ago.

    What package should dpkg show for Bay Trail?  What driver should I find?  Is this video even supported in Linux?


    Dec 10, 2014 - 07:23pm
  • fledermaus's picture
    fledermaus (not verified)

    Hi - to start with, the driver you want is the i915 kernel module. This ships as part of the kernel, and the installer from provides a newer version for the version of Ubuntu it is currently targeting (14.04) at the moment.

    The package will be something like i915-3.16-3.13-dkms (I forget the exact versions),
    and `modinfo i915' should show that module being loaded from a path that contains "dkms" in it.

    lspci -kvnn will show you more details about your graphics hardware (and a lot of other hardware
    too), but the main thing is that the i915 module has been loaded.

    For example, on my laptop:

    00:02.0 VGA compatible controller [0300]: Intel Corporation \
    2nd Generation Core Processor Family Integrated Graphics Controller \
    [8086:0126] (rev 09) (prog-if 00 [VGA controller])
    Subsystem: Lenovo Device [17aa:21da]
    Flags: bus master, fast devsel, latency 0, IRQ 50
    Memory at f0000000 (64-bit, non-prefetchable) [size=4M]
    Memory at e0000000 (64-bit, prefetchable) [size=256M]
    I/O ports at 5000 [size=64]
    Expansion ROM at <unassigned> [disabled]
    Capabilities: <access denied>
    Kernel driver in use: i915

    Dec 12, 2014 - 11:40am