Sorry, you need to enable JavaScript to visit this website.

Primary tabs

Install on Fedora 20 (beta)

13 posts / 0 new
01 Staff's picture
Starter
01 Staff (not verified)

Nov 25, 2013 - 01:16am

  • 01 Staff's picture
    01 Staff (not verified)

    Hello,

    with Fedora 20 coming around, how can I already install the drivers on the Beta-version?

    Obviously, the installer says 'distribution not supported', but with that patched out from the source code the installer stops at 'freedesktop.packagekit.update-package not in PackageKit' (error message from memory; not actual text).

    Did anyone succeed in installing the drivers on F20?

     

    I have another question: Why do I have to install the drivers via the installer anyway? All the packages from the intellinux-repository are already installed (in a newer version) from the f20-repo. I asked that myself for F19 as well, but after the installation my laptop was finally able to go to sleep AND wake up every time. I did not follow up my question. But now without installing the drivers by using the installer, it's a gamble whether the laptop goes to sleep and wakes up afterwards.

    Nov 25, 2013 - 01:16am
  • A quick bit of background: The way these releases work is that every quarter, Intel cuts a new release
    of the upstream packages. We then compare what's in the quarterly release with what's in the current
    release of each targeted distribution (or the next release if it's about to happen), and prepare a repository
    containing the updated packages equired to bring the distribution up to speed with upstream.

    So, it looks like the packagekit API changed in f20 (based on the error message you reported), which
    means that the installer will have to updated (again) for f20, which should happen when the Q4 release
    of the intel stack happens (a f19 release should be available shortly, it's going through QA right now).

    As to why you need to use the installer: Strictly, you do not. You can build the packages from source,
    or you can configure your package manager to point at the 01.org repositories directly, it's all good.

    The installer is mainly there to make the process as smooth as possible for people whoc don't know
    how or don't want to do those things.

    I hope that answers your questions.

    Nov 25, 2013 - 07:54am
  • kabooki's picture
    kabooki (not verified)

    So if I understand you right, I only have to install the mentioned packages from your repository instead of the ones from Fedora and I'm good?

    I will try that.

    Nov 25, 2013 - 10:47am
  • kabooki's picture
    kabooki (not verified)

    I installed the yum-plugin "yum-plugin-priorities" and added to the file "/etc/yum.repos.d/intellinux.repo" the line:

    ...
    priority=1

    After that, I did a yum distro-sync and it downgraded several packages (the drivers).

    Now, my laptop can go to sleep everytime I close the lid and it wakes up reliably by opening the lid.

     

    Thank you for this drivers.

     

    Nov 29, 2013 - 08:52am
  • Can anyone tell me how to add the Intel graphics driver repo for Fedora 20?

    Dec 18, 2013 - 03:52pm
  • Hi - there isn't a Fedora 20 repository for the Intel graphics stack yet - given that various people
    are off for the Christmas break right now, it'll be a few weeks before there is one (has to get
    built, and then go through several QA phases and all that - all terribly time consuming, I know,
    but it's got to be done).

    Dec 24, 2013 - 07:45am
  • kabooki's picture
    kabooki (not verified)

    For the last months it worked by having a file /etc/yum.repos.d/intellinuxgraphics.repo with the following content:

    [intellinuxgraphics]
    name=Intel Linux Graphics
    baseurl=https://download.01.org/gfx/fedora/19/
    gpgkey=https://download.01.org/gfx/RPM-GPG-KEY-ilg
             https://download.01.org/gfx/RPM-GPG-KEY-ilg-2
    gpgcheck=1
    enabled=1
    priority=1

    Unfortunately as of today, yum gives me a error 404 on updating on this repository. Hopefully it's just temporary.

    Jan 14, 2014 - 01:38pm
  • For reasons beyond our control, various proxies and caches seem to be getting
    in the way of our repo URLs, which usually doesn't matter but can really mess things
    up for a short while after a release when all the contents have just changed.

    _Should_ sort itself out fairly quickly.

    Jan 14, 2014 - 05:31pm
  • kabooki's picture
    kabooki (not verified)

    How long do you think it will take?

    I think it's another problem. The folders repodata for F17 and F18 contain the files with the hashvalue in the filename. The repo for F19 does not have that. Could this really be a cache issue?

    Jan 15, 2014 - 03:31pm
  • kabooki's picture
    kabooki (not verified)

    Unfortunately, I cannot edit my posts.

    Seems like I was too fast. It is working now.

    Jan 16, 2014 - 12:23am
  • Still no rough ETA for Fedora 20 support?

    Jan 24, 2014 - 02:47am