Sorry, you need to enable JavaScript to visit this website.

Primary tabs

Intel graphics installer breaks X on Ubuntu 12.04.2

6 posts / 0 new
01 Staff's picture
01 Staff (not verified)

May 19, 2013 - 03:43am

  • 01 Staff's picture
    01 Staff (not verified)

    Hi everybody,

    some days ago I had some problem with a clean install of ubuntu 12.04.2, so I looked a little bit into it and discovered that it ships with 12.10's kernel and Xorg. So I did some experiments on my Asus X201E and I realized that the Intel graphics installer breaks X (lightdm starts but just after that X crashes badly). I thinkt that is because the Intel installer recognize the installation as a pure 12.04 (so with 3.2 line kernel) while it's actually something in between (12.04 apps over 3.5 kernel and 1.13 Xorg (I think)). I tried installing the 12.10 version of the installer but I had no luck (the lines in /etc/apt/sources.list.d/intellinuxgraphics.list still refers to 12.04). I'm trying manually editing said lines but I'm not sure that will work.

    Anyway, if it's not just a problem of mine, can I suggest an update to the installer program (or at least a guide on how to correctly deal with it) since people getting ubuntu lts now from the website are getting the 12.04.2 version?

    Thanks a lot and have a nice day,



    EDIT: manually changing the apt sources gives a working evironnement with intel drivers but cairo (libcairo2, libcairo2:i386, libcairo-script-interpreter2) remains to the stock ubuntu version (1.12.2-1.0ubuntu0~precise2) for problems of unresolved dependecies. If someone knows what are the expected consequences please let me know :)

    May 19, 2013 - 03:43am
  • fledermaus's picture
    fledermaus (not verified)

    Hi. The kernel version test is purely based on the running kernel, not on the distro version detected, so this shouldn't matter - the only thing that should happen for 12.04.2 is that the backport i915 module doesn't get installed (as the kernel is newer than its source kernel).

    I'm going to do a fresh install of 12.04.2 and see how it behaves: If it's misdetecting things and installing an incompatible backport, that's defnitely a problem.

    With regards to the 12.10 packages - you could probably build them for 12.04.2 locally but I would expect dependencies to block most of them from the published repo (unless you got very lucky).

    May 20, 2013 - 07:47am
  • lambengolmor's picture
    lambengolmor (not verified)

    Ok, thanks! Please drop a line if everything works fine for you :) (I hope to eventually figure out what's not working)

    About the 12.10 packages: I wouldn't go that far since the system works. My main concern is that they appear grayed out in the update manager and that could "scare" non-technical users. (I volounteer at the local library performing ubuntu installations & assistence to people who are curious about FOSS but don't have a technical background so I'd like to know the best course of action to provide them the most unproblematic experience :) )

    May 20, 2013 - 10:15am
  • fledermaus's picture
    fledermaus (not verified)

    Ok, just finished here - looks like a bunch of packages ending in -lts-quantal got removed as a result of running the installer, probably because some of the packages in the installer are tied closely to versions from the original precise (the fact that they've pushed a slew of packages tagged -quantal into precise LTS gives me slight pause - suggests they've transplanted some rather major changes into the older release).

    I haven't experienced any breakage here - everything still seems to work - but it's possible depending on the exact hardware you've got there something necessary might have been removed.

    The kernel module did not get upgraded on 12.04.2 (as expected).

    This might be solved by us rebuilding all our packages against 12.04.2, I'll have to investigate further and check.

    Looking at the versions currently in 12.04.2, I'd say you could probably skip the intel installer for that version of precise (for now, anyway)- the installer would bring significant advantages on vanilla 12.04 but 12.04.2 looks different enough that we'll either have to rebuild and re-test everything or maybe retire our installer for 12.04.

    If you still have access to the machine that broke under the installer, I'd be interested in the installer's log file (which can be found in /var/tmp/)

    May 20, 2013 - 11:04am
  • lambengolmor's picture
    lambengolmor (not verified)

    I do still have access to the machine that broke down but I can't rember if I did a purge to make it work again (so I don't know if the logs are still relevant). In add I don't actually understand them, so I'll pastebin everything I have:

    • intel-linux-graphics-installer-2655.log: this is probably "the one" since it has been created on 19 may 11:29
    • intel-linux-graphics-installer-3872.log: this could be interesting since it has been created on 19 may 12:00 (if I remebrer correctly, after it broke I did a purge, reinstalled and manually set the apt line to 12.10... this could be the "reinstall one")
    • intel-linux-graphics-installer-3000.log (part1 and part2, it's too long for free pastebin): this is probably the one from my first installation (when the system was still a plain 12.04.1) and everything worked (maybe you'll find it useful for comparaison?) since it has been created on 9 april.

    I hope all of this could be of some use... I've seen some parts are localized, if you need a translation just point me to the interesting bits.

    About skipping the installer: thanks, I thought that too, but having confirmation is really a good thing! :) Anyway for new installations I'll probably stick to 12.04.1 with, if needed, the driver installer.

    About Canonical messing up dependecies: a lot of people are quite unsatisfied with that (personally the other problem I had is that the whole thing breaks Steam dependencies). On the user-side probably the main issue is that if you install 12.04 and update it the system will say it's a 12.04.2 (but the kernel and X are the "precise" ones) while if you install 12.04.2 the system will still say it's a 12.04.2 (but the kernel and X are the "quantal" ones)... So, same name for two quite different things... Apparently they are going to do the same for 12.04.3 (that will ship the "raring" versions). Here there's some info about it (but you probably already know it :) ).


    May 21, 2013 - 02:00am
  • fledermaus's picture
    fledermaus (not verified)

    Right. Same thing happening here as in the other reports that are trickling in: The renamed packages with -lts-quantal in their names are being removed in favour of the older vanilla packages from precise, because one of the intel packages depends on them, and since the new packages have been renamed, the package manager doesn't realise they're the same.

    I suspect if they'd just released newer versions of xorg-* things would have worked correctly:
    Thanks for the log files.

    May 21, 2013 - 05:59am
  • lambengolmor's picture
    lambengolmor (not verified)

    You're welcome! I hope some else will find this useful :)

    May 21, 2013 - 08:23am