Sorry, you need to enable JavaScript to visit this website.

Primary tabs

Intel HD3000 problem with brightness function keys - Dell N411z

30 posts / 0 new
01 Staff's picture
Starter
01 Staff (not verified)

May 12, 2014 - 08:07am

  • jeremyb's picture
    jeremyb (not verified)

    https://help.ubuntu.com/community/BootOptions#Common_Kernel_Options

    Have you tried some of these acpi commands? I have looked for a while to find a significant difference in dell_wmi and dell_laptop between the good kernel and the bad and cant find much

    Jun 03, 2014 - 09:44am
  • madvinegar's picture
    madvinegar (not verified)

    I have tried various grub parameters like acpi_backlight=vendor, acpi_osi=Linux, acpi_osi=\"!Windows 2012\" etc. but nothing seems to work.

    Also have a look at this pastebin as it may be helpful.

     

    http://paste.ubuntu.com/7582689/

    Jun 03, 2014 - 11:53pm
  • jeremyb's picture
    jeremyb (not verified)

    The last two lines look like what I saw in the Xorg log after changing a video parameter in /sys/module/video/parameters/  I changed brightness_switch_enabled to N but my brightness keys still worked but it might be something to try

    su

    /sys/module/video/parameters/

    echo N > brightness_switch_enabled

     

    Then you can test your hotkeys, if nothing changes just

    echo Y > brightness_switch_enabled

    exit

    Have you ever used showkey in tty1?

    CRTL+ALT+F1 enter username and password

    showkey

    and start pressing FN+ combos and see what registers, 10 seconds after the last keypress showkey should quit and you can press CTRL+ALT+F8 to return to GUI and it might be F7 or F9 for Ubuntu

    Jun 04, 2014 - 04:22am
  • jeremyb's picture
    jeremyb (not verified)

    it should be

    su

    cd /sys/module/video/parameters/

    echo N > brightness_switch_enabled

    Jun 04, 2014 - 04:24am
  • madvinegar's picture
    madvinegar (not verified)

    I will try in the afternoon when I get back home and let you know.

     

    Again, thank you very much. Even if in the end we don't manage to find a solution, I want tou to know that I really appreciate your assistance.

    Jun 04, 2014 - 05:12am
  • madvinegar's picture
    madvinegar (not verified)

    Tried chanfing the brightness switch, unfortunately no result.

    Also tried "showkey" but again the brightness keys do not produce any kind of result.

     

    The funny thing is that the pastebin of Xorg says:

    [    28.805] (--) intel(0): found backlight control interface acpi_video0 (type 'firmware')

     

    This means that acpi_video0 is used for changing the brightness?

    How can I blacklist intel_backlight and leave only acpi_video0 working?

    I tried blacklisting acpi_video0 (by adding "blacklist video" inside blacklist.conf), but after the restart I have again two  backlight folders but this time they were "dell_backlight" and "intel_backlight".

     

    What is the module of intel_backlight so as to blacklist it and see if that helps...?

    Jun 04, 2014 - 11:54pm
  • jeremyb's picture
    jeremyb (not verified)

    You don't want to blacklist anything video if you want it to work.  The i915 module is likely the cause of intel_backlight but with the hotkeys not working the issue is likely deeper than that

     

    It appears that these dell models had backlight issues in windows and the fix was to set the card to max performance in advanced power management so I wonder if noapm in grub might work

    Jun 05, 2014 - 04:39am
  • madvinegar's picture
    madvinegar (not verified)

    How do i add this parameter?

    acpi_osi=noapm

     

    ???

    Jun 05, 2014 - 08:07am
  • madvinegar's picture
    madvinegar (not verified)

    On another note, the same problem exists on Dell XPS models. i.e. the function keys do not work after 13.10 kernel.

    In order to solve same, they had to get into BIOS and change the "Load Legacy Option Rom" to "Enabled".

     

    See here the bug report for a Dell XPS with the exact same intel card as mine and the exact same problem: https://bugs.launchpad.net/ubuntu/+source/linux/+bug/954661

     

    In my situation, even if I have installed the latest recomended bios from dell for my N411z (i.e. A06), there is no option in the settings of BIOS for "Load Legacy Option Rom".

     

    Can this be enabled by terminal or a grub parameter?

    Jun 05, 2014 - 08:10am
  • jeremyb's picture
    jeremyb (not verified)

    The noaspm can be added to quiet splash just as it is. If your pc was oem with win7 the correct acpi_osi= would not have been !Windows 2012 and then you have to add some backslashes to make it work in /etc/default/grub with the quotes but it would be simpler to edit during grub boot as the quotes would be single instead of double. You could simply add acpi_osi="!Windows2007"

    After reading some more, your updated bios might work with the acpi_osi="Windows 2012"

    Jun 05, 2014 - 02:43pm