Sorry, you need to enable JavaScript to visit this website.

Primary tabs

Loading Graphic driver for Intel Atom N2600 processor

3 posts / 0 new
01 Staff's picture
01 Staff (not verified)

Mar 16, 2016 - 04:42pm

  • 01 Staff's picture
    01 Staff (not verified)

    Hi there,


    I got a question for a brand-new Ubuntu 14.04 LTS graphic installation, this embedded  system running on top of Intel Aton N2600 CPU, and Intel NM10 intel chipset. 

    After a brand-new OS installation, I found the system is slow, and realized  only the basic graphic  driver installed, the currently resolution  is only (800*600).

    Below steps is what I tried so far but has no luck to get it work.


    1. I downloaded the Intel graphic installer for LINUX from, it installed successfully, but tells me that "You don't seem to have an Intel i915 chipset so no update are needed".

    2. Type command ""Sudo lshw -c video | grep 'configuration' " in term, I got below

        configuration: driver=gma500 latency=0

    3. Try find gma500 linux driver but I got nothing.


    Does anyone know how to install this driver?




    Mar 16, 2016 - 04:42pm
  • fledermaus's picture
    fledermaus (not verified)

    Let's start by checking to see which video driver is in use: lspci -kvnn should tell you this.
    There will be a section starting with something like "00:02.0 VGA compatible controller"
    and ending with Kernel driver in use: <kernel module name here>

    Paste that section of the output here.

    Mar 21, 2016 - 01:14pm
  • adamy's picture
    adamy (not verified)

    Hi Vivek, thanks you so much for the reply. I don't have that unit to test anymore, I have downgrade to 12.04 LTS, and seems the graphic makes a little bit better. For the currently unit that I am testing which also running 12.04 LTS, I got message below:


    $ lspci -kvnn | grep -i vga
    01:00.0 VGA compatible controller [0300]: NVIDIA Corporation G86M [GeForce 8400M GS] [10de:0427] (rev a1) (prog-if 00 [VGA controller])


    So I am pretty sure that this unit's driver has been loaded properly; however I recall the previous unit that I am worked on, it was showing Mesa Video driver. and I looked for everywhere just can't find the driver for Intel N2600.

    Mar 28, 2016 - 10:14am
  • fledermaus's picture
    fledermaus (not verified)

    Well, NVIDIA Corporation G86M [GeForce 8400M GS] [10de:0427] would indicate that you've got an Nvidia based display, not an Intel one.
    I would guess you need one of the package sets described here:

    Mar 29, 2016 - 07:37am