Sorry, you need to enable JavaScript to visit this website.

Primary tabs

New installer problems

23 posts / 0 new
01 Staff's picture
Starter
01 Staff (not verified)

Jul 30, 2013 - 04:12pm

  • 01 Staff's picture
    01 Staff (not verified)

    Error running transaction: GDBus.Error:org.debian.apt.TransactionFailed: error-no-package: Package i915-3.9-3.8-dkms isn't available
     

    Dunno :D

     

    PS - I replied to myself under this post, and i added the key for fedora into the post by accident, im using the right key

    Jul 30, 2013 - 04:12pm
  • diote's picture
    diote (not verified)

    Also after trying fresh install, i try to add the

    wget --no-check-certificate https://download.01.org/gfx/RPM-GPG-KEY-ilg-2 ; \
    sudo rpm --import RPM-GPG-KEY-ilg-2

     

    but i get sudo: rpm: command not found

    Jul 30, 2013 - 04:18pm
  • cliffb's picture
    cliffb (not verified)

    Install rpm (assuming you are using ubuntu) with

    sudo apt-get install rpm

     

    Cliff

    Jul 31, 2013 - 03:44am
  • cliffb's picture
    cliffb (not verified)

    I had the same error on Ubuntu 13.04. I installed package dkms (sudo apt-get install dkms) to proceed.

    However I now get  the following

    Failed to fetch https://download.01.org/gfx/ubuntu/13.04/main/pool/13.04/libv/libva/libv... The requested URL returned error: 404 Not Found
    Failed to fetch https://download.01.org/gfx/ubuntu/13.04/main/pool/13.04/libv/libva/libv... The requested URL returned error: 404 Not Found
    Failed to fetch https://download.01.org/gfx/ubuntu/13.04/main/pool/13.04/libv/libva/libv... The requested URL returned error: 404 Not Found

     

     
    Looking at the packages these seem to be the old versions, the new ones being version 1.2
     
    Sigh, more wasted time. Does nobody bother to test this stuff before release or am I just being stupid (not unheard of)?
     
    As I'm a sucker for punishment I will install F19 and try these updates although last time Ubuntu HD video seemed a lot smoother than Fedora HD video for reasons I don't understand. I have an i7-4770k processor so would really expect HD graphics performance to be at least adequate by now if Intel are serious about Linux support.
     
    Let's hope these errors are just teething problems.
     
    Cliff
    Jul 31, 2013 - 03:41am
  • helium's picture
    helium (not verified)

    Hi,

    first : Thanks for the work ... but same problem here.
    Seems like someone forgot to update the dependencies :)

    Cheers
    Andi

    Jul 31, 2013 - 05:42am
  • Hi cliffb and helium, 

    First of all thanks for using the installer and reporting the issue.

    We do test installer, packages and the final result. Our QA team confirmed result after installer, graphics stack quality is the same as the stack release 2013Q2.

    Also, the Installer doesn't explicit any package version itself. Installer configures the 01.org repository at your distribution that updates database based on the versions available at the repository. As you saw, version 1.2 is available there so your distribution after a database update should get that. 

    Our packages are automatically built and repositories automatically generated by OBS. So, I it is not clear to me what can be happening on your cases. But there is something clearly going wrong with your cases here and we are going to investigate and let you know how to fix it as soon as possible.

    Thanks again,

    Rodrigo.

    Jul 31, 2013 - 06:18am
  • cliffb's picture
    cliffb (not verified)

    Message from Fedora install

    "You are running kernel 3.10.3-300.fc19.x86_64, which is too old and not supported"

    I suspect that the install script is comparing 3.1 with 3.9 and failling. I have done a vanilla install of Ubuntu 13.04 and now Fedora 19 and both installations failed immediately with the graphics installer.

    Thanks for the feedback Rodrigo, I'll await further developments.

    Cliff

    Jul 31, 2013 - 06:47am
  • fledermaus's picture
    fledermaus (not verified)

    Hm, looks like that bug was only partially fixed last time round.
    I'll push a patch for it, thanks for letting us know.

    Jul 31, 2013 - 09:48am
  • helium's picture
    helium (not verified)

    Ign https://download.01.org Ubuntu/13.04 Translation-en_US
    Ign https://download.01.org Ubuntu/13.04 Translation-en                        
    Fetched 326 kB in 6s (49,5 kB/s)

    I did the apt-get update ( did that before ) . Still the same. Database has not been updated for some reason how.

    Thanks for the answer !

    B/R
    Andi

    Jul 31, 2013 - 07:03am
  • fledermaus's picture
    fledermaus (not verified)

    Would those of you experiencing problems be willing to share:

    • the contents of /etc/apt/sources.list.d/* (all file contents there)
    • apt-cache policy libdrm2 (output)
    • whether you have previously installed the ILG stack via the installer
    • the contents of ~/.ilg-config after you have run the installer

    Interested in getting to the bottom of this one.

    Jul 31, 2013 - 07:41am
  • cliffb's picture
    cliffb (not verified)

    Finally got it to install on Fedora 19

    Boot using the supplied kernel 3.9.5

    Edit /etc/yum.repos.d/intellinuxgraphics (remove repos from the directory path)

    [intellinuxgraphics]
    name=Intel Linux Graphics
    baseurl=https://download.01.org/gfx/fedora/$releasever/
    gpgkey=https://download.01.org/gfx/RPM-GPG-KEY-ilg
    gpgcheck=1
    enabled=1

    Can't remember if I had to run it twice but it did install

    This ain't my company's definition of a software rollout!

     

    Cliff

     

     

    Jul 31, 2013 - 10:02am