Sorry, you need to enable JavaScript to visit this website.

Primary tabs

NUC5i3RYH - Black screen - Debian

19 posts / 0 new
01 Staff's picture
01 Staff (not verified)

Sep 10, 2015 - 06:07am

  • 01 Staff's picture
    01 Staff (not verified)

    Dear Forum Members,


    New Forum user here, hope you can help.


    I have an Intel NUC model NUC5i3RYH with Intel HD Graphics 5500. I want to run Debian on it. I installed Jessie (kernel 3.16) and I got a black screen soon after boot. Some preliminary reading seemed to suggest that a more recent kernel could fix the problem. So I installed Stretch (kernel 4.1~) but still get the black screen after boot.


    Currently the only way I can avoid the black screen is to add "i915.modeset=0" to the Grub configuration file ("nomodeset" also works) but this is less than ideal since then I have no control over screen resolution. Other things I've tried after searching online:

    • "acpi_backlight=vendor acpi_osi=Linux" (as boot options): doesn't make a difference;
    • "setpci -s 00:02.0 F4.B=30" in /etc/rc.local (for brightness): also doesn't make a difference;
    • "acpi=off": seems to have the same effect as "nomodeset".

    After more searching I landed on the Intel Graphics for Linux project page which made me think my drivers/graphics stack may not be up date. However after checking my installed packages it seems as if I have all the necessary components with same version as in the 2015Q2 Stack Release page (if not a more recent version). There were a couple of packages that I was not entirely sure about though.


    Anyways, the issue is black screen right after the boot process starts. If anyone could provide any help towards fixing this, it would be greatly appreciated.


    Sep 10, 2015 - 06:07am
  • fledermaus's picture
    fledermaus (not verified)

    Hi - if you have kernel 4.1 you should have a recent enough i915.ko: You can doble check that it's in use with
    "lspci -kvvnn" - probably also worth checking the dmesg output for errors.

    Other than that, there's a similar NUC bug reported here:

    No resolution yet, but there is a link to how to report a bug with all the necessary details: Hope that helps.

    Sep 14, 2015 - 04:05pm
  • fez01's picture
    fez01 (not verified)

    Hello and thank you for your reply!


    I have attached below the parts I thought were relevant from my "lspci -kvvnn" output. As for "dmesg", assuming errors appear in red, I only had a few of those for my wifi card but none that seemed related the graphics card. I had a quick look at the bug reporting process: it goes way over my head and I'm not sure where I should start.


    00:02.0 VGA compatible controller [0300]: Intel Corporation Broadwell-U Integrated Graphics [8086:1616] (rev 09) (prog-if 00 [VGA controller])
    Subsystem: Intel Corporation Device [8086:2057]
    Control: I/O+ Mem+ BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr- Stepping- SERR- FastB2B- DisINTx+
    Status: Cap+ 66MHz- UDF- FastB2B+ ParErr- DEVSEL=fast >TAbort- <TAbort- <MAbort- >SERR- <PERR- INTx-
    Latency: 0
    Interrupt: pin A routed to IRQ 48
    Region 0: Memory at a9000000 (64-bit, non-prefetchable) [size=16M]
    Region 2: Memory at b0000000 (64-bit, prefetchable) [size=256M]
    Region 4: I/O ports at 3000 [size=64]
    Expansion ROM at <unassigned> [disabled]
    Capabilities: <access denied>
    Kernel driver in use: i915
    Sep 17, 2015 - 02:21pm
  • fledermaus's picture
    fledermaus (not verified)

    Thanks for the info. I'll bounce it across to the devs and see what they say.

    The output of modinfo i915 may also be enlightening.

    Sep 22, 2015 - 06:13am
  • fez01's picture
    fez01 (not verified)

    Hi and thanks for the quick reply!


    Here is the output of my modinfo i915 (by the way, I don't know if it matters, but I'm running this with sudo otherwise I get 'command not found'). It's a Google Docs link because the spam filter was blocking it.


    Sep 22, 2015 - 07:23am
  • fez01's picture
    fez01 (not verified)

    I don't know if it helps but I have observed the following behaviour.


    Starting without the nomodeset option causes a black screen. However I noticed that the display is trying to turn on as the power led will at random intervals go from orange (off) to green (on) but revert to orange right away. What I can see on screen is the backlight quickly flickering on and off. At no time I get anything displayed on screen, not even a blinking cursor.

    Sep 23, 2015 - 11:37am
  • cchafe's picture
    cchafe (not verified)

    Same thing here. NUC5i7RYH, fedora 22, 4.1.7-200.fc22.x86_64

    Black screen on boot problem does not occur with any earlier kernels I've tried.

    X applications working fine via SSH.


    Results of modinfo i915 at



    Sep 28, 2015 - 12:11pm
  • fez01's picture
    fez01 (not verified)

    Thanks for sharing!


    Mind if I ask what distribution/kernels you've tried that worked for you? Older kernels never worked for me. I tried Debian Jessie (3.16) and Ubuntu 15.04 (3.19).

    Sep 28, 2015 - 02:10pm
  • cchafe's picture
    cchafe (not verified)

    I've only used Fedora Core 22. The kernel version which ships with the distro is fine



    I had updated a few times over the past two months but don't have a log of which kernels that brought in. When the

    most recent update resulted in this problem, I did a complete fresh install and  dnf update which installed


    and reproduced the problem. With this as the machine's current state, things are fine when booting




    Oct 03, 2015 - 12:03pm
  • piotrekfronc's picture
    piotrekfronc (not verified)

    Same here, I have I7-5775 (HD6200). Motherboard Z97i-PLUS. (Desktop setup)

    All newest kernel on debian testing.

    Ive tried a lot, any nomodeset or acpi=off ends up with device unrecognised and i915 is unloaded.

    Any news on this?

    I tried but no results.

    Ubuntu instalations are so unstable on broadwell that I dont bother evn trying more (they just crash or hang on turbo mode).

    Oct 04, 2015 - 01:15pm
  • fez01's picture
    fez01 (not verified)

    Actually I ended up solving my problem, although I don't how helpful this will be.


    When the problem occurred, I was using a Dell monitor connected via a VGA cable to a miniDisplayPort to VGA adapter. After switching to a Samsung monitor hooked up via DVI and a miniDisplayPort to DVI adapter, all my problems went away and the monitor was recognized correctly.

    Oct 04, 2015 - 03:35pm