Sorry, you need to enable JavaScript to visit this website.

Primary tabs

Problems with new installer

1 post / 0 new
01 Staff's picture
Starter
01 Staff (not verified)

Nov 05, 2013 - 04:38pm

  • 01 Staff's picture
    01 Staff (not verified)

    Hello,

    I'm new at this and I'm having some problems, if anyone can help I would apppreciate it a lot.

    I have an intel core I5 2nd generation 64-bits, I was trying to use this new install because I need to use OpenGL 3.3. I'm on Debian jessie. An other thing is that i'm not sure what should be the order to install this new packages. I tried first with xorg-server-1.14.2 and I'm missing package pixman-1 according to the './configure' execution. Here is the message 

    checking for PIXMAN... no
    configure: error: Package requirements (pixman-1 >= 0.27.2) were not met:
    
    No package 'pixman-1' found
    
    Consider adjusting the PKG_CONFIG_PATH environment variable if you
    installed software in a non-standard prefix.
    
    Alternatively, you may set the environment variables PIXMAN_CFLAGS
    and PIXMAN_LIBS to avoid the need to call pkg-config.
    See the pkg-config man page for more details.
    I do not know much, so i don't know if I should install another package before this one. If i try to apt-get install pixman it says 
    E: Unable to locate package pixman
    But libpixman-1-0 is already the newest version.
    Can anyone help me with this new installer?
     
    Nov 05, 2013 - 04:38pm
  • horon's picture
    horon (not verified)

    Hello adrnavarro,

      It seems you are missing the development headers, usually in -dev package. In this case, libpixman-1-dev.

      Alternatively, you could install missing build dependencies by issuing:

      $ sudo apt-get build-dep xorg-server

     Let me know if that worked for you.

    Regards

    Nov 12, 2013 - 04:51am