Sorry, you need to enable JavaScript to visit this website.

Primary tabs

Support ubuntu 13.10

102 posts / 0 new
01 Staff's picture
Starter
01 Staff (not verified)

Oct 17, 2013 - 09:37pm

  • trendzetter's picture
    trendzetter (not verified)

    Let me correct that: HDMI video does work for me with 4th gen haswell but audio over HDMI is not working in the mainline kernel.

    Dec 10, 2013 - 10:24am
  • horon's picture
    horon (not verified)

    Please, could you attach the output of the following command: uname -a and paste dmesg output (var/log/dmesg). If you can find any evidence (log, trace) of HDMI audio not working, that would be very helpful to help improve the driver.

    I am in the hope of next release, 13.10, to fix all problems for you.

    Dec 10, 2013 - 03:19pm
  • trendzetter's picture
    trendzetter (not verified)

    I am currently on a very recent kernel: Linux 3.13.0-031300rc2-generic #201311291635 SMP Fri Nov 29 21:36:49 UTC 2013 x86_64 x86_64 x86_64 GNU/Linux

    I could hear some audio over hdmi when visiting a friend. It had interuptions and alternated with speeded up sound. Very bizarre.

    At home I could hear nothing over hdmi but when I use pavucontrol I can see the bar indicating sound going up and down.

    In windows2go the audio over hdmi is working ok when installing the intel driver so the cable and the TV are ok.

    dmesg output: h++p://pastebin.com/9Rns2Fe6

    I just noticed these HDMI related lines at the bottom:

    [ 7030.513042] HDMI: Unknown ELD version 10
    [ 7030.514512] HDMI: Unknown ELD version 10
    [ 7030.516114] HDMI: Unknown ELD version 10
     

    Dec 11, 2013 - 11:11am
  • horon's picture
    horon (not verified)

    That's very  interesting, ELD is HDMI audio.. which seems to be a problem there.

    Can you also paste /var/log/Xorg.0.log and output of "lspci -vvnn"?

    Dec 11, 2013 - 11:19am
  • trendzetter's picture
    trendzetter (not verified)

    I put the X.org.0.log here: http://pastebin.com/3xq2FSBy and the output lspci here: http://pastebin.com/CdC5WCw0

     

    I am willing to fill a bug but having a guiding hand in determining what to log certainly helps.

     

    Dec 11, 2013 - 11:53am
  • trendzetter's picture
    trendzetter (not verified)

    I just noticed that the output of lspci contains more juicy output when running it as root:

    http://pastebin.com/E3M3GhnT

    Dec 11, 2013 - 11:58am
  • trendzetter's picture
    trendzetter (not verified)

    Is there anything else that I can upload?

    Where should I look to check if the issue is resolved, changelog of new kernels? I would like to test the proposed patches and give feedback.

    Dec 18, 2013 - 04:10am
  • Hi trendzetter,

    Could you please open a bug entry at bugs.freedesktop.org?

    Please read the guides https://01.org/linuxgraphics/documentation/how-report-bugs to make sure you provide all necessary information for all developers.

    Also if possible I'd like you to check if the same error happens on our development tree, nightly branch available here: http://cgit.freedesktop.org/~danvet/drm-intel/log/?h=drm-intel-nightly

    Thanks,

    Rodrigo.

    Dec 18, 2013 - 08:45am
  • meeder's picture
    meeder (not verified)

    I have the same issue. With Ubuntu 13.04 audio over HDMI didn't work as well but with the 01.org driver it worked perfectly.

    After the upgrade to 13.10 audio over HDMI stopped working and I contacted System76 but they claim that there is an hardware fault which causes audio over HDMI to fail (when I asked them how it is possible that it works in Windows and 13.04 with the 01.org drivers they became somewhat silent and now they are backing away from the hardware error issue slowly). So much for the technical knowledge of that company....

    I tried installing everything from source but that left me with a non-working graphical environment.

    I have a System76 Gazelle Pro laptop (GAZP9) with a Haswell processor and no additional graphics adapter.

    Dec 30, 2013 - 01:09pm
  • galaxymaster's picture
    galaxymaster (not verified)

    Hi meeder,

    I also tried building and installing the latest stack from source, but I also ended up with an unusable graphical envoirement. My problem was that after logging in I got a black screen with only the mouse visible. I have installed everything one-by-one and rebooted after every install, and I got the problem after installing Mesa 10.0. More info on my thread: h++ps://01.org/linuxgraphics/node/263. I will try to install everything from source except Mesa, and post the results on my thread. If it works I will try to install a precompiled Mesa 10 package from a PPA and will also post the results on my thread.

    Dec 31, 2013 - 05:45am