Sorry, you need to enable JavaScript to visit this website.

Primary tabs

Why can't I get sound through HDMI for Intel NUC in Ubuntu 16.04 nor Fedora 24?

5 posts / 0 new
01 Staff's picture
01 Staff (not verified)

Oct 18, 2016 - 07:13am

  • 01 Staff's picture
    01 Staff (not verified)

    I have this annoying issue getting sound through HDMI on an Intel NUC.


    Here is a description of the issue in a post I made on



    Everything looks complete fine, except there is no sound through HDMI (sound through the headphones jack works just fine though).


    Could this be a driver issue somehow?

    Oct 18, 2016 - 07:13am
  • fledermaus's picture
    fledermaus (not verified)

    Not really a graphics installer question, but it sounds like the HDMI audio is being deselected as the default channel, or something. Can you run pulseaudio with the debugging cranked up and try one of the test cases where you mute/unmute to get sounds and them play a video, and then lose sound as soon as the video stops? Might shed some light on what decisions are being made about the sound sinks.

    Oct 18, 2016 - 08:57am
  • hahahihihoho's picture
    hahahihihoho (not verified)

    I ran pulseaudio with the highest verbosity, you can find the log [here](


    Here's what I did:

    1. I started the daemon

    2. I tried increasing and decreasing the volume. I expect the little pop sound everytime i change the volume, but there is no sound.

    3. I then start spotify and start playing a song, but still no sound

    4. I then open alsamixer, select the HDMI card, and I mute and unmute the sound

    5. Now there is all of a sudden sound

    6. I increase and decrease the volume again, but this time there is sound

    7. I then pause the song in spotify and wait for a while

    8. When i start playing the song again there is no sound again

    9. I kill the daemon


    I am using HDMI card 0 device 3.


    I am not plugging in any other sound cables.


    Any idea what causes this issue? 


    Oct 19, 2016 - 05:00am
  • fledermaus's picture
    fledermaus (not verified)

    Hi there. Sorry about the delay - I was away travelling for work, and then away on holiday - just catching up with, well, everything.
    Let's start with the pulseaudio log - I'm not an expert but I see a few things worth chasing up:

    PA is opening some sort of cached database here: /home/tv/.config/pulse/d3307795c10845baaaa7d99b3d1209ad-card-database.tdb
    Hypothesis A - this DB is corrupt or has become invalid - maybe try moving it out of the way - it's in the user's home dir so PA should
    recreate it on demand.

    Next up: PA is looking for /usr/share/alsa/ucm/HDA Intel HDMI/HDA Intel HDMI.conf
    but cannot find it (this may not be a problem, I'm not sure). Now libasound2-data does contain
    a files in /usr/share/alsa/ucm/…
    Hypothesis B - the config file is missing and PA can't cope without it: Install libasound2-data if it is not installed,
    check for files under /usr/share/alsa/ucm.

    Next - PA tries and fails to open a bunch of files matching the pattern /dev/snd/pcm*
    Hypothesis C - PA is trying to open the wrong device files for some reason. Check which
    device files are actually present, check PA' config for mention of the nonexistent device

    Next - a while slew of snd_pcm_hw_params_set_channels(6) failed: Invalid argument and
    Hypothesis D - the alsa config on the machine is messed up, PA is trying to drive the devices
    in some wrong way as a result.

    We're at the limit of my knowledge of PA here, but that log looks like it has plenty to go on.
    Try the config checks/tweaks above, if they don't work I recommend attaching the log
    to a bug reported to ubuntu.

    Hope that's of some help.

    Nov 08, 2016 - 09:21am
  • hahahihihoho's picture
    hahahihihoho (not verified)

    Actually I finally solved this.


    It turned out to be pulseaudio was using the wrong sample rate.


    Following the advice in tom.ty89's 2016-01-11 08:37:45 post, my sound suddenly came alive...


    p.p1 {margin: 0.0px 0.0px 0.0px 0.0px; font: 9.0px Courier; color: #839496; background-color: #022b36} span.s1 {font-variant-ligatures: no-common-ligatures}


    Thanks anyway!

    Nov 09, 2016 - 04:58am
  • fledermaus's picture
    fledermaus (not verified)

    Glad you got it fixed.

    Nov 22, 2016 - 05:35am