Sorry, you need to enable JavaScript to visit this website.

Unable to compile xf86-video-intel-2.99.917

1 post / 0 new
Dr Vertigo's picture
Starter
Dr Vertigo

May 12, 2017 - 06:02pm

  • Requesting advice:

    System: Ubuntu 17.04, NUC715BNH (intel HD640)
    Problem: HD/1080p video stutters, as does, of course, 4k video.
    Unable to use the 'intel graphics update tool' due to running latest Ubuntu, but glad the tool exists - thankyou Intel for the linux support.
     
     
     
    Able to compile all items in the Intel Video 2017Q1 stack, except xf86-video-intel-2.99.917, whereby make fails with:
     
    i810_video.c: In function 'I810BlockHandler':
    i810_video.c:1149:6: error: too many arguments to function 'screen->BlockHandler'
         (*screen->BlockHandler) (BLOCKHANDLER_ARGS);
     
    I suspect this is due to a different version of XOrg, I am running Xorg/xserver: 1.19.3
     
    Looking for anyway to complile the stack so I video can run on this new hardware, while we await the new version of the Intel Graphics Installer.
     
    Any guidance appreciated.
     
    Thankyou.
    May 12, 2017 - 06:02pm
  • Not sure why it's not building for you - fwiw the next release of the updater _won't_ be updating the xorg intel driver for a few reasons - the short version is that there's enough change going on there that we don't want to second guess the distribution just now.

    May 16, 2017 - 08:34am