Sorry, you need to enable JavaScript to visit this website.

Unable to logon after running intel-graphics 2.0.5 (Ubuntu 17.04)

1 post / 0 new
Nistad's picture
Starter
Nistad

Jul 27, 2017 - 03:43pm

  • After tring to upgrade the graphics drives for Ubuntu 17.04 (from 16.04), something during the installation failed. Now when I boot up the system I get a warning, saying the system was started in low-graphics mode. I am able to log into a terminal session, but not start the desktop, or xserver.

    When I try run intel-grapgica-upgrade-tool, there is only an error message saying the xserver could not srart. Is there a way to resume the upgrade, or revert it to a previously working condition, or running the intel-graphics tool as a (purely) command line interface / utility?

     

    Sincerely,

    Jul 27, 2017 - 03:43pm
  • You can add and remove packages on the command line, yes. The update tool is mainly aimed at people who are not confortable with doing this, but if you can't start X I suggest you start by checking the output of dmesg, and the contents of /var/log/Xorg.0.log (or similar) for any relevant looking errors.

    The installer will have logged everything it did to a file in /var/tmp, which should tell you which packages were installed.

    Start with the following:

    apt-get -f install

    This will tell you if the package manager knows of any broken packages, and try to fix them.

    Next, you can revert to your original packages. To do this:

    remove the 01.org repo (/etc/apt/sources.list.d/intellinuxgraphics.list)

    apt-get update

    This will make the package manager forget all about the 01.org repos

    for each package listed in the downloaded config file (~/.ilg-config)
    in the section for 17.04 (zesty) on a line starting with 'u' or 'i'
    do the following:

    apt-get install <packagenamehere>/zesty

    That will pull in the most recent version of the package from the remaining repos.

    For example:

    [Ubuntu zesty]
    source …
    source zesty
    source main
    # kernel
    kernel 0.0 4.10 n …
    kernel 4.10 4.11 i i915-4.11.6-4.10.0-dkms
    kernel 4.11 9.9 n kernel is up to date
    # mesa
    u libegl1-mesa
    # libegl1-mesa-drivers

    would require: apt-get install libegl1-mesa/zesty
    to restore the original version (after removing the 01.org repo)

    If you have an i915-* package (it'll have ‘dkms’ in its name) then remove that too,
    and reboot.

    Let me know if you have any trouble with any of this.

    Jul 31, 2017 - 10:31am