Sorry, you need to enable JavaScript to visit this website.

How do I install 1.0.8 from source in Debian 8?

5 posts / 0 new
admin's picture
Starter
admin

May 08, 2015 - 04:03am

  • I want to get my onboard HD4600 graphics working to try my Steam games and install XBMC or Kodi.

    I don't see the new drivers available for plain Debian, so if I download the source code drivers, how would I install them?

     

    Thank you in advance for any assistance you can provide.

     

    Len

    May 08, 2015 - 04:03am
  • For debian jessie if you install the most bpo kernel (backports.debian.org) you should be most of the way there.

    Other than that, the significant packages are likely to be mesa and libdrm, although you may not need to
    update these (I have steam running on a partially upgraded wheezy install, so jessie should present no
    real obstacles)

    Jun 17, 2015 - 11:23am
  • Hi all:

    I am using laptop graphics built into Intel Core i7 4800MQ CPO @ 2.70 Ghz x 8, running Debian Jessie 8.1 (the latest).

    Is there a way to get around the following package conflict:

    root@debaway:/home/nick/0001_PC_nick/tech/video# dpkg -i  intel-linux-graphics-installer_1.1.0-0intel1_amd64.deb
    (Reading database ... 149589 files and directories currently installed.)
    Preparing to unpack intel-linux-graphics-installer_1.1.0-0intel1_amd64.deb ...
    Unpacking intel-linux-graphics-installer (1.1.0-0intel1) over (1.1.0-0intel1) ...
    dpkg: dependency problems prevent configuration of intel-linux-graphics-installer:
     intel-linux-graphics-installer depends on libpackagekit-glib2-16 (>= 0.8.10); however:
      Package libpackagekit-glib2-16 is not installed.
    dpkg: error processing package intel-linux-graphics-installer (--install):
     dependency problems - leaving unconfigured
    Processing triggers for desktop-file-utils (0.22-1) ...
    Processing triggers for gnome-menus (3.13.3-6) ...
    Processing triggers for mime-support (3.58) ...
    Errors were encountered while processing:
     intel-linux-graphics-installer
    root@debaway:/home/nick/0001_PC_nick/tech/video# 

     

    libpackagekit-glib2-18 comes with jessie, not libpackagekit-glib2-16

    Almost certainly one cannot downgrade jessie to libpackagekit-glib2-16, so my questions are:

     

    1) Will there soon be a verion of intel-linux-graphics-installer for the newer package kit?

     

    2) Is there any way to get arround this dependancy problem until there is an upgraded intel-llinux-graphics-installer?

     

    Thanks, Nick

    Jun 28, 2015 - 05:26pm
  • You might be able to get round the dependency in question, but you're going to be better off with the approach outlined above - getting a recent kernel from bpo will get you the newest i915 driver automatically, probably even
    a newer one than you'd get from the installer - and all the packages the installer would install are built against
    the libraries in ubuntu, so you probably don't want to install those binary packages on a jessie system anyway.

    Jun 29, 2015 - 04:08pm
  • libpackagekit-glib2-16 has never been available in Debian.

    Backports is for stable users to get testing packages. In testing this problem is exactly the same: libpackagekit-glib2-16  does not exist in Debian, at all,, anywhere at any time.

     

    I am going to post a separate post about this, but intel here are OBSESSED with FORCING users to have an unstable system.  As soon as the their packages have aged enough that they will work with even Testing (forget about stable), they are deleted.  They do not have any desire, or idea, about stability.

    And they can't think that many users will not, or can not, upgrade to an ustable kernel just to have proper video drivers.

    Currently they are building against the 4.0.4 kernel. Testing is 3.16.

    Aug 11, 2015 - 05:07am
  • I'm not sure what your accusation here is, to be honest. Some points of interest:

    The backports currently target Ubuntu and Fedora, which have a different release strategy to
    Debian. It is entirely reasonabe that an approach that works for them might not fit Debian well.

    The packagekit library is required for the installer, and will be the version that's in the targeted
    version of Ubuntu or Fedora, since that's what the installer is built for. it is not a requirement
    for any of the graphics packages themselves.

    The kernel module (i915.ko) is backported from the latest intel release to the currently
    shipping kernel. That's kind of the point of these releases (again, for Ubuntu and Fedora).

    There is no obsession with forcing anyone to use anything. These are open drivers which Intel
    contribute to the mainline kernel. This little project aims to make more recent versions of said drivers
    available to a couple of distributions. Given the amount of effort involved in backporting drivers, and
    the rate at which the kernel infrastructure in this area changes, it's always going to be more
    sensible to suggest that people use a distro kernel rather than a backported module if such
    a kernel is available, hence the suggestions above: It's a better fit for the Debian release pattern
    than the installer and its accompanying backports.

    If Intel or 01.org did decide to extend official support to Debian then there would be
    a different approach, as Debian is not Ubuntu and does not follow the same (or even a similar)
    release pattern.

    Aug 11, 2015 - 05:38am