Sorry, you need to enable JavaScript to visit this website.

Intel HD Graphics Driver for Ubuntu 14.04 (Trusty Tahr)

8 posts / 0 new
Mike B.'s picture
Starter
Mike B.

Apr 20, 2014 - 02:24am

  • Hi,

    in release notes to Intel(R) Graphics Installer 1.0.4 for Linux mentioned: "Ubuntu* 14.04, "Trusty Tahr", is expected (as of writing) for release in mid-April 2014. Support for Ubuntu* 13.04 will end when 14.04 is released."

    14.04 version has been released successfully on 17 of April 2014, but no drivers are provided to the new version of Ubuntu 14.04. The main problem is that when I'm trying to install current version of driver (1.0.4) installer fails with the foillowing error: "Checking distribution... Failed".

    Is there any roadmap when new drivers will be released, bringing support of newly released Ubuntu 14.04 LTS?

    Thanks.

    Apr 20, 2014 - 02:24am
  • I am starting to wonder what the advantage of these drivers is.

    I keep having trouble with sound over HDMI with my Haswell based laptop. Intel doesn't seem to be bothered with this issue which a *lot* of people are experiencing.

    I am really dissapointed by the lack of support for this issue which has been around for a long time now.

    Apr 20, 2014 - 03:29am
  • Hi Mikeb,

    When I upgraded from 13.10 to 14.04 the other day I had problems that it seemed that my intel drivers did not install. I kept seeing the "Gallium 0.4" drivers and my FPS on games was absolutely horrible. I did a little research and it seems that there are drivers that come with the new Kernel but sometimes they don't seem to install correctly. What I did to get my intel graphics to work with 14.04 was to run the following commands in terminal:

     

    sudo apt-get install --reinstall xserver-xorg-video-intel libgl1-mesa-glx libgl1-mesa-dri xserver-xorg-core
    sudo dpkg-reconfigure xserver-xorg
    sudo update-alternatives --remove gl_conf /usr/lib/nvidia-current/ld.so.conf

     

    After I restarted my computer the System Settings-->Details started showing Sandybridge Mobile again like it did while I was running 13.10.

    I figure that should hold me until they release an installer which supports 14.04

     

     

    Apr 20, 2014 - 03:42am
  • You are using a laptop with a seperate GPU? I wonder if 14.04 recognisez my hardware correctly since I only use the integrated GPU in the Haswell CPU.

    Apr 20, 2014 - 03:45am
  • Hi Meeder,

    I'm not sure it is separate from the processor. An lspci returns  "VGA compatible controller: Intel Corporation 2nd Generation Core Processor Family Integrated Graphics Controller (rev 09)". So it seems it is integrated with my core i5 processor. I figured the problem I was having was that the upgrade screwed up the handling of the drivers, because my Xorg.0.log was saying it couldn't find the "intel" module. So I performed a reinstall as I mentioned above and that seemed to work form me.

    Apr 20, 2014 - 03:53am
  • Hi irsofty, I try to use your way to make my lenovo g400 work graphicaly speaking but i had no luck it did not work thanks any way you make me dream even if only for few minute, now i am back to my Low Graphic Mode window, we hope for a soon future

    Apr 24, 2014 - 01:21pm
  • Hi - the Intel Graphics drivers delivered by the installer are more up-to-date versions of the mainline drivers delivered by the Linux kernel and by the various distributions. As such, Ubuntu 14.04 already has a more recent
    version of the Intel driver than the update supplied to Ubuntu 13.10, so installing it won't buy you anything.

    In fact, Ubuntu 14.04 already contains the driver that is specified by the 2014-Q1 release of the Intel graphics stack, so the new installer (when released) won't be upgrading that bit of the graphics stack anyway:
    We'll mostly be shipping updated VAAPI video acceleration support (this time).

    Apr 28, 2014 - 07:58am
  • Hi guys, 

    I am new to this forum. I use a Shuttle XS35V4 machine with Ubuntu 14.04.5 server (fully updated) as a collaboration mailserver. The Shuttle is fully operational with Ubuntu and other distros.  (see link below) I have bi-weekly hangups on CPU tainted or graphics driver issue. I want to rule out the graphics part by installing the 01.org driver. I use the machine as a server, no GUI only cli. 

    Sympthoms with hanging: after 1,5-2weeks usually I see some output on the screen and few days later things with "cpu tained". Linux friend (expert) can't find it also.

    Ubuntu server 14.04.5 was installed and only the graphics driver was not from 01.org. I can't find the correct driver and don't know how i should install the driver (when found) Please help! 

    Currently uses Ubuntu i915 driver. I found the graphics-installer 1.0.7 but due to server there is no display. So I can't install. After some digging on Google it looks like Baytrail CPU is the problem. No fix available.

    XS35V4
    00:02.0 VGA compatible controller: Intel Corporation Atom Processor Z36xxx/Z37xxx Series Graphics & Display (rev 0c)

    http://faq.shuttle.eu/faq:software:linux_compatibility#fn__4

    Feb 24, 2018 - 02:49am
  • And this  behavior is with the latest kernel as well? Can you share your kernel version?. 

    Feb 28, 2018 - 02:30pm